• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

VoLTE and VoWIFI in Australia

Search This thread

BigRed0592

New member
Jun 2, 2021
2
2
5G working great on IN2020 CN Global Rom on 11.0.2.2, Telstra network, thanks to happiboi's instructions. Not able to get VoLTE and VoWiFi working though, not sure why.

Had to roll back initially as 5G and VoLTE and VoWiFi not working on latest update 11.0.6.6.

Will stay on 11.0.2.2 until PDC and EFSExplorer issues are fixed.

Thanks a lot happiboi.

EDIT: Figured out how to enable VoLTE and VoWiFi on 11.0.2.2 without root, did some searching on other sites.

1. Download and install this older version of the LogKit https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk

2. Go to phone app and dial *#800#

3. Scroll down to Function Switch and tick the boxes next to VoLTE and VoWiFi then reboot phone.

4. Should now be working, if not then go into SIM settings on phone and check the VoLTE and Wi-Fi Calling toggles are on. Also make sure the icons are toggled on in the Icon Manager section in phone settings.

Tested with my mate next to me and the icons stayed on throughout both calls!.
 
Last edited:
  • Like
Reactions: Talysdaddy

happiboi

Senior Member
Aug 27, 2010
761
244
OnePlus 8 Pro
5G working great on IN2020 CN Global Rom on 11.0.2.2, Telstra network, thanks to happiboi's instructions. Not able to get VoLTE and VoWiFi working though, not sure why.

Had to roll back initially as 5G and VoLTE and VoWiFi not working on latest update 11.0.6.6.

Will stay on 11.0.2.2 until PDC and EFSExplorer issues are fixed.

Thanks a lot happiboi.

EDIT: Figured out how to enable VoLTE and VoWiFi on 11.0.2.2 without root, did some searching on other sites.

1. Download and install this older version of the LogKit https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk

2. Go to phone app and dial *#800#

3. Scroll down to Function Switch and tick the boxes next to VoLTE and VoWiFi then reboot phone.

4. Should now be working, if not then go into SIM settings on phone and check the VoLTE and Wi-Fi Calling toggles are on. Also make sure the icons are toggled on in the Icon Manager section in phone settings.

Tested with my mate next to me and the icons stayed on throughout both calls!.
glad it's now working for you mate.


yea - I kinda overlooked that logkit part as most have here have been on kind of a journey with this process and had done the logkit + toggles part earlier. I might add a link in the post to a previous post to remember to do that logkit bit for new comers.
 
Feb 11, 2016
27
12
Just a data point - 1+ 6T:

This 'hack' is now completely breaking my data connection (Telstra - rural/regional Victoria). As per here:

I was using Network Cell Info.

I was trying unsuccessfully to use any data, for ages, up arrow was lit as the phone was requesting data, no data would come down though. Could see B28 was all that was visible in Network Cell Info. As soon is I was within range of B3 (1800) or others, everything would work and the VoLTE symbol would appear or when the phone dropped to B5 UMTS all was good. 30+ ASU signal strength B28 was totally unusable for long extended periods over large spans of distance (wasn't just a single tower with issues).

I tried rotating through APNs and resetting them to default. Nothing helped the B28. As soon as I climbed a really big rock while camping, the VoLTE symbol lit up as the B3 connected and I was pulling 10-20mbit/s very nicely. Did not manage to pull a single KB of data while in B28 only areas even though I had no trouble 'seeing' it.

Exact model of 6T is A6010. Had friends in the same vehicle that had coverage almost 100% of the time with Optus whereas I had nothing most of the time except when in the actual towns.

This may be because the UMTS is gradually being repurpsed - I dunno.

But with the phone operational on SIM1, and this 'hack' placed on SIM1 [only] I can get VoLTE & VoWiFi without a problem, but mobile data is basically not operational OR;

when SIM card placed in slot SIM2, SIM2 Mobile data works as it should, but no VoLTE or VoWiFi.

HTH someone else...
 

DaveC24

New member
Jul 14, 2021
2
1
Hey guys,
I've heard that 5G was initially functioning on these but an update broke it? If I buy a Oneplus 9 Pro (US version) does anyone know what version it comes with out of the box? Can I just avoid updating it to not break the 5G?
 
Hey guys,
I've heard that 5G was initially functioning on these but an update broke it? If I buy a Oneplus 9 Pro (US version) does anyone know what version it comes with out of the box? Can I just avoid updating it to not break the 5G?
Hey DaveC24,

I can confirm running the latest version of OOS on my UK variant 9pro and following this guide still works flawlessly. Getting volte, vowifi, and 5g on the telstra network.
 

Attachments

  • Screenshot_20210714-200206.jpg
    Screenshot_20210714-200206.jpg
    192.4 KB · Views: 12
  • Screenshot_20210714-192036.jpg
    Screenshot_20210714-192036.jpg
    310.2 KB · Views: 13
Hey guys,
I've heard that 5G was initially functioning on these but an update broke it? If I buy a Oneplus 9 Pro (US version) does anyone know what version it comes with out of the box? Can I just avoid updating it to not break the 5G?
Hey DaveC24,

I can confirm running the latest version of OOS on my UK variant 9pro and following this guide still works flawlessly. Getting volte, vowifi, and 5g on the telstra network.
 
  • Like
Reactions: happiboi
Am I better off with the UK variant or is the US one fine?
From my research the UK variant is the best variant for Australia due to it supporting all the Australian bands. US one will still work but won't support all the bands used here so therefore you may result in slower speeds, or worse coverage in certain areas.


This post has a list of all the bands used in Aus and I then just compare to each variant on gsmarena as to which version suits best.

US version also doesn't support dual sim if that matters to you.
 

MrPariah

Senior Member
Jul 15, 2018
66
8
@happiboi

Hi mate, appreciate your amazing efforts in this thread to help us aussies get volte on our Oneplus phones.

I've just ordered my first oneplus phone (8T UK Variant)

I'm just replying to ask if the method you outlined in page 2 of this thread is still the go to method to enable both volte and vowifi on the 8T I'd be receiving?

Thanks for your help!
 
@happiboi

Hi mate, appreciate your amazing efforts in this thread to help us aussies get volte on our Oneplus phones.

I've just ordered my first oneplus phone (8T UK Variant)

I'm just replying to ask if the method you outlined in page 2 of this thread is still the go to method to enable both volte and vowifi on the 8T I'd be receiving?

Thanks for your help!
Hey MrPariah,

The most up to date method for Android 11 is outlined in happibois post on page 9.

Good luck :)
 
  • Like
Reactions: MrPariah
Hey @mhall156

Where does he get EFS Explorer? Is that an application on the phone or on the computer?

Also does it need root permissions?


thanks!
Hey Mate,

EFS Explorer is part of the QPST suite which also includes PDC.

Here is the link to download the suite itself, its a suite of programs for the PC.
You will also need ADB installed on your PC, here is a guide for this; https://www.xda-developers.com/install-adb-windows-macos-linux/

This method does not require root, the only other thing required is to actually enable the toggles with the old oneplus logkit which is linked here; https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk
@BigRed0592 explains this process at the top of this page.

Let me know if you have any other questions!
 
  • Like
Reactions: MrPariah
Oct 11, 2018
48
16
Hey Old Man,

what update did you get? i've checked a few times on mine and haven't seen any newer updates come through yet?
G'Day Happiboi

It was/is a security update for July I think. I'm loathe to download and open it again..... Rolled back and followed your instructions again. All good.

Of course I could have stuffed up after the download as I woke though the night pressed the update and went through your instructions pre coffee in the morning!!
 
  • Haha
Reactions: happiboi

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    hey everyone wanted to update that i've got 5g+volte+vowifi working on my OnePlus 8 now!! (with Optus). thanks to all the contributors on this thread, it's been a massive help

    sharing some of the steps i took/things i learnt along the way:

    1. reinstalled the qualcomm drivers here (https://gsmusbdriver.com/install-qualcomm-usb-driver) as suggested by mhall156 (didn't have to uninstall anything)

    2. reinstalled the oneplus drivers provided in the youtube video:
    (this seemed to fix the "**** connect to device" error in PDC i was facing previously. Again, didn't have to uninstall anything)

    3. this one might be obvious to most but to replace the ims and policy xml files is just a matter of deleting the existing files and uploading the files provided. i kept trying to overwrite the current files somehow - silly me. (also didn't have to change anything in the xml files even on optus network).

    4. also if you got an error while your phone was in the "adb reboot ftm" mode, just do a fast reboot by holding the power button and volume up button simultaneously.

    5. remember to contact your carrier to enable 5g/volte. after i completed all the steps, it was still not working for me. turns out the 5g/volte services aren't activated by default and i had to contact optus chat to request these services to be enabled

    hope this helps someone and i'm off to enjoy what feels like a brand new device now :)
  • 8
    Here's the screenshot & writeup of what I did:

    Here is some screenshots of 5G reception, VoLTE icon, VoWiFi icon & VoWiFi Calling while in aeroplane mode to confirm all these things are working!
    https://imgur.com/a/tau5wyX

    So what did I do? All credits go to this guy on XDA to get VoLTE & VoWiFi working: https://forum.xda-developers.com/rog-phone-2/how-to/guide-enabling-volte-vowifi-v2-t4028073

    For the TL;DR version, I did what I mentioned previously to get 5G going here:
    https://forums.oneplus.com/threads/...pro-in-australia.1225092/page-2#post-21673760
    https://forums.oneplus.com/threads/...pro-in-australia.1225092/page-3#post-21717398

    Then to get VoLTE & VoWiFi working download these files:
    EFS zip - https://drive.google.com/open?id=1PiVhB35MPx19sxqxQ4svgOvPXL1dxobt
    MBNs zip - https://drive.google.com/open?id=1v8V281EkYGI_C1KeMqVni8L2qjQLdx5P
    EfsTools 0.10 modded 1.2 - https://github.com/HomerSp/EfsTools...modded-1.2/EfsTools-0.10-modded-1.2-win32.zip
    EfsTools 0.10 modded 1.1 - https://github.com/HomerSp/EfsTools...modded-1.1/EfsTools-0.10-modded-1.1-win32.zip

    The reason I've linked both modded 1.1 & 1.2 is because 1.2 is the latest version and supports activation of 2nd SIM slot (but it errors for me so I used the modded 1.1 version but that only does SIM slot 1).

    So steps:
    - Enable the VoLTE/VoWiFi toggles first:
    - Download the OnePlus Log Kit app’s APK from > https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk
    -Install the OnePlus Log Kit APK
    - Open dialer, type in *#800# (If this doesn't do anything, just google search "Oneplus engineer mode apk", download and install it. Then retry)
    - Click 'Enter' on the warning
    - Select 'oneplus Logkit'
    - Scroll down & select 'Function Switch'
    - tick the VoLTE & VoWiFi switch options
    - Then reboot.
    - when your phone comes back after restart, in Settings > Wifi & network > SIM & network > SIM1 (and SIM2) > you should now see the 'Enhanced communications' area have the option to toggle on VoLTE/VoWiFi

    Onto the actual making VoLTE/VoWiFi work:
    - Unzip EfsTools into a directory
    - Open command window on PC & navigate to the directory created in above step
    - On your phone, go to dialer, type in *#801# - enter into it via 'engineer mode'
    - Select "Rndis, diag switch" - ON (last time we selected "full port switch on")
    - Then in the command window, you should be able to test connection to EFStools by typing "EfsTools.exe efsInfo"
    - This should give some info & not any errors (mine was like 2 lines of information)
    - Then the real fun begins.
    - Extract the efs.zip from above download into the same directory as the EFStools (make sure the mcfg_autoselect_by_uim file is there - yes it's 0 bytes) and then run 2 commands:
    - EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    - EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1 (this one I couldn't get working - it's for SIM slot 2 & only works if usinf modded 1.2 version)
    - should see 0 errors
    - then open the MBNs zip & look for your carrier file. Ours are \aunz\<your carrier - e.g. mine is Telstra>\commerci\mcfg_sw.mbn
    - copy this mbn file to the same dir as the EFStools, then run 2 commands:
    - EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    - EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1 (again this one I couldn't get working - it's for SIM slot 2 & only works if usinf modded 1.2 version)
    - If it worked your screen should spew out a load of output but no errors.
    - Reboot your phone & if you already enabled the switches from my above mentioned post, you should see the VoLTE/VoWiFi icons like in the screenshots linked above.

    Seems like a lot but that's literally step by step explanation & takes roughly 5-10 mins to do slowly.

    Happy days - 5G, VoLTE & VoWiFi all working on our OnePlus 8 Pro =)
    7
    Well this is awesome! Thanks for everyone's research - I now have 5G + VoLTE + VoWiFi all working on my OnePlus 8 Pro (IN2020 model) on Android 11 (OOS 11.0.2.2) on the Telstra network.


    For some weird reason though, the "Telefonica_UK_Commercial" profile via PDC wouldn't give me 5G. Upon further investigation, I found that this profile + the carrier_policy.xml - didn't have the right config for my IN2020 phone.


    Subsequently modified the carrier_policy.xml file further and BOOM! 5G is back. Researching the carrier_policy XML further - instead of specific band enabling per the previous config - I edit it to be 'hardware' so that whatever the hardware supports, it will be made available.


    Anyhoo, long story short it's all working again thanks to you wonderful people :)


    Summary of steps taken:

    Code:
    Prerequisites:
    * Need ADB suite available on PC & enabled "ADB debugging" on phone via developer options
    * When you permit your PC adb access to the phone after first adb command, make sure you tick always permit this device. When the phone boots after "adb reboot ftm", the screen is inactive so you can't authorize the device when you try to adb shell and are stuck
    * Need QPST suite of apps installed on PC (needed PDC tools + EFS explorer)
    * If on custom firmware - probably a good idea to backup your phone before you do this. On custom firmware after the first "adb reboot ftm" rebooting again puts the device in a boot loop until you format data
    * You'll also need to ensure the toggles are enabled for VoLTE/VoWiFi before heading down this path too:
        - Enable the VoLTE/VoWiFi toggles first:
            - Download the OnePlus Log Kit app’s APK from > https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk
            - Install the OnePlus Log Kit APK
            - Open dialer, type in *#800# (If this doesn't do anything, just google search "Oneplus engineer mode apk",                      download and install it. Then retry)
            - Click 'Enter' on the warning
            - Select 'oneplus Logkit'
            - Scroll down & select 'Function Switch'
            - tick the VoLTE & VoWiFi switch options
            - Then reboot.
            - when your phone comes back after restart, in Settings > Wifi & network > SIM & network > SIM1 (and SIM2) >                 you should now see the 'Enhanced communications' area have the option to toggle on VoLTE/VoWiFi
    
    
    Then continue onto the main process:
    - Open command prompt on PC & navigate to where your ADB suite is located
    
    - Type command without "":
        "adb devices" (I like to do this to ensure adb can speak with phone/computer)
    
    - Should display:
        List of devices attached
        <if working, your device should be listed here (else, it'll be blank)>
    
    - Type command without "":
        "adb reboot ftm"
        --> This puts phone into field test mode
    
    - Type command without "":
        "adb shell"
        --> Creates dialogue for shell command on phone
    
    - In the shell (OnePlus8Pro:/ $ ) type command without "":
        "setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb"
        --> This opens up ports that we used to be able to in Android 10
    
    - Phone Screen is still blank - but it's OK.
    
    - Start up PDC Tool in Admin mode on PC
    
    - Click drop down, select phone connection (there's only 1 in the list)
    --> **  If the drop-down box is empty and no phone/device listed, you cannot proceed.
    --> ** Other users have foudn this to be related to a Qualcomm driver issue.
    --> ** Delete the drivers you have currently installed and get a new one from here:
    --> **      https://gsmusbdriver.com/install-qualcomm-usb-driver.
    --> **  Also once the device shows up in PDC don't click on it, open efs explorer and let it start searching directories --> ** before going back to PDC and clicking on the device in the drop down.
    --> ** The window may say 'not responding' just leave it until the carrier list populates then carry on with below steps
    
    - Do the profile activation stuff for Telefonica_UK_Commercial:
        - Look for "Telefonica_UK_Commercial", right click and SetSelectedConfig for both Sub0 and Sub1
        - Click on the above profile again and click on Activate
        - Do not restart your phone
    
    - Don't close PDC yet (don't know if it make a difference but I didn't close)
    
    - Open EFS Explorer (I opened in Admin mode too)
    
    - Navigate to "\nv\item_files\ims\"
        - Replace ims_user_agent file with one supplied
        --> The supplied one has Telstra VoLTE Qualcomm as header instead of Telefonica
    
    - Navigate to "\policyman"
        - Replace carrier_policy.xml & carrier_policy.xml_Subscription01 with ones supplied.
        --> Just take carrier_policy.xml and make a copy named "carrier_policy.xml_Subscription01"
        --> ** Caveat, I further modified the carrier_policy.xml file as it wasn't enabling 5G for me on my IN2020 (Android 11) Oneplus 8 Pro.
        --> ** I changed the nr5g_sa_bands base & nr5g_nsa_bands base values to be "hardware" rather than specifically band n78.
        --> ** This changes config to allow whatever 5G bands the hardware has available rather than specific bands
        --> ** You can't enable bands that the hardware doesn't support anyway so makes sense to enable all
        --> ** This gave me the needed 5G access with Telstra
    
    - Type command without "":
        "adb reboot"
    
    After phone boots back up, 5G + VoLTE + VoWiFi are all intact and in working order!

    Again, thank you to everyone's research and efforts to get this all working!

    @Mattycee have you given this a go yet ?
    3
    Well this is awesome! Thanks for everyone's research - I now have 5G + VoLTE + VoWiFi all working on my OnePlus 8 Pro (IN2020 model) on Android 11 (OOS 11.0.2.2) on the Telstra network.


    For some weird reason though, the "Telefonica_UK_Commercial" profile via PDC wouldn't give me 5G. Upon further investigation, I found that this profile + the carrier_policy.xml - didn't have the right config for my IN2020 phone.


    Subsequently modified the carrier_policy.xml file further and BOOM! 5G is back. Researching the carrier_policy XML further - instead of specific band enabling per the previous config - I edit it to be 'hardware' so that whatever the hardware supports, it will be made available.


    Anyhoo, long story short it's all working again thanks to you wonderful people :)


    Summary of steps taken:

    Code:
    Prerequisites:
    * Need ADB suite available on PC & enabled "ADB debugging" on phone via developer options
    * Need QPST suite of apps installed on PC (needed PDC tools + EFS explorer)
    
    Process:
    - Open command prompt on PC & navigate to where your ADB suite is located
    
    - Type command without "":
        "adb devices" (I like to do this to ensure adb can speak with phone/computer)
    
    - Should display:
        List of devices attached
        <if working, your device should be listed here (else, it'll be blank)>
    
    - Type command without "":
        "adb reboot ftm"
        --> This puts phone into field test mode
    
    - Type command without "":
        "adb shell"
        --> Creates dialogue for shell command on phone
    
    - In the shell (OnePlus8Pro:/ $ ) type command without "":
        "setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb"
        --> This opens up ports that we used to be able to in Android 10
    
    - Phone Screen is still blank - but it's OK.
    
    - Start up PDC Tool in Admin mode on PC
    
    - Click drop down, select phone connection (there's only 1 in the list)
    
    - Do the profile activation stuff for Telefonica_UK_Commercial:
        - Look for "Telefonica_UK_Commercial", right click and SetSelectedConfig for both Sub0 and Sub1
        - Click on the above profile again and click on Activate
        - Do not restart your phone
    
    - Don't close PDC yet (don't know if it make a difference but I didn't close)
    
    - Open EFS Explorer (I opened in Admin mode too)
    
    - Navigate to "\nv\item_files\ims\"
        - Replace ims_user_agent file with one supplied
        --> The supplied one has Telstra VoLTE Qualcomm as header instead of Telefonica
    
    - Navigate to "\policyman"
        - Replace carrier_policy.xml & carrier_policy.xml_Subscription01 with ones supplied.
        --> ** Caveat, I further modified the carrier_policy.xml file as it wasn't enabling 5G for me on my IN2020 (Android 11) Oneplus 8 Pro.
        --> ** I changed the nr5g_sa_bands base & nr5g_nsa_bands base values to be "hardware" rather than specifically band n78.
        --> ** This changes config to allow whatever 5G bands the hardware has available rather than specific bands
        --> ** You can't enable bands that the hardware doesn't support anyway so makes sense to enable all
        --> ** This gave me the needed 5G access with Telstra
    
    - Type command without "":
        "adb reboot"
    
    After phone boots back up, 5G + VoLTE + VoWiFi are all intact and in working order!

    Again, thank you to everyone's research and efforts to get this all working!

    @Mattycee have you given this a go yet ?


    Well this is awesome! Thanks for everyone's research - I now have 5G + VoLTE + VoWiFi all working on my OnePlus 8 Pro (IN2020 model) on Android 11 (OOS 11.0.2.2) on the Telstra network.


    For some weird reason though, the "Telefonica_UK_Commercial" profile via PDC wouldn't give me 5G. Upon further investigation, I found that this profile + the carrier_policy.xml - didn't have the right config for my IN2020 phone.


    Subsequently modified the carrier_policy.xml file further and BOOM! 5G is back. Researching the carrier_policy XML further - instead of specific band enabling per the previous config - I edit it to be 'hardware' so that whatever the hardware supports, it will be made available.


    Anyhoo, long story short it's all working again thanks to you wonderful people :)


    Summary of steps taken:

    Code:
    Prerequisites:
    * Need ADB suite available on PC & enabled "ADB debugging" on phone via developer options
    * Need QPST suite of apps installed on PC (needed PDC tools + EFS explorer)
    
    Process:
    - Open command prompt on PC & navigate to where your ADB suite is located
    
    - Type command without "":
        "adb devices" (I like to do this to ensure adb can speak with phone/computer)
    
    - Should display:
        List of devices attached
        <if working, your device should be listed here (else, it'll be blank)>
    
    - Type command without "":
        "adb reboot ftm"
        --> This puts phone into field test mode
    
    - Type command without "":
        "adb shell"
        --> Creates dialogue for shell command on phone
    
    - In the shell (OnePlus8Pro:/ $ ) type command without "":
        "setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb"
        --> This opens up ports that we used to be able to in Android 10
    
    - Phone Screen is still blank - but it's OK.
    
    - Start up PDC Tool in Admin mode on PC
    
    - Click drop down, select phone connection (there's only 1 in the list)
    
    - Do the profile activation stuff for Telefonica_UK_Commercial:
        - Look for "Telefonica_UK_Commercial", right click and SetSelectedConfig for both Sub0 and Sub1
        - Click on the above profile again and click on Activate
        - Do not restart your phone
    
    - Don't close PDC yet (don't know if it make a difference but I didn't close)
    
    - Open EFS Explorer (I opened in Admin mode too)
    
    - Navigate to "\nv\item_files\ims\"
        - Replace ims_user_agent file with one supplied
        --> The supplied one has Telstra VoLTE Qualcomm as header instead of Telefonica
    
    - Navigate to "\policyman"
        - Replace carrier_policy.xml & carrier_policy.xml_Subscription01 with ones supplied.
        --> ** Caveat, I further modified the carrier_policy.xml file as it wasn't enabling 5G for me on my IN2020 (Android 11) Oneplus 8 Pro.
        --> ** I changed the nr5g_sa_bands base & nr5g_nsa_bands base values to be "hardware" rather than specifically band n78.
        --> ** This changes config to allow whatever 5G bands the hardware has available rather than specific bands
        --> ** You can't enable bands that the hardware doesn't support anyway so makes sense to enable all
        --> ** This gave me the needed 5G access with Telstra
    
    - Type command without "":
        "adb reboot"
    
    After phone boots back up, 5G + VoLTE + VoWiFi are all intact and in working order!

    Again, thank you to everyone's research and efforts to get this all working!

    @Mattycee have you given this a go yet ?

    For some weird reason though, the "Telefonica_UK_Commercial" profile via PDC wouldn't give me 5G. Upon further investigation, I found that this profile + the carrier_policy.xml - didn't have the right config for my IN2020 phone.


    Subsequently modified the carrier_policy.xml file further and BOOM! 5G is back. Researching the carrier_policy XML further - instead of specific band enabling per the previous config - I edit it to be 'hardware' so that whatever the hardware supports, it will be made available.


    Anyhoo, long story short it's all working again thanks to you wonderful people :)


    Summary of steps taken:

    Code:
    Prerequisites:
    * Need ADB suite available on PC & enabled "ADB debugging" on phone via developer options
    * Need QPST suite of apps installed on PC (needed PDC tools + EFS explorer)
    
    Process:
    - Open command prompt on PC & navigate to where your ADB suite is located
    
    - Type command without "":
        "adb devices" (I like to do this to ensure adb can speak with phone/computer)
    
    - Should display:
        List of devices attached
        <if working, your device should be listed here (else, it'll be blank)>
    
    - Type command without "":
        "adb reboot ftm"
        --> This puts phone into field test mode
    
    - Type command without "":
        "adb shell"
        --> Creates dialogue for shell command on phone
    
    - In the shell (OnePlus8Pro:/ $ ) type command without "":
        "setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb"
        --> This opens up ports that we used to be able to in Android 10
    
    - Phone Screen is still blank - but it's OK.
    
    - Start up PDC Tool in Admin mode on PC
    
    - Click drop down, select phone connection (there's only 1 in the list)
    
    - Do the profile activation stuff for Telefonica_UK_Commercial:
        - Look for "Telefonica_UK_Commercial", right click and SetSelectedConfig for both Sub0 and Sub1
        - Click on the above profile again and click on Activate
        - Do not restart your phone
    
    - Don't close PDC yet (don't know if it make a difference but I didn't close)
    
    - Open EFS Explorer (I opened in Admin mode too)
    
    - Navigate to "\nv\item_files\ims\"
        - Replace ims_user_agent file with one supplied
        --> The supplied one has Telstra VoLTE Qualcomm as header instead of Telefonica
    
    - Navigate to "\policyman"
        - Replace carrier_policy.xml & carrier_policy.xml_Subscription01 with ones supplied.
        --> ** Caveat, I further modified the carrier_policy.xml file as it wasn't enabling 5G for me on my IN2020 (Android 11) Oneplus 8 Pro.
        --> ** I changed the nr5g_sa_bands base & nr5g_nsa_bands base values to be "hardware" rather than specifically band n78.
        --> ** This changes config to allow whatever 5G bands the hardware has available rather than specific bands
        --> ** You can't enable bands that the hardware doesn't support anyway so makes sense to enable all
        --> ** This gave me the needed 5G access with Telstra
    
    - Type command without "":
        "adb reboot"
    
    After phone boots back up, 5G + VoLTE + VoWiFi are all intact and in working order!

    Mate, you're a freaking legend. (Magisk Canary root: IN2020 / Android 11 / 11.0.2.2.IN11AA / BOOST network)

    I got abit confused with the "carrier_policy.xml_Subscription01" part as it wasn't in any of the files you provided, so just assumed I had to just copy and rename the "carrier_policy.xml".

    Also EFS explorer took a little longer than I expected to start up (~1 minute) just incase anyone thinks theirs crashes and close it prematurely.

    Worked like a charm.

    Cheers
    3
    Nah, I actually used the 'ims_user_agent' File linked above by Jaansberger.

    The only thing I used from Happyboi's original exploit, was the Engineering APK File to enable 5G. However, make sure you don't install the Engineering APK before you do the initial VoLTE/VoWi-FI Process listed above by Mike_Fre.

    So basically order of steps I followed:

    - Mike_Fre's steps to enable the 'Telefonica VoLTE Qualcomm' Profile.
    - Jannsberger's step to insall the 'ims_user_agent' file (Before doing the adb reboot step listed in Mike_Fre's Post).
    - Watched and replicated the YouTube video (Which I linked in my post above), to enable 5G and still have VoLTE/VoWi-Fi.


    Hope this clears things up for you, but if you have any further questions, I'd be happy to try and help.
    That worked perfectly!!! Thankyou!!!
    3
    We have a working solution without root that is easier than previous instructions.

    You still need the old toolkit app and #*800# to activate vowan and volte functions if you haven't done in the past.

    Follow:
    {Google Translate is your friend}

    In essence...
    Download the Qualcomm tools and drivers.
    Follow the adb instructions

    adb reboot ftm
    (wait for chinese to disappear and screen goes blank)
    adb shell
    setprop sys.usb.config diag,diag_mdm,qdss,qdss_mdm,serial_cdev,dpl,rmnet,adb

    Open the Advanced PDC tool and select the "Telefonica_UK_Commercial " (works with Vodafone, Telstra and Optus) option for sim0 and sim1. Activate.

    Do adb reboot

    Enjoy vowifi and volte.