VoLTE - Bell Mobility

Search This thread

StatikBlue

Senior Member
Jan 23, 2015
149
30
So when I first got my P20 Pro I had VoLTE enabled and working fine but one day I noticed the HD notification was missing the dialer app no longer had the HD call button. Just noticed that when I make a call my device does actually revert back to the 3G network and I can no long "multitask" online while on a call. Of course I've also lost the ability to make video calls.
I've checked the wife S7 and can still make calls over LTE with that one. So now I'm wondering if it is the Bell network or my P20 Pro? A quick check on Bell support site shows a list of devices compatible with their VoLTE, the list shows older devices but newer ones also, P20 Pro not listed. Can't see Bell deactivating VoLTE specifically for this device, or at least I'd hope not.
Anybody else on the Bell network have this happen or is VoLTE working for you? Before I factory reset I wanna know if it's just me.
FYI. Locked and stock
 
Last edited:

StatikBlue

Senior Member
Jan 23, 2015
149
30
Come on, are there no other P20 Pro users in Canada who can take a second to respond and help fellow users?
VoLTE setting is ON. Is it working for you. Do you have HD calls notification on top left, HD dial button in dialer app? When not on wifi does mobile network revert to 3G for phone calls?
Yes/No? Any info would help folks.
 

bill_in_mtl

Senior Member
Jan 26, 2008
882
254
Montreal
Working fine on Rogers

Screenshot_20181216-165650.jpeg

Sent from my CLT-L04 using Tapatalk
 
  • Like
Reactions: StatikBlue

StatikBlue

Senior Member
Jan 23, 2015
149
30
Fido told me VoLTE not supported on the P20 Pro and I've certainly never gotten it to work

That sucks since Fido is on the Rogers network and looks like it does work for Rogers users.

Notice a couple a days ago for me also on bell network not working.

I'm starting to think the Bell network (Virgin) is the culprit here and not the device (fingers crossed). Curious as to why Bell would pull VoLTE support for the P20 Pro? Hopefully ain't no political thing (lol). Wonder if it's anything to do with Pie update and compatibility. I could say I lost VoLTE on my device almost a month now. I've tried everything in the book on my end even factory reset with no resolve and am more convinced now it's happening on Bell's side on things. Which really sucks cause I hate their support system but need to contact them find out what's going on with my service.

Thanks for the answers folks. Keep them coming.
 

Cobthaich

Senior Member
May 3, 2012
59
11
I am on the Rogers network using an unlocked Bell P20 pro and do not have the VoLTE function so i wonder if it is disabled on Bell hardware?
 

tangnt

Senior Member
Oct 21, 2014
120
15
I am on the Rogers network using an unlocked Bell P20 pro and do not have the VoLTE function so i wonder if it is disabled on Bell hardware?

Google about this. Rogers and Fido do the IMEI whitelisting so if you don't buy a device from them you are out of luck
 

auto_art

Member
Jan 28, 2012
17
0
just to inform you guy, I have p20 pro telus(unlocked) I put bell sim and asked bell to enable volte. it works. and it should work on virgin too.

clt-l04 8.1.0.120(c792)
 
Last edited:

mike613ottawa

Member
Aug 28, 2009
22
1
I've been wondering the same. Got my P20 Pro with Bell a couple of weeks ago. About a week ago, I noticed "HD" at the top left of my notification bar, but it only lasted a few seconds and never returned. After that, I discovered that I'm always connected to LTE, but when I make a call it drops to 3G, and then after the call it reverts back to LTE.

When I insert the Bell SIM into my S7 Edge, it stays connected to LTE at all times.

How is it possible that it showed "HD" very briefly several days ago and never came back? Perhaps Bell was just testing HD on the network for a few minutes? I've always had VoLTE enabled in the settings.

On a somewhat unrelated note, I have two friends with an iPhone 8+, one on Rogers, the other on Bell, and they both drop to 3G when on a call.
 

Cobthaich

Senior Member
May 3, 2012
59
11
Just got of the phone with Rogers, the Support specialist tried and also followed up with their network specialist, it is a no go, this was what they said:

"Since the device is not a Rogers device it wont allow VoLTE calls and the VoLTE notification is not being pushed to this IMEI. This gets enabled on the network and since the device is not Rogers it wont allow for it to register. So just make sure when you purchase the phone its from the same carrier as the one you are looking to use as it can cause compatibility issues. All phones get a pre-configured file when they are sent to Carriers and based on the carrier provisioning of the device it becomes compatible to the network."

It looks like some of us are out of luck.
 

StatikBlue

Senior Member
Jan 23, 2015
149
30
How is it possible that it showed "HD" very briefly several days ago and never came back? Perhaps Bell was just testing HD on the network for a few minutes? I've always had VoLTE enabled in the settings.
I've had this device for about 3 months now and would say it's been about 1 month since I've lost VoLTE service

Just got off the phone with Bell support. Didn't really get anywhere as expected, other then many apologies and an open service ticket to try and find out if it's their end or the P20 Pro. Should hear back within 2 weeks. Again, as expected.
 
Last edited:

gd6noob

Senior Member
Apr 29, 2011
1,805
268
Fido sucks.. might switch to Rogers soon... my work has a ok deal.. $55/mo for 6gb and unlimited calls/text canada wide.
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone