VoLTE for Xperia Z & Xperia X series.

Search This thread

akshay2shah

Senior Member
Mar 10, 2016
733
855
Pune
Hi Guys,
After many days of search and trials I have managed to enable VoLTE in Xperia Z2 & Z3 in Android 6.0.1.
But this Method should work on Newer Z & X series models(till 2018).

Only For Xperia Z & X series


Your carrier must support VoLTE service and it should not be locked to certain devices by your carrier.
This method Only works on stock roms.
Tested and working !
Operator- Idea, Reliance Jio [India]

Thanks to @jitz975 @Dilesh Perera @kevev @tititoto


Try at your own risk.

Always make a backup of system and data before doing this in case anything goes wrong

Follow these steps, ;)

1. Root Access and Recovery are mandatory.

2. Download & flash VoLTE .zip via recovery(only for Xperia Z2 & Z3).

3. Find this line in /system/build.prop [ro.build.type=user] & change it to [ro.build.type=userdebug] then restart phone.

4. Then u have to find the modem switcher.
its in system/priv-app and its called CustomizationSelector.apk

> download Quick shortcut maker from play store
> open Quick shortcut maker to make a shortcut using the app then go to customisation Selector \ modem switcher
> open Customization Selector app and select modem according to your network operator.
> if u dont find your operator just select volte_base_operator_trials_tar.
> try other ims modems if any of these wont work.
> if it wont work even after then try another stock Android rom from xperifirm flashtool.

5.. After selecting modem, phone will restart and you are good to go.
 

Attachments

  • Screenshot_20160914-202714.png
    Screenshot_20160914-202714.png
    92.3 KB · Views: 20,252
  • Screenshot_20161229-173202.jpg
    Screenshot_20161229-173202.jpg
    70.2 KB · Views: 13,478
  • VoLTE_Xperia_Z2_Z3_D6503_D6653_Flashable.zip
    1.1 MB · Views: 12,961
Last edited:

vandiaz_sairavinz

Senior Member
Apr 29, 2014
261
145
Jakarta
Did u change overlay apps and set app permission to rwrr ??

Did u add line lines in build.prop ?

Try to switch another modem and then again switch to VoLTE modem. It works.

yes add build.prop and permission

I've tried all the same German modem ,,,
Indonesian carriers seemed not supported volte

thanks for his tutorial ...
nice :fingers-crossed:
 

Attachments

  • Screenshot_20160813-212808.png
    Screenshot_20160813-212808.png
    232.2 KB · Views: 4,601
  • Screenshot_20160813-212844.jpg
    Screenshot_20160813-212844.jpg
    194.7 KB · Views: 4,527

Dilesh Perera

Senior Member
May 26, 2012
1,796
941
Colombo
VoLTE is a Carrier dependent service. if ur carrier not supports u wont get anything other than the toggle in settings
VoLTE is one of the coolest services comes with 4G
im waiting with the toggle until my carrier launch the service :D Lol
 

Hans_Werner

Senior Member
Jul 30, 2015
92
23
Cologne
It seems not to work for me too. All settings are made exactly like in the description. Modem selected and use volte option is enabled in settings too. Carrier is Telekom_de which supports volte also volte option is enabled in contract.

Best
 

akshay2shah

Senior Member
Mar 10, 2016
733
855
Pune
It seems not to work for me too. All settings are made exactly like in the description. Modem selected and use volte option is enabled in settings too. Carrier is Telekom_de which supports volte also volte option is enabled in contract.

Best
Your carrier locked VoLTE to certain xperia model.
Cant help with that.

In your case VoLTE access is restricted from network side.
Remaining settings are correct by these method
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 48
    Hi Guys,
    After many days of search and trials I have managed to enable VoLTE in Xperia Z2 & Z3 in Android 6.0.1.
    But this Method should work on Newer Z & X series models(till 2018).

    Only For Xperia Z & X series


    Your carrier must support VoLTE service and it should not be locked to certain devices by your carrier.
    This method Only works on stock roms.
    Tested and working !
    Operator- Idea, Reliance Jio [India]

    Thanks to @jitz975 @Dilesh Perera @kevev @tititoto


    Try at your own risk.

    Always make a backup of system and data before doing this in case anything goes wrong

    Follow these steps, ;)

    1. Root Access and Recovery are mandatory.

    2. Download & flash VoLTE .zip via recovery(only for Xperia Z2 & Z3).

    3. Find this line in /system/build.prop [ro.build.type=user] & change it to [ro.build.type=userdebug] then restart phone.

    4. Then u have to find the modem switcher.
    its in system/priv-app and its called CustomizationSelector.apk

    > download Quick shortcut maker from play store
    > open Quick shortcut maker to make a shortcut using the app then go to customisation Selector \ modem switcher
    > open Customization Selector app and select modem according to your network operator.
    > if u dont find your operator just select volte_base_operator_trials_tar.
    > try other ims modems if any of these wont work.
    > if it wont work even after then try another stock Android rom from xperifirm flashtool.

    5.. After selecting modem, phone will restart and you are good to go.
    3
    Hey dude, amazing work.

    my carrer in Brazil has the WiFi calling from native but just for iphone owners, so, if your great work now a i can have this service.
    Just one question...why i need to use the google contacts? the stock one don't work? and how I select the wifi calling using google contacts?
    Stock call app doesn't have ViLTE option enabled.. Google contact has.
    2
    Can you make it @akshay2shah a flashable zip ?


    Here is a flashable zip which i made for myself.
    Device --> Xperia Z2 D6503
    2
    Which lines were edited. I'm concerned changing D6603 to something else could create issues. Thanks

    BTW was talking to T-mobile tech support that confirmed that VoLTE is working when H+ is displayed during call. It's automatic when phone support it. But I don't hear the clarity difference on calls, but have had some calls come with designation "HD call" and those sound better.
    /system/etc/customization/settings/config.prop

    ######################## Customized property values #########################

    persist.radio.enable_nw_cw=1

    ro.nfc.icon.enable=true

    persist.ro.ril.sms_sync_sending=1

    ro.nfc.se.sim.enable=true

    ro.telephony.default_network=9

    persist.radio.calls.on.ims=1

    persist.ims.volte=true

    persist.dbg.volte_avail_ovr=1

    persist.dbg.wfc_avail_ovr=1

    persist.dbg.vt_avail_ovr=1

    persist.radio.jbims=1

    Persist.ims.rcs=true

    persist.radio.RATE_ADAPT_ENABLE=1

    persist.radio.ROTATION_ENABLE=1

    persist.radio.VT_ENABLE=1

    persist.radio.VT_HYBRID_ENABLE=1

    ro.cst.prm=1281-1806:R2D

    persist.radio.ue_interrogate=0

    #############################################################################

    This enables the VoLTE and Wifi-Calling switch in phone settings app, but it is not necessary needed, it should work without, but nice to have.

    In build.prop you have to set ro.build.type to userdebug and under Customized Property Values you must change firmware version to the latest number if your provider. So it looks like you are on a branded rom. This is only version info and doesn't change anything else. You can find the latest versions in xperifirm tool.

    Of course you must now change modem to your provider version.

    This makes your provider think that you are on branded rom and are allowed to use VoLTE (but only if your provider supports VoLTE and it is part of your contract)

    Mostly providers say you must use the branded rom and it only works when you see LTE sign when making a call. You can test it by calling your providers hotline. You can also see the calling starts very fast and hear the difference in voice.

    Sent from my D6603 using XDA-Developers mobile app
    2
    Thanks! Everything looks like worked fine on my D6503 with ATT sim. However, the modem to select is the last in the list, and it is buried beneath my Back/Home/Recents soft buttons, preventing me from choosing it. The selector does not change into landscape mode in order to try that. Any workarounds?
    Dont worry ! I got u covered ?
    Follow these simple steps.

    1. Go to system/etc/customization/modem

    2. Rename any 1 modem file name starting with z
    Eg. Zamss_fsg_sirius_amr_wb_2g_tar.mbn

    3. Then restart modem switcher app.

    You are good to go ?