• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

VoLTE not working

Search This thread

elzazo

New member
Nov 25, 2020
1
2
Hi Poco X3 Users, I 've just found what you're looking for!
I live in Italy and I got the proper code to enable this stuff. Please understard that I'm translating straight from Italian phone labels, so labels may not be accurate, but are there!
1) Dial *#*#4636#*#* and an internal menu "Verify" should pop up.
2) Your "Provisioning Volte" should be toggled to Off at the moment. At this point open a new phone dialer and type *#*#86583#*#* and an on screen label should come (ignore it because it seems to say the opposite).If you now go back to the Verify menu it should tell you that the Provisioning volte is On, although it's still grey.
2.1) Since you're fixing stuff, dial *#*#869434#*#* so that you can enable calls over Wifi as well.
2.2) Since Poco X3 supports Dual Volte if you own two SIMs with two Volte Carriers enable the other one as well, repeating the steps on point 2)
3) Go to Sim Cards and mobile networks --> Go to the SIM you're using (one of the upper big boxes) --> You should now see a new option "Use VoLTE", already enabled.
You should see an option to enable Calls over Wifi as well, with a preference over Wifi or Mobile Network.

Strange thing I've checked with a test call and it does not say HD, but the guy with the other phone got the signal bars with the "LTE" label on it.I'll do other tests and I'll get back with the result.
You're done! I have screenshots of the entire procedure if you want. Hope this helped!


Bye
 
Last edited:

pak lah

Member
Aug 13, 2008
36
9
Hi Poco X3 Users, I 've just found what you're looking for!
I live in Italy and I got the proper code to enable this stuff. Please understard that I'm translating straight from Italian phone labels, so labels may not be accurate, but are there!
1) Dial *#*#4636#*#* and an internal menu "Verify" should pop up.
2) Your "Provisioning Volte" should be toggled to Off at the moment. At this point open a new phone dialer and type *#*#86583#*#* and an on screen label should come (ignore it because it seems to say the opposite).If you now go back to the Verify menu it should tell you that the Provisioning volte is On, although it's still grey.
2.1) Since you're fixing stuff, dial *#*#869434#*#* so that you can enable calls over Wifi as well.
2.2) Since Poco X3 supports Dual Volte if you own two SIMs with two Volte Carriers enable the other one as well, repeating the steps on point 2)
3) Go to Sim Cards and mobile networks --> Go to the SIM you're using (one of the upper big boxes) --> You should now see a new option "Use VoLTE", already enabled.
You should see an option to enable Calls over Wifi as well, with a preference over Wifi or Mobile Network.

Strange thing I've checked with a test call and it does not say HD, but the guy with the other phone got the signal bars with the "LTE" label on it.I'll do other tests and I'll get back with the result.
You're done! I have screenshots of the entire procedure if you want. Hope this helped!


Bye


Works like a charm
 

Attachments

  • Screenshot_2020-12-15-20-24-09-728_com.android.phone.jpg
    Screenshot_2020-12-15-20-24-09-728_com.android.phone.jpg
    201.5 KB · Views: 304

e20140

Senior Member
May 12, 2009
324
70
That screenshot means nothing and you are on 3G, you are not getting Volte. Most users already tried this method which only works on some Mi devices such as Note 8 Pro. I am looking at buying Poco X3 but need a solution to the Volte issue. I see others need to root and use PDC to change modem profile which I don't want to do to a new phone.
 

e20140

Senior Member
May 12, 2009
324
70
Ok I think I figured out how I got it to work mine does say HD on calls and sounds great. I unlocked the bootloader and rooted with Magisk what I had forgot and forgot to mention here was I went into the vold.fstab I think and changed the setting from False to true. My wife is having the same issue with her Mi Note 9 Pro and I am going to unlock it this weekend and root it and I will confirm which setting to change.
Will be interested to your finding, please share with step by step instruction. I am still debating to buy Poco X3 or Note 9 Pro
 

pak lah

Member
Aug 13, 2008
36
9
That screenshot means nothing and you are on 3G, you are not getting Volte. Most users already tried this method which only works on some Mi devices such as Note 8 Pro. I am looking at buying Poco X3 but need a solution to the Volte issue. I see others need to root and use PDC to change modem profile which I don't want to do to a new phone.

Hahah sometimes my connection drops
 

Attachments

  • Screenshot_2020-12-18-19-50-53-310_com.android.phone.jpg
    Screenshot_2020-12-18-19-50-53-310_com.android.phone.jpg
    216.6 KB · Views: 119

e20140

Senior Member
May 12, 2009
324
70
It might be working for you and that's good, but that's not how to find out if you have Volte. If the dialer doesn't show HD when making calls or no Volte Icon as in your screenshot, that's the 1st sign that U are not getting it. To find out for sure, make a phone call and go check the phone SIM status from the phone setting menu. I've Redmi Note 7 and too have those 2 screen you posted plus I even have 4G icon when making calls but I am not getting Volte.
For us in the USA, it seems the only option is to root and use PDC via QPST to reprogram the modem. Sad! I am still hoping someone find another solution.
 

adambomb_13

Senior Member
Jul 17, 2007
270
49
I'm sorry guys I am using metro by TMobile I did have it working the calls said HD and the signal stayed at volte it no longer dropped to h or 3g I just reset my network setting and bang no more Volte now back to instant hang up the minute I call I have tried everything I did that I can think of when I got it working and no dice I did flash a universal Volte fix It said Volte in the build prop which is what I thought fixed it before but it is no longer there and now I somehow wiped my build prop blank. It does work and there is a way to fix it just not exactly sure how yet. But I did it once so I can do it again and when I do I will let you guys know
 

adambomb_13

Senior Member
Jul 17, 2007
270
49
Ok I figured out something new and it may be why some people can make calls and some can't. I must have changed a setting before that fixed it and changed it back when I did a network reset
I can make calls in HD as long as I do not use the 3 digit area code. If I use only 7 digits for the number it works and if I use 9 it fails...
Anyone know why? I can't help but feel like I am so close to solving this issue....
I would really hate to have to change all my contacts :)
 

adambomb_13

Senior Member
Jul 17, 2007
270
49
Ok I figured out something new and it may be why some people can make calls and some can't. I must have changed a setting before that fixed it and changed it back when I did a network reset
I can make calls in HD as long as I do not use the 3 digit area code. If I use only 7 digits for the number it works and if I use 9 it fails...
Anyone know why? I can't help but feel like I am so close to solving this issue....
I would really hate to have to change all my contacts :)
I figured it out my contacts that were moved to this phone have a +1 added remove that and should work
 

adambomb_13

Senior Member
Jul 17, 2007
270
49
PROBLEM SOLVED:
Sorry for spamming but after noticing no one on the internet has a fix for this and after countless failed attempts the answer is simple it is the country code and area code causing the issue. I was also able to fix my wife's mi note 9 pro the same way make sure you have roaming for area codes and remove any country codes from your contacts.
To test dial a number local to you that is not in your contacts. Make sure VOLTE is turned on and only dial the 7 main digits of the number (no country code exe. +1 and no area code exe. (202) only exe.
555-5555) the call should now work.
Hope this helped you guys, if so post here to confirm so others know it is the solution and maybe the admins can move this to the OP thanks
 

e20140

Senior Member
May 12, 2009
324
70
PROBLEM SOLVED:
....
To test dial a number local to you that is not in your contacts. Make sure VOLTE is turned on and only dial the 7 main digits of the number (no country code exe. +1 and no area code exe. (202) only exe.
555-5555) the call should now work.
Hope this helped you guys, if so post here to confirm so others know it is the solution and maybe the admins can move this to the OP thanks
I don't have a Poco X3 yet, but I have the same issue with my Redmi Note 7.
Question: Did U gone thru root and QPST route and still didn't work?
No root, just dialing *#*#86583#*#*, I noticed that simply removing "+1" works as I was wondering why some number works and others don't on Mint Mobile. When I use TruConnect (both are on T-Mobile Network), it simply works. Also did a troubleshooting with a Mint tech and he's sending me a new SIM as my SIM is close to 3 years old. I'll update when the new SIM arrive.
 

adambomb_13

Senior Member
Jul 17, 2007
270
49
I don't have a Poco X3 yet, but I have the same issue with my Redmi Note 7.
Question: Did U gone thru root and QPST route and still didn't work?
No root, just dialing *#*#86583#*#*, I noticed that simply removing "+1" works as I was wondering why some number works and others don't on Mint Mobile. When I use TruConnect (both are on T-Mobile Network), it simply works. Also did a troubleshooting with a Mint tech and he's sending me a new SIM as my SIM is close to 3 years old. I'll update when the new SIM arrive.
No root needed fixed my wife's redmi note 9 pro no root with locked bootloader
 

e20140

Senior Member
May 12, 2009
324
70
The new SIM from Mint Mobile doesn't help. I discovered all you need to do is remove "+" in front of the phone number and Volte calls will go through. Now I got to go through all my contacts, so werid!
 

e20140

Senior Member
May 12, 2009
324
70
@adambomb, I talk too soon, I think you are right, removing "+" only works occasionally. How do you call someone with a different area code? If I toggle the Volte option, all calls without the "+" works. So confusing
 
Last edited:

adambomb_13

Senior Member
Jul 17, 2007
270
49
@adambomb, I talk too soon, I think you are right, removing "+" only works occasionally. How do you call someone with a different area code? If I toggle the Volte option, all calls without the "+" works. So confusing
I am fairly certain you have to have roaming on for all calls to work. At first I had to remove the +1 and the area codes but once I turned on roaming only had to remove the +1 then area codes work.
This is obviously a bug that xiaomi is not aware of because Europon numbers do not work this way. They really need to be made aware and do a mass update as I am sure they lose a ton of American customers and soon most carriers will only use VOLTE if they don't fix this simple issue they will regret it for sure..
 

jefffrom

Senior Member
Oct 19, 2016
227
64
think its working after I choose prefered network type to gsm only but it did not stick and reverted back and followed the codes above during the call i see nothing about HD in dialer though using Tello piggybacks off T-mobile USA Chicago area one thing I noticed in the second picture VoLTE provisioned should state its on correct?

update not working very poor network data speeds going to return this :(
 

Attachments

  • 1 (1).jpg
    1 (1).jpg
    157.9 KB · Views: 51
  • 1 (2).jpg
    1 (2).jpg
    282.5 KB · Views: 52
  • 1 (3).jpg
    1 (3).jpg
    258.4 KB · Views: 53
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi Poco X3 Users, I 've just found what you're looking for!
    I live in Italy and I got the proper code to enable this stuff. Please understard that I'm translating straight from Italian phone labels, so labels may not be accurate, but are there!
    1) Dial *#*#4636#*#* and an internal menu "Verify" should pop up.
    2) Your "Provisioning Volte" should be toggled to Off at the moment. At this point open a new phone dialer and type *#*#86583#*#* and an on screen label should come (ignore it because it seems to say the opposite).If you now go back to the Verify menu it should tell you that the Provisioning volte is On, although it's still grey.
    2.1) Since you're fixing stuff, dial *#*#869434#*#* so that you can enable calls over Wifi as well.
    2.2) Since Poco X3 supports Dual Volte if you own two SIMs with two Volte Carriers enable the other one as well, repeating the steps on point 2)
    3) Go to Sim Cards and mobile networks --> Go to the SIM you're using (one of the upper big boxes) --> You should now see a new option "Use VoLTE", already enabled.
    You should see an option to enable Calls over Wifi as well, with a preference over Wifi or Mobile Network.

    Strange thing I've checked with a test call and it does not say HD, but the guy with the other phone got the signal bars with the "LTE" label on it.I'll do other tests and I'll get back with the result.
    You're done! I have screenshots of the entire procedure if you want. Hope this helped!


    Bye
    1
    Remove the +1 from the phone numbers in your contacts and make sure roaming is on. Worst case scenario only use 7 digits