Question Volte

Search This thread

Shipoftheline

Senior Member
Oct 6, 2015
868
362
Salford
Google Pixel 6 Pro
Has anyone had this working yet, does it even have an icon to show its on because my network provided said the Pixel 6 has no option in the menu, does it even show on the phone if its working/on?
 

PhilipL2021

Senior Member
Oct 27, 2021
125
66
VoLTE is working fine with EE in the UK. There are no signs it is working from what I can see, except for the fact it stays on 4G rather than drop to 3G. I've had HD calls (shows the tiny HD icon when the call connects) on 4G as well.
 

Shipoftheline

Senior Member
Oct 6, 2015
868
362
Salford
Google Pixel 6 Pro
Mine is greyed out
Screenshot_20211030-142104.png
 

Morgrain

Senior Member
Aug 4, 2015
902
984
It depends on your carrier.

Some offer the ability to activate it on your own (call a number, send an SMS), some activate it automatically, some won't even give you the ability to deactivate it/activate it yourself.

It needs to be activated and attached into the carriers system as an information that it's activated for your contract.

Are you sure that VoLTE is activated properly?

I have no problems with activating it on my phone.
 

foobar66

Senior Member
Jan 8, 2011
2,084
2,146
Brussels
Google Pixel 6 Pro
Same problem here ... Youfone network in Belgium ...

VoLTE works fine when I put the SIM card in my OnePlus 8 phone.
VoLTE does not work on the P6P if I insert the SIM card there.

I chatted to a Google support guy, he said it definitely is the provider whi must change something ... they claim the P6P supports VoLTE properly ...

But that is strange to me ... why would the SIM card have VoLTE in OnePlus phone and not in P6P? Could the provider really fix that? I doubt it ... but I am not a VoLTE specialist. I will contact provider anyway to see what they have to say.
 

foobar66

Senior Member
Jan 8, 2011
2,084
2,146
Brussels
Google Pixel 6 Pro
Hmm ... I checked my provider's website ... they (explicitly) say that VoLTE is availabe for the following phone brands: Apple, Huwai, LG, OnePlus, Samsung, Sony, Nokia, Oppo. So maybe indeed the provider has to "activate" it for specific models/phones ...
 

Shipoftheline

Senior Member
Oct 6, 2015
868
362
Salford
Google Pixel 6 Pro
I'm told after checking settings that Volte is switched on in fact it can't be turned off due to the carrier config file, greyed out on 'yes' however no Volte working.

The phone supports all the bands so this has to be an issue with the phone itself
 
  • Like
Reactions: skyman631

foobar66

Senior Member
Jan 8, 2011
2,084
2,146
Brussels
Google Pixel 6 Pro
Hmm ... see attach. Same issue here. VoLTE works on my OnePlus, does not work on P6P. Chatted with Google support (see attach); they claim it is the provider who has to activate it for the P6P model (which I find strange). I will check with my provider (but I'm pretty sure they will bounce me back to Google). Ping pong.
 

Attachments

  • 2021-11-07-154949_856x535_scrot.png
    2021-11-07-154949_856x535_scrot.png
    80.2 KB · Views: 139

m1ckbr1t

Senior Member
Nov 7, 2021
60
64
Manchester
So I hate volte because if my phone signal is weak and it decides to call over data the call gets all distorted and robot like if you know what I mean!! So I always turn this feature off, normally! Been a Samsung user for years and always had a setting to turn volte off via the SIM/network menu, well as it seems I've had a few of the distorted calls and gone to turn of volte but not a setting in sight and I think I may have figured it out. Seeing this post triggered me look into it deeper and after using that phone code above to establish that the carrier volte setting is switched on but greyed out, as somebody posted above made me switch my SIM to My S20 and check the volte and I can confirm that although the mobile provider has it switched on permanently for active Sims the phone has the hardware to switch it off.

If you look at the screenshot from my Pixel 6 Pro and read what toggling the WiFi Calling switch does, it actually states "When Wi-Fi calling is on, your phone can route calls via Wi-Fi networks OR YOUR MOBILE'S NETWORK"

What I take from that is the toggle on/off is for both WiFi Calling and volte at the same time and we can't have them as independent switches like on my S20 and probably other phones. It makes sense as to why none of us can turn it off, which is cr*p. Especially when my mobile signal is dodgy in my house so I relay on WiFi Calling and sometimes as I have 2 AP's I could have low WiFi signal so it decides to use volte but my mobile signal is also weak thus making my robot distorted calls to happen. I'll be sending feedback via about/send feedback to Google and just hope somebody picks up on it.

Do you agree?

Unless I'm missing something then appolgies for waisting your time.

If you do agree please could you send feed back to Google via "settings/about phone/send feedback about his device" as the more reports they get we have a better chance of the toggles being separated.
 

Attachments

  • Screenshot_20211107-155037.png
    Screenshot_20211107-155037.png
    151.6 KB · Views: 133
  • Like
Reactions: foobar66

m1ckbr1t

Senior Member
Nov 7, 2021
60
64
Manchester
I don't even have a setting 'Wifi calling' ... so I guess this is present in your case exactly because VoLTE is enabled.
Have you opened settings and searched for wi-fi calling?? See screen shot. I'm guessing you have and if it's not there then possibly your network provider doesn't support either... Is your phone on the latest firmware?
 

Attachments

  • Screenshot_20211107-164353.png
    Screenshot_20211107-164353.png
    172.2 KB · Views: 119

m1ckbr1t

Senior Member
Nov 7, 2021
60
64
Manchester
I do not have a setting when I search for "Wifi call". My phone is on the latest (November) firmware.
That's strange and does your mobile network support both WiFi Calling and VoLTE services? If so then all I could possibly suggest is maybe a factory reset, making sure all your data is backed up first of course. It's a bit drastic I know but sometimes it does fix issues especially if the update missed some steps out when it was applied.
 

foobar66

Senior Member
Jan 8, 2011
2,084
2,146
Brussels
Google Pixel 6 Pro
That's strange and does your mobile network support both WiFi Calling and VoLTE services? If so then all I could possibly suggest is maybe a factory reset, making sure all your data is backed up first of course. It's a bit drastic I know but sometimes it does fix issues especially if the update missed some steps out when it was applied.
Well, VoLTE for sure, when I put the SIM card in my OnePlus phone I have VoLTE (not wifi calling; that may be the reason why I don't see the entry in settings).
 

m1ckbr1t

Senior Member
Nov 7, 2021
60
64
Manchester
Well, VoLTE for sure, when I put the SIM card in my OnePlus phone I have VoLTE (not wifi calling; that may be the reason why I don't see the entry in settings).
Quite possibly, like you can't have one without the other... If I'm correct that they have a joint on/off switch I really hope Google fix it. Hope you manage to get something sorted.
 

elsdon

Member
Apr 4, 2007
31
7
Hong Kong
Google Pixel 6 Pro
This is a carrier setting first and foremost. My phone came with it enabled on EE here in the UK, but not explicitly. I have Wifi Calling enabled on my phone as well, and I believe that works for wideband voice calls.

I've tried both VoLTE (unmarked in status bar, just as "HD" in call log) and VoWifi, both seem to work with my P6P.
 
  • Like
Reactions: roirraW "edor" ehT

Shipoftheline

Senior Member
Oct 6, 2015
868
362
Salford
Google Pixel 6 Pro
Update: I've had one call where its shown as HD (Volte) on my call log even though the areas I go are all covered by Volte so I'm going to guess this is down to the rather poor modem on this handset which shows weak signal strength compared to my last handout (Oneplus 8 Pro)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Also ... look in the file (as root):
    Code:
    /data/user_de/0/com.android.phone/files/carrierconfig-com.google.android.carrier-8932002100401134483-1365.xml
    [code]
    Your filename WILL BE DIFFERENT (as this is generated from the carrier configuratiin and hence depends on your carrier).
    
    If you have another phone, download the file from your other file and compare it with the one on Pixel 6 Pro.
    
    I subsequently added some properties from the file on my OnePlus phone into the file on my Pixel 6 Pro.\
    [code]
    <boolean name="show_4g_for_lte_data_icon_bool" value="true" />
    <boolean name="enhanced_4g_lte_on_by_default_bool" value="true" />
    <boolean name="editable_voicemail_number_setting_bool" value="false" />
    <boolean name="carrier_volte_available_bool" value="true" />
    <boolean name="vendor_hide_volte_settng_ui" value="false" />
    But please check and compare! These are for my carrier!

    FInally, change the write permission (to make sure it does not get overwritten):
    Code:
    chmod -w carrierconfig-com.google.android.carrier-8932002100401134483-1365.xml
    After these changes, I had:
    - 4G icon in the status bar (instead of LTE - as it should be in my country)
    - wherever 'LTE' was used in the Settings app, now it says '4G' (e.g. '4G Calling', 'Preferred network type -> 4G')

    Hope this helps.
    2
    Very primitive question ... where/how do I check this call log? thanks
    If you can make a call and your phone stays on 4G/LTE then you are using VoLTE. If the phone drops to 3G/H or 2G, then you are not using VoLTE.

    HD is a separate thing, and during a call on the phone screen you will see HD near the call timer to indicate both parties support and are using an HD codec for better voice quality, or after a call you will see HD near the phone number in the recent call list.
    1
    Maybe you can also show screenshot showing IMS service status?

    After go into phone information from *#*#4636#*#* and then click the 3 dots menu and choose IMS service status. VoLTE is using IMS protocol
    See attach.
    1
    So I hate volte because if my phone signal is weak and it decides to call over data the call gets all distorted and robot like if you know what I mean!! So I always turn this feature off, normally! Been a Samsung user for years and always had a setting to turn volte off via the SIM/network menu, well as it seems I've had a few of the distorted calls and gone to turn of volte but not a setting in sight and I think I may have figured it out. Seeing this post triggered me look into it deeper and after using that phone code above to establish that the carrier volte setting is switched on but greyed out, as somebody posted above made me switch my SIM to My S20 and check the volte and I can confirm that although the mobile provider has it switched on permanently for active Sims the phone has the hardware to switch it off.

    If you look at the screenshot from my Pixel 6 Pro and read what toggling the WiFi Calling switch does, it actually states "When Wi-Fi calling is on, your phone can route calls via Wi-Fi networks OR YOUR MOBILE'S NETWORK"

    What I take from that is the toggle on/off is for both WiFi Calling and volte at the same time and we can't have them as independent switches like on my S20 and probably other phones. It makes sense as to why none of us can turn it off, which is cr*p. Especially when my mobile signal is dodgy in my house so I relay on WiFi Calling and sometimes as I have 2 AP's I could have low WiFi signal so it decides to use volte but my mobile signal is also weak thus making my robot distorted calls to happen. I'll be sending feedback via about/send feedback to Google and just hope somebody picks up on it.

    Do you agree?

    Unless I'm missing something then appolgies for waisting your time.

    If you do agree please could you send feed back to Google via "settings/about phone/send feedback about his device" as the more reports they get we have a better chance of the toggles being separated.
    1
    This is a carrier setting first and foremost. My phone came with it enabled on EE here in the UK, but not explicitly. I have Wifi Calling enabled on my phone as well, and I believe that works for wideband voice calls.

    I've tried both VoLTE (unmarked in status bar, just as "HD" in call log) and VoWifi, both seem to work with my P6P.