volume and on\off button broken/not responding. How to turn on device?

Search This thread

xzpremium40

New member
Oct 12, 2017
3
1
My volume and on/off button are broken and not responding. Cant turn my device on. First my on/off button was broken so i had to turn it on/reboot into system holding volume up key and then connect the usb cable on the computer and i entered flashmode and used flashtool and reboot to system. But now the volume key is also broken and not responding. so now i cant turn it on through flashmode/flashtool no more. All i can do is charge battery. So the device does turn on. But only charching mode. Also USB debugging is turned off. So ADB wont work either. How to reboot into system?
 
Last edited:

the_kms

Member
Jul 2, 2017
12
0
Solved.
Here's how for future reference if someone encounters a similar issue.

1. Disconnect battery and reconnect it
2. Download and install Xperia Companion Tool from Sony (tested on Mac, but the Windows version should work as well)
3. Choose Repair Software/Xperia on the Companion tool
4. Connect phone to computer using a USB cable
5. Disconnect phone when the Xperia splashscreen appears.
Done.
 

cissco28

New member
Jan 8, 2022
2
0
Does not work for xperia xz premium or am I doing something wrong ? using windows version of Xperia companion tool, reconnect battery, click on "software repair" , connect phone , disconnect but does not boot system
 

ardaarya

New member
Jul 6, 2022
1
0
the problem is from on off flex cable. it is hardware problem. not software.
just change the that cable it will fix onoff switch and valume buttons and fix ui restarting.
 

cissco28

New member
Jan 8, 2022
2
0
I change flex and buttons but didn't work, after disassembly I noticed that flex connector on mother board is broken , it is caused by the too long flex cable that strain this connector. Original parts. They are idiots or its just maketing.