[VOLVO SCT] Volvo Sensus Connected Touch (car - navi - audio)

theqkash

New member
Jul 10, 2012
3
0
0
Waze 3.8.1.0 - search mechanism stopped working. Is it just me? Is Google dropping some APIs?
Well, yes, same for me.

But generally, is there any chance to update android version on this device?
I'm just curious when it all will broke down, waze is almost dead for now as we all see, for spotify I was unable to find any version of app which will be installable on this device and will let me to remote control my car music from remote device, so without having favourites list on spotify it's almost impossible to use it.

It's not something like "you do it I watch", but I'm just afraid that in near future things can finally stop working and we will not be able to do anything more.

Going into Android Auto seems to be only fair method, except flashing it to newer Android version, IMO.
 
Last edited:

nfshp253

Member
May 14, 2015
28
0
0
So there's hope? Well one way I'm using Waze for now is to launch the app on my phone, and set my destination as the Work address, then launch Waze in SCT and select that. Troublesome workaround but it works (I could just use my phone, but I don't want an ugly phone holder in the car).
 

le_mOnd

New member
Aug 2, 2020
1
0
0
Backup or update iGo?

Hi @All!

I have a V40 T5 with the SCT including iGo and I am reluctant to root it, because I fear I might turn the system unusable, which would be bad, because the car does not have the original Sensus navigation, only iGo.
So now I got new maps and a new license for the maps from the internet. I made a backup of the whole original SD card and I'm using the backup card (a 32 GB sandisk) to test the whole thing. The backup card worked as long as I keep the original content. But when I replace the maps and other folders and put the license in the appropriate folder, iGo starts up and shows a message that it cannot display the map because of licensing issues. I also got a new iGo version as an .apk which I don't dare to install, because I fear I might lose the whole iGo system if anything goes wrong.
So is there a way to backup the old iGo primo before testing with a new version?
I assume, there is no problem with the new card, because if the whole iGo is tied to the original card, then the new card would not work at all, is that right?
All the best and thanks in advance for any comments and hints how to fix this thing. I just want more recent maps, and a working weather widget, and maybe working google maps and internet traffic.
 

dreamy2

Member
Mar 15, 2009
13
0
0
volvo stc stop to work

i've on my Volvo V60 my11 the STC installed in 2014. i've rooted it and it work fine.
from a couple of month ago it stop to work. it freeze during loading with volvo screen and the android button on the left side, after some minutes of this screen it reboot and show again volvo screen.
i've also tried to remove the SD and put in the original one provided by volvo, but the issue is the same.
there is some way to hard reset or to let it boot again?

Thanks
 
Last edited:

incogn1to

Senior Member
Nov 5, 2017
66
8
8
Rīga
i've on my Volvo V60 my11 the STC installed in 2014. i've rooted it and it work fine.
from a couple of month ago it stop to work. it freeze during loading with volvo screen and the android button on the left side, after some minutes of this screen it reboot and show again volvo screen.
i've also tried to remove the SD and put in the original one provided by volvo, but the issue is the same.
there is some way to hard reset or to let it boot again?

Thanks
I'm afraid you are in boot loop. There is no way back.
Only option is to plug ethernet card, connect via adb and try to figure out what is going wrong.
Might take a while.
 

dreamy2

Member
Mar 15, 2009
13
0
0
Thanks for your help.

Do you think can be usefull to try to load last software version via usb? I m not able to find it more on parrot site.

What do you mean for "plug eternet card"?

Thanks
 

dongwenxuan

Member
Aug 22, 2010
42
3
0
Found that Google dropped support for old android - Youtube won't be support in a few days unless SCT can be upgraded to 4.0 and later version. Volvo/Parrot no longer support nor care about SCT. Not sure if anyone had tried to upgrade the OS or change the hardware for this unit?
 

Rita159

Member
Sep 27, 2020
14
0
0
Volvo Sensus Connected Touch (SCT) is a new car audio-navi system based on systems of Parrot. SCT has hardware and software from the Parrot, but is not exactly equal. In general it has some more restrictions build in by Volvo.
The system is based on the Parrot FC6100 (not the Parrot Asteroid Smart as was first believed). Looking at the Installation manual for Sensus Connected Touch (ACU) Accessory, Part Number: 31399165 the form factor is closest to the Parrot Asteroid Tablet (PAT). The only similarity that the SCT has with the PAS is Parrot's custom base of the Android 2.3 branch which is also shared by the PAT. So, if anything is more analogous to the Parrot Asteroid Tablet (PAT) than the Parrot Asteroid Smart. (thanks to Donaldta, see post) (Link to the Volvo V40 (MY14) SCT installation manual, also attached to this post as pdf)

This is how the hardware of the SCT looks if outside of the car (thanks to @AAT):





This thread is research and development on several topics and has already some nice answers:
The starting questions:
  1. How to get ADB working y
  2. How to install .apk files y
  3. How to root y

WARNING!:
The below mentioned method is an experimental way of rooting. Rooting your SCT involves some android knowledge. Me, the developers and anyone in this topic are not responsible for typo's or any damage that may occur when you follow these instructions.
ROOTING means you have complete control over the android system. This also means you can do damage to it.

Security warning:
The SCT has ADB over WIFI enabled by default. Never ever connect your Volvo SCT to an unknown and/or untrusted network! Anyone connected to that same network can harm your Volvo SCT. The same applies for connecting unknown people to a known/trusted network of yours.
Security warning 2:
If your ROOTED your SCT, you are extra vulnerable to above. Anyone with ADB on the same network has complete control over your SCT!


WARNING!

Do NOT attempt to replace the SCT's BUSYBOX executable or the command symlinks to it. Another user in this forum just sent me a private message stating that they tried this on their SCT and can no longer mount USB drives or connect to ADB over WiFi. Apparently, they also do not have a File Explorer or a Terminal Emulator installed so it seems this is going to be nearly impossible to fix and will most likely be required to swap it at the dealer.
See message from @donaldta : Message




The below answers are not yet completely reviewed and tested. The answers will be reviewed in the next days. In any case the instructions below are delivered "as is" and have no guaranty. If you follow the instructions below, you are responsible for your own actions. So, before you do so, understand, or at least try to, what you are doing. If you have questions or have recommendations, post them in the topic.

The answers and instructions below are constructed from the work of @gekkekoe123 and @donaldta and the trial and error experiments of the first users of the SCT (see first pages of the topic)
This means everone using these instructions must give BIG THANKS TO @gekkekoe123 and @donaldta


Instructions to root en install apps:

Note: Instructions are tested on specific versions of the Volvo SCT
It is possible that these instructions below are not (yet) working on other versions: Other continents, newer versions etc.
If you tested it on a different continent + version, let me know, so I can put it here.

Available versions:
EU
-1.47.88 - Tested
-1.47.96 - Tested
-1.49.34 Tested
  • One click script version 4 in attachments cmd-frama-menu-4.zip (4.62 MB)
    One-click script with menu provided by @gekkekoe123 and @donaldta
    Oneclick , latest version, script is discussed from here


    It is rather simple as long as You have the SENSUS CONNECTED TOUCH and a PC (prefer a laptop) which You need to connect to the same network.

    How to:
    1. Preparing
    *Download the: cmd-frama-menu-4.zip from the page 1, first post attachments. LINK: http://forum.xda-developers.com/attachment.php?attachmentid=2636951&d=1395149723

    2. Follow the instructions
    The instructions are rather simple.
    -Connect your SCT to the same Wifi network as your PC. This wifi network can be your home network or your local hotspot from your phone.
    -Unzip the (cmd-frama-menu-4.zip) and start menu.bat found in the folder "menu"
    - After starting menu.bat on your pc it will ask:
    Code:
    Input {IP Address of Android Device} or USB:
    Type in the IP address of the SCT, can be found when You go to the settings on SCT -> WIFI -> and click on the connected network (starts with 192.-).
    After that the menu look list this: (Now just type in: 1 and wait a bit so it will say complete, then type in 2 and wait a bit until complete and so on, until step 6 when the SCT will restart itself)
    Code:
    1 - Copy Framaroot files and execute.
    2 - Install remount.sh into /system/xbin and remount as writeable.
    3 - Alter /system/build.prop to ro.parrot.install-all=true
    4 - Install Google Framework & Android Market
    5 - Install rewhitelist.sh/setpropex/patch init.parrot.capabilities.sh
    6 - Reboot Android Device
    7 - Install Android Packages from APKs folder.
    8 - Android Debug Bridge Shell
    9 - Save ADB Bugreport to Disk
    R - Input connection information & retry ADB connect.
    Q - Quit
    Run steps 1 through 6 in order to root the SCT.
    Step 7 is optional and will install all APKs you have placed inside the APKs folder in your unzipped menu.zip folder on your pc PC.
    Step 8 is for manual commands or troubleshooting.
    Step 9 is for troubleshooting.
    Step R is only needed when the connection to the SCT seems lost.

    3. You should have now a rooted SCT.

    4. Installing applications
    I noticed that lots of Apps from Google Play Store can not be downloaded directly to the SCT (because the SCT is not in the available list of the apps) so a easy way is to download the Applications as ".apk" files from the PC (You can find the desired app from: http://www.appsapk.com/ or http://www.androiddrawer.com/ for example).
    Then copy-paste these .apk files(make sure they do not have any spaces in the filenames) to the folder "APKs" found in the downloaded unzipped folder "cmd-frama-menu-4". To install them, run the menu.bat again and once connected with the SCT again run the step 7 to install the applications You copied to the APK folder.

    If you want to install apps using the Google Play Store that are larger than 7MB or so, you need to remap the cache directory to the SD card:
    Code:
    remount.sh cache-sd
    Then after the app installation has finished, but before you start the app, remap the cache directory to the internal SCT memory:
    Code:
    remount.sh cache-og
    5. Enable displaying applications while driving (disable safety feature)
    1. Download Android Terminal Emulator from Google Play Store on Your rooted SCT.
    2. Once installed, run Android Terminal Emulator under Applications
    3. touch the screen - the keyboard pops up
    4. Type in "su" press ENTER
    5. It should ask wether You allow Superuser or not, choose the "Allow" option.
    6. Type in "rewhitelist.sh" press ENTER
    7. Type in "reboot" press ENTER

    6. Enable Google Maps and Voice Search
    First install google.maps.6.14.4.apk by the method explained above. Then copy libvoicesearch.so to /system/lib and install Voice_Search_2.1.4.apk. These files can be found in Voice_Search_2.1.4.zip.
    Here is an example of how to do this with adb:
    Code:
    adb connect [ip of your SCT]
    adb push google.maps.6.14.4.apk /mnt/sdcard
    adb install /mnt/sdcard/google.maps.6.14.4.apk
    adb push libvoicesearch.so /mnt/sdcard
    adb shell su -c 'remount.sh system-rw'
    adb shell su -c 'cp /mnt/sdcard/libvoicesearch.so /system/lib'
    adb shell su -c 'chmod 644 /system/lib/libvoicesearch.so'
    adb push Voice_Search_2.1.4.apk /mnt/sdcard
    adb install /mnt/sdcard/Voice_Search_2.1.4.apk
    Now #reboot# and Google Maps and Voice Search should be working.


    Now You should be done. Happy downloading and drive safely. :)

    Older instructions, just for reference here, do not follow anymore.

    [*]One-click script with menu provided by @gekkekoe123 and @donaldta
    This one-click script with menu options is here

    [*]One click script for version 1.49.34: http://forum.xda-developers.com/showthread.php?p=50846498



    Manual instructions and commands:

    1. Detailed instructions how to get ADB working between your pc and SCT
      1. Download the Android SDK, it contains the nescesary tools like ADB.exe and Monitor.bat (Download page Android SDK)
      2. Install the android SDK
      3. If you are using windows: set the installation path of your SDK\platform-tools\ in your windows environment variables. So, add c:\\SDK\Platform-tools\ to it. (More instructions on this point)
      4. Now connect your SCT to a Wifi network and also connect your laptop/pc to the same wifi network. This network can be your home network, or for example the wifi network you create with your phone wifi-tether function.
      5. Go into the SCT>Settings>Wifi and click on your connection details. Find out the IP adress of your SCT. (example, it would be something like 192.168.43.x if you are using wifi tether from your android phone. )
      6. Now on your pc, open the command line (cmd). Easiest is to click with shift-button hold and with Right-Mouse-Button on the folder where the files reside you want to transfer to the SCT (see instructions further for rooting). After RMB click, choose option: open command line here.
      7. Now type:
        Code:
        adb connect $IPADDRESS
        Replace $IPADRESS with the IP from the previous step.
      8. ADB is now connected and you are ready to type the instructions for rooting.
        Code:
        D:\sdk\platform-tools>adb connect 192.168.43.5
        connected to 192.168.43.5:5555


    2. Detailed instructions how to Root SCT
      1. Download the cmd-frama-working.zip from the attachments
        Attachment
      2. Unzip it into a folder (example: d:\sct\ )
      3. Open the commandline in this folder
      4. Connect to adb (see instructions above)
      5. Do the following commands (line by line):
        Usage:
        Code:
        adb push libframalib.so /data/local/.
        adb push sploit.jar /data/local/.
        adb shell mkdir /data/local/tmp/dalvik-cache
        adb shell ANDROID_DATA=/data/local/tmp LD_LIBRARY_PATH=/data/local dalvikvm -cp /data/local/sploit.jar com.alephzain.framaroot.FramaAdbActivity Gimli 0
        [or]
        adb shell ANDROID_DATA=/data/local/tmp LD_LIBRARY_PATH=/data/local dalvikvm -cp /data/local/sploit.jar com.alephzain.framaroot.FramaActivity Gimli 0
        See post here and thank developer!
      6. Now you are rooted:
        Code:
        cmd line frama root by Gekkekkoe
        Credits to alephzain for Framalib
        using Exploit: Gimli choice: 0
        Executing Check
        idx: 0 value: Gimli
        idx: 1 value: Aragorn
        Executing Check Completed
        No such user 'root:root'
        No such user 'root:root'
        Result: 0
      7. Test root by command:
        Code:
        adb shell
        su
        id
        On the SCT you will get a screen of SuperSU, asking if shell may have root access privileges. Say yes.
      8. exit the su and shell using
        Code:
        exit
        exit
      9. Reboot the SCT
        If you are still within shell, just use
        Code:
        reboot
        If you are on command line again, use
        Code:
        Adb Reboot
    3. Detailed instructions how to get Google framework and Google Play (market) on the SCT
      1. Download the files for framework and market

        Framework
        Market
      2. Push them to your SCT
        Code:
        adb shell su root -c 'mount -o remount,rw ubi0:system /system'
        adb push GoogleServicesFramework-2.2.1.apk /data/local/.
        adb push Market-3.3.11.apk /data/local/.
        adb shell
      3. Now install them
        Code:
        cp /data/local/*.apk /system/app/.
        chmod 644 /system/app/GoogleServicesFramework-2.2.1.apk
        chmod 644 /system/app/Market-3.3.11.apk
        reboot
      4. After reboot, connect the SCT to internet
      5. Open the google market on your SCT (in the applications drawer)
      6. Log in with your google credentials
      7. Accept terms and conditions
      8. Be sure to stay connected to internet, google market will update itself after some minutes
      9. Connect Adb and force SCT to reboot again.
      10. Open Market/Play and Accept terms and conditions again! (now for the updated versions)
      11. Wait for some time, it will again update itself again.
      12. Open adb, force reboot again
      13. Last time open Play (It should be named Play now, since it is updated, if it is not, wait longer and try previous steps again)
      14. Go into My Apps, update SuperSu
      15. After update, open SuperSu from your app drawer
      16. It will ask to update SuperSu Binary, use Normal Method
      17. Say thanks to Chainfire for the SuperSu :)
      18. In settings, you can disable the popup that will ask if you want to run an App that is using root. Can be convenient, but also dangerous (apps can use root even without notifying you.)

    4. Detailed instructions how to installation of other apps
      1. We have to enable installing all apps on SCT. Warning, this means editing the build.prop, which is vital to the system. Typing errors can result in a system that will not boot correctly.


        More methods apply here, use one which is convenient to you:
      2. Fast method:
        Code:
        adb shell
        mount -o remount,rw ubi0:system /system
        sed -i 's/ro.parrot.install.allow-all=false/ro.parrot.install.allow-all=true/' /system/build.prop
      3. Slow method, more control, moderate risk:
        Code:
        adb pull /system/build.prop
        edit content and set to true. Content of the file should look like this
        Code:
        #TODO Set to false for prod #Package install limitations. Set to false to allow only the install of verified packages 
        ro.parrot.install.allow-all=true
        replace build.prop with proper one.
        Code:
        adb shell su root -c 'mount -o remount,rw ubi0:system /system'
        adb push build.prop /system/build.prop
        If above does not work, use method like the google framework.
      4. Third method: install ES file explorer, use the rooting functions of this app to edit build.prop
        Instructions in this post and this post
    5. Detailed instructions how to install APK files
      1. Method 1: Use google play
      2. Method 2: If not available on google play, use a Google Play APK downloader on your pc and install using the
        Code:
        ADB install
        or using
        ES Fileexplorer mentioned above
    6. Detailed instructions how to make apps available during driving

      All apps are behind a security wall of the SCT. When driving >5km/h, all apps not listed in the whitelist.xml will be disabled. To enable your installed apps you have to edit the whitelist.xml
      Warning: it is a safety feature you are disabling now, it is your own responsability when using apps during driving

      1. Slow method:
      2. Get the whitelist.xml from your SCT

        Code:
        adb pull /system/etc/whitelist.xml
      3. Find out which packages are installed and have to be listed there:
        Code:
        adb shell
        pm list packages
        Other method, look to the url of google play on your pc, see bold part: https://play.google.com/store/apps/details?id=com.estrongs.android.pop
      4. List the packages by adding new lines with the package names
      5. Edit the whitelist.xml using a smart text editor. Preferably use Notepad++
      6. Copy the whitelist back to SCT

        Code:
        adb push whitelist.xml /data/local
        adb shell
        su
        mount -o remount,rw ubi0:system /system
        cp /data/local/whitelist.xml /system/etc
        reboot


        Scripted method:
      7. Download script
      8. Instructions in this post



  • FAQ
    1. Audio is not working when using application X
      This is a feature or limitation by design
      - TomTom and other navigation apps will break Sound/Audio due to this feature.
    2. If you have more, PM me or react in topic

  • TIPS
    1. Use a USB keyboard in combination with ES file explorer or a Shell app to edit files on the system.
    2. If you have more, PM me or react in topic








Informational links:

Information about SCT:
http://www.volvocars.com/intl/sales-services/sales/sensus-connected-touch/pages/default.aspx
Official FAQ of SCT:
http://www.volvocars.com/intl/top/support/pages/sensus-connected-touch-faq.aspx
Dutch experiences with SCT:
http://www.volvo-forum.nl/viewtopic.php?t=54935&postdays=0&postorder=asc&start=0


SCT update files:
http://www.parrot.com/nl/support/sensus-connected-touch
Current version: All regions - 1.49.34

How to unpack the update (.plf) files:
Download the plftool
Basically, download, unzip, and go into the command line, the binaries directory and use the command syntax, "plftool -i -o "
And please take the time to thank hoppy_barzed for hosting it for us and for loveshackdave for providing the tool to use it.


Linked topic of Parrot Asteroid Smart:
http://forum.xda-developers.com/showthread.php?t=2118432
By contrast, I prefer the Atoto S8 headunit, support android auto&carplay, dual bluetooth, split scrren display, ultra Clear QLED Display, VSV Parking...meet all my needs.
 

martijn246

New member
Nov 13, 2020
1
0
0
Installation doesn't work

I'll try to hack my SCT system with version 1.49.34 and i have some problems with it.

My log....
Pushing libframalib.so to /data/local
cannot stat 'libframalib.so': No such file or directory

Pushing sploit.jar to /data/local/.
8 KB/s (1837 bytes in 0.207s)

Creating /data/local/tmp/dalik-cache directory
mkdir failed for /data/local/tmp/dalvik-cache, File exists


What can i do to install this hack on my SCT system?
 
Nov 6, 2013
16
1
23
It looks like API for Waze app for Android 2.3 is completely down. I'm constantly getting 'Searching network...' now for more than a week.
UPDATE: API is live again.
 
Last edited:

icaroavelar

New member
Feb 6, 2021
1
0
11
Hi all, good afternoon. Is it possible to update the SCT to android 4.0+? I've try to do it by connecting to a wifi and using the automatic update in my V40 T5 2014, but it shows a message of connection faillure.
All other apps works fine, but when I try to update, this message occur.
 

konradmik

New member
Feb 5, 2008
2
0
21
First of all, I'd like to thank everyone contributing to this thread for making this totally useless hardware a bit more useful. Thanks guys!
So far, thanks to you, I was able to deal with most of the problems, unfortunately I got stuck on Internet connecion. The problem is that some apps doesn't "see" active connection. It does't matter if I connect via Wifi, BT tethering or usb 4g stick. This is especially true for google "related" apps i.e. Waze (it starts but can't connect), Play Store (it opens and load but i can't download anything) or Google Maps Live Wallpapers (it shows map centered to google headquaters and doesn't refresh). Today i had a problem with AirDroid (it starts but can't login because of "No Internet connection. Check connection settings and try again"). A lot of other apps works great. Do you have any solution for this??
Cheers!!
 

incogn1to

Senior Member
Nov 5, 2017
66
8
8
Rīga
It is not the apps. The problem is that services are dropping support for old APIs. Applications responds as "no network" just because they can't reach service APIs they are used to.
 
Last edited: