VPN Issues

mrsubway

Senior Member
Dec 3, 2009
1,014
371
113
Bronx, NY
I'm thinking this is more of an Android 10 issue. I cannot use ANY VPN when on Wifi. It's not my router. I've tried different routers. If I'm on Wifi, VPNs will connect, but I'll immediately lose all internet. If I turn the VPN off, I have to flip Wifi off and on again in order to get my connection back. This doesn't happen on 5G. I'm using AT&T.

I don't plan on rooting, and I cannot use an adblocker because most of them require creating a VPN connection. Any suggestions?
 

danial.aw

Senior Member
Feb 27, 2009
1,847
274
103
Kitchener
Ya this is an LG software issues... I read in the blokada thread someone who was getting help and the dev said it was our device fault. Then the person said they got a software update and it fixed their issue.

I guess we just have to wait for LG to send us a new security patch fixing the issue ?*♂
 

mrsubway

Senior Member
Dec 3, 2009
1,014
371
113
Bronx, NY
Ya this is an LG software issues... I read in the blokada thread someone who was getting help and the dev said it was our device fault. Then the person said they got a software update and it fixed their issue.

I guess we just have to wait for LG to send us a new security patch fixing the issue ?*♂
At first I thought it was my router. But, I tried at work too. I don't really use a VPN, but I want it because that's how non-root ad-blockers work. Oh well. Thanks.
 

nimr0dv

Senior Member
Aug 17, 2010
72
0
0
Ya this is an LG software issues... I read in the blokada thread someone who was getting help and the dev said it was our device fault. Then the person said they got a software update and it fixed their issue.

I guess we just have to wait for LG to send us a new security patch fixing the issue ?*♂
Heh I think that was me ? It's working normally now and all I did was software update.
 

danial.aw

Senior Member
Feb 27, 2009
1,847
274
103
Kitchener
Model LM-G900UM

SW VERSION G900UM10e

Security June 1, 2020

I'm guessing there's no root for this phone.

Weird I'm running the July 1st one 10d ... I don't really know how LGs scheming works but ya VPN won't work for me.

And nah pretty much forget any hope of root on our model since our bootloader is locked. Also this phones not that popular that we'll have devs creating bounties to try and put the effort
 

mrsubway

Senior Member
Dec 3, 2009
1,014
371
113
Bronx, NY
Weird I'm running the July 1st one 10d ... I don't really know how LGs scheming works but ya VPN won't work for me.

And nah pretty much forget any hope of root on our model since our bootloader is locked. Also this phones not that popular that we'll have devs creating bounties to try and put the effort
It works on 5G. It won't on wifi.
 
M

mlamm

Guest
So no solution to this yet? Very annoying. As said above, VPN works with mobile connection, breaks connection when on wifi. Reported to LG (and where is even their link or address for reporting it)?
 

mrsubway

Senior Member
Dec 3, 2009
1,014
371
113
Bronx, NY
So no solution to this yet? Very annoying. As said above, VPN works with mobile connection, breaks connection when on wifi. Reported to LG (and where is even their link or address for reporting it)?
Believe me. If there were a solution, it'd be posted here. I've fiddled with some settings. By the way. It's NOT DNS. I've tried loading raw ip addresses, and no go. What's odd is the vpns connect, which means that, somehow, THAT'S getting out. Weird.
 

pomponazzo

Senior Member
Nov 18, 2014
204
69
0
Bordeaux
Same stuff here on my LM-G900EM.
I've been using AdGuard for years without any glitch, but since last LG software update, no luck on wifi. Waiting for a new version from LG.
 

danial.aw

Senior Member
Feb 27, 2009
1,847
274
103
Kitchener
The latest October security patch that my phone just got fixed the VPN issue. So keep an eye out whenever you get the next security patch it should be fixed.

The horrible laggy scrolling in apps has been fixed as well.

LG launcher is still a POS though and still seems to redraw at times going back home... And the random lag going into the eecents screen still exists ?.

I miss the LG of the G2 and G3 days
 

Ryano89

Senior Member
May 6, 2011
1,904
670
143
Indiana
I'm thinking this is more of an Android 10 issue. I cannot use ANY VPN when on Wifi. It's not my router. I've tried different routers. If I'm on Wifi, VPNs will connect, but I'll immediately lose all internet. If I turn the VPN off, I have to flip Wifi off and on again in order to get my connection back. This doesn't happen on 5G. I'm using AT&T.

I don't plan on rooting, and I cannot use an adblocker because most of them require creating a VPN connection. Any suggestions?
If you want adblocking without battery drain, just go to SETTINGS/NETWORK AND INTERNET/PRIVATE DNS... and type in dns.adguard.com. It will block most ads without a VPN or any other app installed and it's free. It's a built in function of Android 10