"waiting for device" in Fastboot Mode...

Search This thread

akinkoff85

Senior Member
Nov 14, 2014
125
5
Cleveland
I had my phone rooted with the first official Android 11... I uninstalled root and completely reset the phone. Now I am on the second release of Android 11 and when I try to flash modified boot image in fastboot mode it says "Waiting for device" any suggestions or fixes? My device is available in adb mode doing the adb devices command... Please advise.
 

dladz

Senior Member
Aug 24, 2010
14,986
5,314
Liverpool
Huawei Watch 2
OnePlus 10 Pro
I had my phone rooted with the first official Android 11... I uninstalled root and completely reset the phone. Now I am on the second release of Android 11 and when I try to flash modified boot image in fastboot mode it says "Waiting for device" any suggestions or fixes? My device is available in adb mode doing the adb devices command... Please advise.

Did you unlock the bootloader again? Or was it just a wipe

Is usb debugging turned on?

Perhaps revoke it and cycle it then test ADB again.

If so run ADB kill-server

Then run ADB reboot bootloader should work then.

Also did you get the prompt when you did ADB devices on your phone to allow connections to that device?
 
Last edited:
Jan 1, 2021
13
4
Earth
I had my phone rooted with the first official Android 11... I uninstalled root and completely reset the phone. Now I am on the second release of Android 11 and when I try to flash modified boot image in fastboot mode it says "Waiting for device" any suggestions or fixes? My device is available in adb mode doing the adb devices command... Please advise.

Hey I'm having the same issue. Did you get this resolved?
 

ymDroid

Senior Member
Feb 15, 2012
242
29
Stafford, VA
I tried for hours to unlock on windows 10. I could access the device in adb while the phone was on and as soon booted into fastboot, Windows 10 says there was no driver.

Disabled verified drivers in Win 10 and was able to install the drivers, but fastboot still couldn't recognize the oneplus.
 

dladz

Senior Member
Aug 24, 2010
14,986
5,314
Liverpool
Huawei Watch 2
OnePlus 10 Pro
I tried for hours to unlock on windows 10. I could access the device in adb while the phone was on and as soon booted into fastboot, Windows 10 says there was no driver.

Disabled verified drivers in Win 10 and was able to install the drivers, but fastboot still couldn't recognize the oneplus.

Quite strange that.

From a completely fresh win 10 installation I just plugged in my phone, install the OnePlus drivers, then activated USB debugging, allowed all drivers to be installed.

Added necessary ADB and fastboot files in a folder to C: and then typed ADB devices via powershell in that folder, got prompted to accept the device.

From that point fastboot worked and always has.
 
  • Like
Reactions: ymDroid

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    D
    Deleted member 5408779
    Seems like driver issue.
    1
    I tried for hours to unlock on windows 10. I could access the device in adb while the phone was on and as soon booted into fastboot, Windows 10 says there was no driver.

    Disabled verified drivers in Win 10 and was able to install the drivers, but fastboot still couldn't recognize the oneplus.

    Quite strange that.

    From a completely fresh win 10 installation I just plugged in my phone, install the OnePlus drivers, then activated USB debugging, allowed all drivers to be installed.

    Added necessary ADB and fastboot files in a folder to C: and then typed ADB devices via powershell in that folder, got prompted to accept the device.

    From that point fastboot worked and always has.