WARNING - Google Services massive data usage! 4.2.2, 4.3 OTA bug?

Search This thread

Jikx

Member
Oct 30, 2010
26
14
I think there's a bug going around for those on custom roms, with the release of 4.3, some of us are having Google Services trying to download the 4.3 OTA, having it fail, and having it redownloaded over and over.

Burnt through 800mb of my data in a few hours!

Some more info:
http://forum.xda-developers.com/showthread.php?t=2383691
http://forum.xda-developers.com/showthread.php?t=2385996
http://forum.xda-developers.com/showthread.php?t=2388243

Currently on AOKP 4.2.2 (3 June nightly), and Franco Kernel milestone 3. Appears to impact many different custom roms and models.

On the spot temporary solution is to disable background data in Google Services from the data menu (which can break other things, but saves your data cap).
More permanent fixes include:
http://forum.xda-developers.com/showpost.php?p=44234110&postcount=4
http://forum.xda-developers.com/showthread.php?p=44217744
Or flash a 4.3 ROM (as I did).

Just a word of warning to have your data limiter on, this could have cost me over $200!! Still I had to buy a data pack.. so only $20.

Keep a look out people!


View attachment 2161161
 
Last edited:

Nucleotide

Senior Member
May 31, 2011
2,034
1,153
I'm pretty sure most custom Roms have this disabled. This is the first I've ever heard of it.

Custom ROMs "should" have this disabled but it appears as though a lot don't. XenonHD and Purity both don't appear to disable it. There have been HEAPS of reports of this kind of behaviour in both ROM threads.

From the logging I've done, it does actually appear to be the 4.3 update trying to get through.

You can stop this from happening by disabling "com.android.gsf.update.SystemUpdateService" receiver under Google Service Framework using something like ROM Toolbox.

There is no need to prevent all Google Services background data. That is likely to cause more issues.
 
Last edited:

meangreenie

Senior Member
Mar 6, 2012
2,584
732
You sure this isn't the well documented dalvik commits that caused a data reading bug, which was on many roms built around that time in June?

Have you checked against your actual data usage according to your supplier?
 
G

GuestK00105

Guest
I think there's a bug going around for those on custom roms, with the release of 4.3, some of us are having Google Services trying to download the 4.3 OTA, having it fail, and having it redownloaded over and over.

Burnt through 800mb of my data in a few hours!

Some more info:
http://forum.xda-developers.com/showthread.php?t=2383691
http://forum.xda-developers.com/showthread.php?t=2385996
http://forum.xda-developers.com/showthread.php?t=2388243

Currently on AOKP 4.2.2 (3 June nightly), and Franco Kernel milestone 3. Appears to impact many different custom roms and models.

Solution appears to disable background data in Google Services. Going to flash to 4.3 to see if this fixes it..

Just a word of warning to have your data limiter on, this could have cost me over $200!! Still, a data pack is in order.. so only $20. Keep a look out people!


View attachment 2161161

I had this check your real usage with your carrier it's a bug, look in the wifi section it's in gb

Sent from my Nexus 4 using xda premium
 

bundi22

Senior Member
Jan 10, 2011
276
53
This happened to me! 500mb in 2 days.. It must download the ota into cache a couple of times, I've now turned off mobile data

Sent from my Nexus 4
 
G

GuestK00105

Guest
This happened to me! 500mb in 2 days.. It must download the ota into cache a couple of times, I've now turned off mobile data

Sent from my Nexus 4

Wow that sucks obviously not what I've had then.
I still have 1gb of my 2gb allowance just checked

Sent from my Nexus 4 using xda premium
 

Attachments

  • uploadfromtaptalk1375512317151.jpg
    uploadfromtaptalk1375512317151.jpg
    38.9 KB · Views: 1,786
  • uploadfromtaptalk1375512330791.jpg
    uploadfromtaptalk1375512330791.jpg
    41.1 KB · Views: 1,755
G

GuestK00105

Guest
...

Sent from my Nexus 4 using xda premium
 

Attachments

  • uploadfromtaptalk1375512498519.jpg
    uploadfromtaptalk1375512498519.jpg
    81.4 KB · Views: 2,034

Nucleotide

Senior Member
May 31, 2011
2,034
1,153
I have posted a solution for this problem here

http://forum.xda-developers.com/showthread.php?p=44217744

It would be great if the OP could be updated with it

Sent from my Nexus 4

I posted a solution to this about 3-4 posts down on the first page of this thread. It seems no one can read! :(

---------- Post added at 05:28 PM ---------- Previous post was at 05:27 PM ----------

I had this check your real usage with your carrier it's a bug, look in the wifi section it's in gb

Sent from my Nexus 4 using xda premium

It's not a bug - it's using real 3G/data. I detailed what the problem was on the first page.
 
  • Like
Reactions: joshuab227

xallinvaynex

Senior Member
Feb 1, 2012
173
29
I use go phone and it happened to me yesterday. I ran out of data yesterday, added another gb. Last night I browsed Internet for about 10 min, when I woke up this morning, data gone. My phone went through a gb of data while I was sleeping.
 

p0izn

Senior Member
Jun 14, 2010
237
42
I'm with you , guys.
My 2Gb and My GF's 500Mb of data gone too.
I flashed latest CM build with latest unoffic gapps with wipe, restored user apps with titaniumBackup, now its ok.
 

Nucleotide

Senior Member
May 31, 2011
2,034
1,153
I updated the OP to include a possible fix. In the end, I just flashed a 4.3 rom which fixed the issue.

Disabling background data for Google Services is not a solution at all - temporary or otherwise. That is just likely to cause more problems and confusion.
 

Jikx

Member
Oct 30, 2010
26
14
Disabling background data for Google Services is not a solution at all - temporary or otherwise. That is just likely to cause more problems and confusion.

Well if you're out and about, you don't want to be sitting on your phone trawling forum posts and installing programs. Disabling the background data is an in-built feature.

Anyway, updated the OP post again.
 

Muuhmann

Senior Member
Aug 3, 2010
84
1
Cologne
Hi, just wanted to check in and confirm that I do have the same issue (but on Galaxy Nexus). I'm also on AOKP 4.2.2, maybe it is an AOKP issue, that they didn't disable the OTA functionality completely?

I remember when 4.2.x or even 4.1 was rolling out, I had the same issue, also on AOKP rom.
I had to switch to stock 4.2/4.1 until AOKP released their update.

It's really annoying though.. I'll raise a bug for AOKP.
 

icecicle

Senior Member
Feb 18, 2011
259
42
I'm on PA 3.60 4.2.2 and my Google service data usage is crazy... I got unlimited so I'm not too worried but cmon

Sent from my Nexus 4 using xda app-developers app
 

Attachments

  • uploadfromtaptalk1375703165502.jpg
    uploadfromtaptalk1375703165502.jpg
    83.9 KB · Views: 617

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone