How To Guide WARNING: Read BEFORE Locking Bootloader

Search This thread
Thank you @Andrologic for the hint that I might have been attempting to flash when the phone was in the wrong section of the boot process. Indeed it was: From the boot-loader, the phone ought not to have been progressed to Recovery mode for the raw firmware flashing to work. That was my mistake.
Now I was able to successfully flash the raw firmware image cited in the initial post. Even right before the firmware update, I've noticed that the phone doesn't always boot to boot loader when powered on. Since flashing raw firmware, I haven't been able to get it to boot even to boot loader. At best it loads some sort of garbled graphic screen of some sort (possibly Android setup screen??).
 

Attachments

  • IMG_20221202_234759833.jpg
    IMG_20221202_234759833.jpg
    1.6 MB · Views: 14
Last edited:
Actually I needed patience as usual. The most recent problem was due to depleted battery by the look of it. After charging the phone using its charger for an hour, I was able to boot it successfully and it went straight to ASUS ROG Welcome screen (with music, language selection and all).
As recommended in the original post, I'll proceed with updating it all the way to up-to-date A12 firmware version from ASUS website. Then I'll attempt boot loader lock. 🤞
Thank you for your help.
 
The instructions provided in the OP worked great. Got a successfully-working-with-a-locked-bootloader phone now. Thank you all for working out the meticulous/intricate steps & related firmware links etc to make it possible.
(From Android 11 raw firmware 18.0840.2106.83, within Android itself, updating to Nov A12 firmware 31.0810.1226.139 downloaded from ASUS website didn't work; however updating it to the highest A11 18.0840.2202.231 & then jumping from there to Nov A12 update 31.0810.1226.139 did work.)
(And oh, up-to-date Fedora with its native android-tools package provided fastboot tool worked just fine for all fastboot work; so there was no need for Windows platform for it, which is simply great.)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    DO NOT LOCK THE BOOTLOADER WHILE ROOTED!

    When locking the bootloader while rooted, the boot image will fail verification and the system will fail to boot. You cannot flash a stock boot image with a locked bootloader.

    Locking the bootloader will not fix most issues. It will allow you to use apps that check for an unlocked bootloader without the need for any additional modification. That is the ONLY benefit.

    If you still want to lock your bootloader, make sure you can say yes to each of the following:

    1. Have you restored the stock boot.img / vendor_boot.img and the phone functions normally?
    Follow the instructions in the thread above.
    Use only the boot and vendor_boot images.
    Do NOT flash any images that end with "-magisk.img"
    2. Have you made a backup of everything you do not want to lose when wiping the phone?
    The sdcard is part of the internal storage and is cleared by a factory reset
    Copy everything you want to keep to a computer or USB-C storage device
    Apps and settings can be backed up by enabling the Google Backup option
    • Open Settings
    • Select Google
    • Select Backup
    • Select Back up now
    • Wait for the backup to complete
    3. Have you flashed raw firmware and made sure the phone and updates function normally?
    Follow the instructions in the thread above.
    If you perform a wipe, you may skip step 4.
    4. Have you performed a factory reset and made sure the phone functions normally?
    • Open Settings
    • Select System
    • Select Reset options
    • Select Erase all data (factory reset)
    • Follow the instructions

    Once you have verified all of the above requirements, you are now ready to lock the bootloader.
    From the bootloader (volume up + power):
    Code:
    fastboot oem asus-csc_lk
    2
    If by using ASUS unlock utility one was able to oneself unlock the boot-loader once, then is it safe to say that (after relocking it) it'd be possible to unlock it again?
    Some people have reported that you can't unlock the bootloader again after relocking, using the official "Unlock Device App", but I suspect it is an OS mismatch. This issue has only been observed on Tencent (CN) version with global ROM. Have anyone been able to unlock->relock->unlock on the same version of the phone, but not relocking while on the global ROM (i.e. relocking while on stock CN ROM)?

    I am surprised the phone did not hard brick. Usually, and this is a general case in almost all Android phones with bootloader unlock capability, when you relock on a different ROM your phone hard bricks. Always restore to original ROM before relocking. Can people with Tencent (CN) phones with global ROM and locked bootloader flash the original CN ROM without unlocking the bootloader? If so, can you test the "Unlock Device App" to see if it works while on the CN (official) ROM? I gotta a feeling it might work in that situation.
    1
    I don't want to spread false information here, but here is a question post I created recently with two replies showing me contacting the help center (two different agents) confirming that I can use the app more than once to unlock the device's bootloader: https://forum.xda-developers.com/t/...nlock-relock-for-asus-rog-phone-5-5s.4367047/ . @Andrologic also confirms the case there for global (EU) version. I have a feeling that for the Tencent version it is because the sellers lock it on a wrong official ROM, or wrong ROM in general, e.g. global ROM, and therefore it confuses the unlock app. I am surprised the device did not even get hard bricked from locking on not the original ROM. By the way, I have contacted the help center of the US store, but I have a feeling it should work on the global (EU) version as well.

    Based on new information, it does seem possible to repair the issues caused by converting.

    That said, this guide is still quite relevant. After all, most of the issues people were having were caused by unlocking the bootloader, converting, rooting, and locking the bootloader. The warning for possibility of not being able to unlock have been removed, but the info about restoring to stock before locking has been left.
    1
    I send mine in for a motherboard repair I was rooted and everything I unrooted installed stock firmware and locked the bootloader again once I got the phone back I unlocked the bootloader once again and I am rooted again
    1
    Darn i thought im already dead! i didn't even know how i fixed it hahahaha! but its working now successfully downgraded to android 11 because its the only firmware i found and managed to make it work again combination of alot of research in google and here xda. working 100% imei two of them, finger print and sn are all intact. thanks guys