Weird Night Mode type issue...

Search This thread

zeebone

Member
May 5, 2010
37
8
Clinton Township
So I got my T-Mobile S9+ on Tuesday. I got everything loaded up and restored and at 10pm, I noticed the color shift on the screen into a night mode type color scheme. Whites were turning a yellowish hue. I'm running Nova Launcher as my main launcher and checked all the settings in the phone itself, and nothing is enabled for Night mode. I ended up having to reboot the phone and it was back to normal.

It happened again the last two nights at 10pm EST. No idea why. I've tried everything short of rebuilding the phone (I know most will suggest this, but I'm trying to avoid it for the time factor). Rebooting seems to reset the clock on whatever is doing it and it goes back to normal.

My wife has the same phone and similar setup with Nova and hers doesn't do it. I've tried going back to the stock Samsung launcher when it is happening and nothing seems to fix it.

Anyone had this happen? I don't see any third party apps that would cause this that I have installed. the only app I can think of that even has a night mode is Nova, but that just effects menus and turns them black, not yellow.

*Edit* Sorry, I meant to put this in the Q&A Section.....
 

skinnytoo2

Senior Member
Oct 22, 2007
647
135
Anyone having this blue light issue...blue light is enabled. When I turn on phone from sleep mode it takes like a second to switch to blue. Very weird

Sent from my SM-G965U1 using Tapatalk
 

lessthanzach

Senior Member
May 23, 2008
1,035
384
Redding, CA
EDIT: I Fixed it finally!
I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
Code:
adb shell 'settings list secure
you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
Code:
adb shell 'settings put secure night_display_activated 0'
Code:
adb shell 'settings put secure night_display_auto_mode 0'
This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

(ORIGINAL, not needed, left for posterity)
This needs more attention. I know EXACTLY what this is. You came from a more recent Android device that uses Google's own "night mode" settings. I know, because I did too. I came from the Razer Phone and had night mode enabled on that on schedule. After my screen turned a real dank orange color at night, I started looking for the setting and discovered Samsung's "Blue Filter" setting and that enabling it made the orange color even more dank. So I immediately knew that the setting must have carried over when I logged into my google account and carried over my settings.
I have a workaround, but it is just that, it's not a permanent fix and I'm still trying to figure out how to fix it permanently. You need to install System UI tuner from the playstore. Follow the instructions to make the app work by granting permissions using ADB while connected to a PC. This is not root and will not void your warranty as such. From here, you can either just disable "Night Mode" under the miscellaneous tab or you can go to the playstore and install "Nougat / Oreo Quick Settings" which will allow you to add the toggle for "Night Mode" to your quick settings pull down bar. Unfortunately, you have to do this every night to get rid of the ugly orange color.

I've tried disabling the setting on my Razer and syncing everything in my google account from that phone, then restarting my galaxy and hoping that the settings would transfer over, but it hasn't worked. My fear is that I will have to factory reset the Galaxy, go back to Razer, toggle the night mode on and back off. Sync settings, then sign back into my galaxy and hopefully the settings will not come back this time. I just haven't because I don't want to set EVERYTHING back up again, ugh.

If anyone is aware of how to disable the "Night Mode" schedule feature in a different way without factory resetting the device, please let me know. Thanks!
 
Last edited:

lessthanzach

Senior Member
May 23, 2008
1,035
384
Redding, CA
  • Like
Reactions: cawith

zeebone

Member
May 5, 2010
37
8
Clinton Township
LOL. Jesus. My long-winded solution above yours looks barbaric now. Good thing I wasted a good evening sifting through ADB commands. Good on you for finding this and posting this. Nova saves the day again.

Wish I had waited a little bit longer and had done this. I ended up backing everything up to my SD Card using Smart Switch and then wiping and rebuilding the phone yesterday afternoon. However, I didn't choose to restore from Google and only from Smart Switch, so the night light setting didn't end up carrying over again.

Good to know I wasn't crazy and that my phone wasn't defective.
 

PorcoPorco

New member
Apr 14, 2018
1
5
I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.
 

genocidalrobot

New member
May 14, 2018
1
0
I was all ready to get adb working and use the above workaround, and / or install nova launcher and fix this issue but THIS WORKED.

THANK YOU it has been bugging me for WEEKS.

I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.
 

Jilleybeans

New member
Jun 21, 2018
1
0
You are amazing! It was the Google play books settings.

Thank you so much! It just started happening last week so I knew that it didn't come from my smart switch settings. Google play books was on night light settings from 10p-6a. I can see my phone again at night without my screen being yellow or without having to restart my phone. Thank you so much!!! I NEVER would've looked there.
 

Autumnflower

New member
Dec 21, 2018
1
0
Perfect!

This fixed my problem, so thank you! :)
Google play book... who would have guessed..

I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.
 

rogerperk

Senior Member
Aug 11, 2010
639
34
North Carolina
So I got my T-Mobile S9+ on Tuesday. I got everything loaded up and restored and at 10pm, I noticed the color shift on the screen into a night mode type color scheme. Whites were turning a yellowish hue. I'm running Nova Launcher as my main launcher and checked all the settings in the phone itself, and nothing is enabled for Night mode. I ended up having to reboot the phone and it was back to normal.

It happened again the last two nights at 10pm EST. No idea why. I've tried everything short of rebuilding the phone (I know most will suggest this, but I'm trying to avoid it for the time factor). Rebooting seems to reset the clock on whatever is doing it and it goes back to normal.

My wife has the same phone and similar setup with Nova and hers doesn't do it. I've tried going back to the stock Samsung launcher when it is happening and nothing seems to fix it.

Anyone had this happen? I don't see any third party apps that would cause this that I have installed. the only app I can think of that even has a night mode is Nova, but that just effects menus and turns them black, not yellow.

*Edit* Sorry, I meant to put this in the Q&A Section.....
You might have your blue light filter turned on to a specific time. Mine is set to come on at 6 pm and go off at 6 am. Check that in settings.
 

Desmondz

Member
Mar 23, 2018
18
1
Tangerang
EDIT: I Fixed it finally!
I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
Code:
adb shell 'settings list secure
you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
Code:
adb shell 'settings put secure night_display_activated 0'
Code:
adb shell 'settings put secure night_display_auto_mode 0'
This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

Did you tripped your knox warranty, when using this ??..... I want to disable night mode on my note 9.....did adb trigger knox ??? Please advice sir... And thank you
 
  • Like
Reactions: abhi123vj

Vinay_sandy

Member
Jul 25, 2018
27
8
If nothing solves your peoblem then just download systemuituner app from playstore and give it some permission using adb commands and then turn off the night light option in the app.
It helped me .:fingers-crossed:
 

mbhuiyan13

New member
Mar 28, 2018
4
0
Buddy ur basically a lifesaver. Note 10+ fixed too, can confirm!

Buddy the workaround just saved me at least one trip to SES which is like 30 mins away from my house in Long Island, saved me from erasing the phone and restore it which would definitely be a nightmare and also u just saved my one big annoyance with this phone for the first week of usage!! U are the man!!



I had this problem too, and couldn't find an easy solution, until today.

The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

So, where is this setting hidden?

Google Playbook.

Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

Simply turn it off and Voila!

No rooting, no launcher or nothing required.
 

ntelas

Senior Member
Nov 17, 2013
114
14
EDIT: I Fixed it finally!
I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
Code:
adb shell 'settings list secure
you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
Code:
adb shell 'settings put secure night_display_activated 0'
Code:
adb shell 'settings put secure night_display_auto_mode 0'
This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

Huge thanks as you saved me from factory resetting my new Mi 9 Lite. That's why I love the internet.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    EDIT: I Fixed it finally!
    I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
    Code:
    adb shell 'settings list secure
    you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
    Code:
    adb shell 'settings put secure night_display_activated 0'
    Code:
    adb shell 'settings put secure night_display_auto_mode 0'
    This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

    (ORIGINAL, not needed, left for posterity)
    This needs more attention. I know EXACTLY what this is. You came from a more recent Android device that uses Google's own "night mode" settings. I know, because I did too. I came from the Razer Phone and had night mode enabled on that on schedule. After my screen turned a real dank orange color at night, I started looking for the setting and discovered Samsung's "Blue Filter" setting and that enabling it made the orange color even more dank. So I immediately knew that the setting must have carried over when I logged into my google account and carried over my settings.
    I have a workaround, but it is just that, it's not a permanent fix and I'm still trying to figure out how to fix it permanently. You need to install System UI tuner from the playstore. Follow the instructions to make the app work by granting permissions using ADB while connected to a PC. This is not root and will not void your warranty as such. From here, you can either just disable "Night Mode" under the miscellaneous tab or you can go to the playstore and install "Nougat / Oreo Quick Settings" which will allow you to add the toggle for "Night Mode" to your quick settings pull down bar. Unfortunately, you have to do this every night to get rid of the ugly orange color.

    I've tried disabling the setting on my Razer and syncing everything in my google account from that phone, then restarting my galaxy and hoping that the settings would transfer over, but it hasn't worked. My fear is that I will have to factory reset the Galaxy, go back to Razer, toggle the night mode on and back off. Sync settings, then sign back into my galaxy and hopefully the settings will not come back this time. I just haven't because I don't want to set EVERYTHING back up again, ugh.

    If anyone is aware of how to disable the "Night Mode" schedule feature in a different way without factory resetting the device, please let me know. Thanks!
    5
    I had this problem too, and couldn't find an easy solution, until today.

    The problem is that samsung will ask you out of the blue if you wanted to enable the "Nightmode" which is separate from "Blue Light Filter," and the two can overlap. Which is annoying. And you'll find yourself looking everywhere to find the setting to turn it off.

    So, where is this setting hidden?

    Google Playbook.

    Launch google playbook, read something, anything. Click the screen and then the "Aa" icon, for changing brightness/fonts. Then there, click Setting again, and you'll find "Night Light" turned on and scheduled.

    Simply turn it off and Voila!

    No rooting, no launcher or nothing required.
    1
    There's an easy solution to this, if you hadn't switch off the night mode on your previous phone before transferring to the S9:

    https://www.reddit.com/r/GalaxyS9/comments/85blz5/psa_night_light_and_blue_light_filter_overlap
    1
    There's an easy solution to this, if you hadn't switch off the night mode on your previous phone before transferring to the S9:

    https://www.reddit.com/r/GalaxyS9/comments/85blz5/psa_night_light_and_blue_light_filter_overlap

    LOL. Jesus. My long-winded solution above yours looks barbaric now. Good thing I wasted a good evening sifting through ADB commands. Good on you for finding this and posting this. Nova saves the day again.
    1
    EDIT: I Fixed it finally!
    I have no idea if there's an easier way to fix this, but here's what I figured out sifting through adb commands. If you run the command
    Code:
    adb shell 'settings list secure
    you will get a list of many of the device's settings. The one we're modifying is called "Night Display" which is different from what everyone has been calling "Twilight Mode" in my google searches. So all we have to do is run the two following codes:
    Code:
    adb shell 'settings put secure night_display_activated 0'
    Code:
    adb shell 'settings put secure night_display_auto_mode 0'
    This fixed my issue immediately and it persisted through my manual date and time adjustments just to verify and also two reboots. I know ADB commands aren't everyone's cup of tea but it is also a very powerful tool at unfu**ing what manufacturers have fu**ed. Hope it helps others as well!

    Did you tripped your knox warranty, when using this ??..... I want to disable night mode on my note 9.....did adb trigger knox ??? Please advice sir... And thank you
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone