WhatsApp Sniffer issue

Search This thread

SotirisA

New member
Jun 11, 2012
2
1
Hi guys,

I downloaded WhatsApp Sniffer in my HTC Desire, it seems to be working but can't capture any conversation. In short, when I start the app, I can only see the following message:

"There isnn't any conversations yet, wait until one has been captured. Make sure WhatsAppSniffer is listening and if you are on a WPA/WPA2 network, check that the ARP_Spoof is activated."

I've tried the app in both WEP and WPA/WPA2 networks but no luck. My phone is rooted with:
Android version: 2.3.7
Mod Version: CyanogenMod-7-11162011-NIGHTLY-Desire
WhatsApp Messenger: 2.7.8509

Any clues what might be the reason?

Thx,
Sotiris.
 
  • Like
Reactions: hgurbuz78

spooky1976

New member
Oct 2, 2012
3
0
44
Hello all am new @ this site, awesome site... am using whatsapp sniffer or @ least am trying too...
my issue is that @ times it says that ( my devise seem not to be rooted ), I have rooted phone i do have the superuser icon... samsung GS3
and i restart the app, and it runs ok, but it don't capture anything... am i doing something wrong??? i do see that it will not
capture anything in wap or wap2...
any help will be appreciated
 

J053PH_

New member
Nov 10, 2012
2
0
London
Hi.

I'm also wondering the same thing. Just went through the fairly painful process of downgrading my HTC Desire Z Gingerbread to Froyo in order to then gain root, specifically so that I could use WhatsAppSniffer.

The app seems to have installed correctly, it's running fine, the other apps like SuperUser and BusyBox have no problems. I've run the sniffer for several hours on my shared WPA network at home, and for a couple of hours on a shared Open network last night with no results. It could very easily be the case that there were no conversations to capture, but the other possibility is that WhatsApp have fixed the vulnerability. I'm going to keep trying for a couple more days, and on one more network connection. Will confirm if whether or not I get anything here.
 

J053PH_

New member
Nov 10, 2012
2
0
London
Just reading a couple of open-source articles it seems that WhatsApp pushed release 2.8.3 to iPhones on 27th August 2012, and a similar release to Androids around the same time. This release included (relatively poor) encryption. Anyone who has downloaded the update will now be protected from WhatsAppSniffer. Seems that sniffing is still possible if you can fathom this: ezioamodio.it/?p=29. It's beyond me though. #noob
 

Italia77

Senior Member
Dec 3, 2014
138
9
I tried yesterday found on web the versione 1.03 donate root,
also for myself it seems doens't work,
the spoof says that if I'm scanning a WPA/WPA2 network I have to activated the ARP Spoof, otherwise for WEP it doens't need.

But I supposed it worked in one of the two cases, instead the app continue to search but see nothing.
I tried to send a whatsapp message connecting to the same network that sniffer is connecting too, and it see even not my message.

Is it an older version that doesn't work or maybe it needs a rooted phone and mine one is not?

THANKS
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone