Why does the Peacock not work on my Fire Stick 4K?

Search This thread

bird333

Senior Member
Jul 19, 2010
474
18
I have tried several different versions of the Peacock app and none of them will run. They install but when I try to run them they crash. Can anyone explain why?
 

meohmy

Senior Member
Aug 7, 2015
85
19
Are you setting your VPN to the U.S and have you tried the latest update v2.3.3 from 29th April? They seem to have fixed a lot of bugs.
 

bird333

Senior Member
Jul 19, 2010
474
18
Are you setting your VPN to the U.S and have you tried the latest update v2.3.3 from 29th April? They seem to have fixed a lot of bugs.
I tried 2.3.3 but this one says my device is not supported. I had been trying the versions from AFTVnews, but they always crash. I thought it might be because my device is rooted or maybe there is some mod on it that is causing the app to crash. It would at least be nice to know why it doesn't work for me.
 
  • Like
Reactions: king200

SweenWolf

Senior Member
  • Mar 18, 2016
    433
    267
    Paradise
    Amazon Fire TV
    I tried 2.3.3 but this one says my device is not supported. I had been trying the versions from AFTVnews, but they always crash. I thought it might be because my device is rooted or maybe there is some mod on it that is causing the app to crash. It would at least be nice to know why it doesn't work for me.
    the app is crashing because of unofficial bootloader, going back to stock is the only way to resolve this issue.
     
    • Like
    Reactions: bird333

    Top Liked Posts

    • There are no posts matching your filters.
    • 1
      Are you setting your VPN to the U.S and have you tried the latest update v2.3.3 from 29th April? They seem to have fixed a lot of bugs.
      I tried 2.3.3 but this one says my device is not supported. I had been trying the versions from AFTVnews, but they always crash. I thought it might be because my device is rooted or maybe there is some mod on it that is causing the app to crash. It would at least be nice to know why it doesn't work for me.
      1
      I tried 2.3.3 but this one says my device is not supported. I had been trying the versions from AFTVnews, but they always crash. I thought it might be because my device is rooted or maybe there is some mod on it that is causing the app to crash. It would at least be nice to know why it doesn't work for me.
      the app is crashing because of unofficial bootloader, going back to stock is the only way to resolve this issue.