• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Wi-Fi problem after 4.4.2 update. [solved]

Search This thread

mmathiou

Senior Member
Jul 13, 2008
371
166
Athens
To fix wi-fi problem on 4.4.2 android you have to rename Wi-fi Direct device name.
To do that you have to go:
WiFi - then 3 dots - WiFi Direct - 3 dots - Rename Device - HTC One.

thank you very very very very very much !!!!!! me also register an account to thank you. :D:D:D:D:D:D

Unbelievable it worked for me as well!!
I have this phone since 4.1 and I have always connected to my home router a FritzBox 7140 from HTC desire to....to HTC ONE having always the same settings!
Upon upgrading to 4.4.2 it stopped connecting!
By applying the above setting it worked!!!!!

Thank you very much!!
 

zoological

Senior Member
Dec 15, 2012
65
5
Unbelievable it worked for me as well!!
I have this phone since 4.1 and I have always connected to my home router a FritzBox 7140 from HTC desire to....to HTC ONE having always the same settings!
Upon upgrading to 4.4.2 it stopped connecting!
By applying the above setting it worked!!!!!

Thank you very much!!

the rename thing is not working for me, dammit
 

NoAxToGrind

Member
May 15, 2014
9
0
Yet Another Solution to 4.4.2 Wi-Fi Vexing Problem

I've been researching this problem and have gone to several sites. There appear to be several different things that Android 4.4.2 changed and which are affecting WiFi. I've seen several of those and I've frustrated users who haven't solved the problem.

The one solution that I haven't seen posted, but which I believe will work for some, has to do with WiFi (or Wi-Fi) sleep. Go to Settings|Wi-Fi then go to "Advanced" (Advanced works differently on different phones; on the Samsung Galaxy you need to hit the context button (the one on the bottom lower left. Some phones have three dots "...")

Once you get to Advanced you will see "Keep Wi-Fi on during sleep". You may solve the problem if you sent this to "Always." There's controversy about what this does to the battery. Might be good, might be not so good.

By the way, watch out for other 4.4.2 surprises. Google Maps needs to change the way your location works and true to form, they changed the way to turn on the required setting without alerting you. Go to Settings|Location (just because it is on doesn't not mean you have the needed setting) and then Mode. Chose "High Accuracy".

Bluetooth seems to have changed a little bit too. Haven't figured that one out yet.
 

kamaroov

New member
Jun 20, 2014
1
1
the final solution of this issue

i tried it on htc one max 4.4.2 update and its working successfully :laugh::laugh::
firstly itsn't a problem in your device or in the update its your internet confregration on your wirless router

open your router page on the internet then go to interface setup then go to wireless tap

on the left you will see a topic named : Multiple SSIDs Settings infront of it you will see
Authentication Type : choose this choice : WPA2-PSK

i think it will solve this issue if the wireless internet connection already working with you on your other devices like laptop or any other phone

thank you :good::good::good::



 
Last edited:
  • Like
Reactions: SlamTheDoor

Burt Reynolds

Senior Member
Jul 13, 2010
61
5
Make sure Bluetooth name and WiFi direct name match

That's pretty much it. I had tried the WiFi direct rename to HTC One with no luck. But someone mentioned renaming Bluetooth so I checked it out. Different name. Made them both the same and voila!. All good.
 

Hikyuuri

Member
Jan 10, 2010
9
2
My phone will connect to the wireless network, but its speeds are complete crap. I have a 50MB internet connection, phone only gets about 50kb. It uploads just fine (10mbps), but the download is complete crap.

If I change my wireless AP settings from AES to TKIP, phone works fine. But, I am not able to leave it at TKIP (lots of people trying to access my network).

I have a full Cisco network using 1142N APs with a WLCM. This network is the same kind of equipment you would find in a corporate environment.

I have tried the above "fix", but it did nothing to increase my download speeds. At this point, I have faster speeds on the 3G connection than I do on my WiFi.

Anyone got any other ideas?
 

Armando Diaz

New member
Jul 19, 2014
1
0
Another WiFi issue after 4.4.2 update

Slightly different issue after 4.4.2 update on my I9192 Galaxy S4 Mini Duos.

At startup, Android doesn't remember the previous WiFi state and always boots with WiFi disabled.
Incredibly annoying, do you know how could I fix that??

Thanks in advance!
 

Dieselwoof

New member
Aug 22, 2014
1
0
Hope this helps....

Hi guys, this morning I received the notification that an update was ready (4.4.2 update, I live in Italy but my One is from Norway). Well, just ended the update, and since that moment, I' m not able to connect to any Wi-Fi network, even if from favorites. It founds networks, says connection in progress, and then nothing. Has anyone founded this kind of problem?

Sent from my HTC One using xda app-developers app

I had exactly the same issue and tried various fixes which didn't work. The only thing I figured was that I had changed the WPA password recently and it was slightly longer than usual. The one I set it to was 11 characters long, I reverted it back to a previous one which was the minimum 8 characters and it phone works fine now. Seems a bit odd but would appear the 4.4.2 update doesn't like long WPA passwords.
 

nabeelmuzaffar

New member
Nov 11, 2014
1
0
Still no benefit

I have searched over the internet a lot but of no avail. This forum has the most discussion about the problem so I decided to join in and share my problem.

My problem is the same, as you know... The Wifi will say 'Turning on...' but never actually doing so.

I can't change the network or the bluetooth device name as people here have suggested because Wifi direct option is disabled. (Three dots over Wifi Settings > Wifi Direct). Only the last two options, Advanced and Help are enabled.

So I did a factory reset. (I long pressed the Volume Down button and then the switch off button for like 5 seconds and selected Factory reset and then pressed the switch off button). After the reset... guess what... The Wifi still stuck in the Turning on... phase!

I would highly appreciate any help.

One question. After the factory reset, My software version that shows up in the About menu is 4.4.2. Now, I don't remember if it is the default version before the update or is it the updated one. Does the factory reset really erase any software updates? Thanks in advance.
 

RidzVarn

Senior Member
Feb 2, 2015
60
22
38
Kuala Lumpur
www.facebook.com
Hi everyone,

Just want to share a solution I just found, my head meet desk after 2 days looking for this wifi connecting problem but finally fixed it :victory:

in this case, I got DIR 614 router and Android device 4.4.2.

Login into router and go to SETUP tab > Wireless Setting > Manual Wireless Network Setup

&

1. Change router 802.11 mode to : 802.11 b/g/n - by default it was only set to b and g only.
2. Unchecked "Enable auto channel scan" and only set it to Channel 6. - by default it was set to Auto.
3. Change/Set Channel Width to 20/40Mhz
4. Chipher type change to : AES only - by default it was both TKIP & AES

and reboot ( router & device ) & yay! finally it's connected!:angel:

In this case, the default setting is in my router ( DIR 614 ) and may different with other brand.

Good luck :D
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    To fix wi-fi problem on 4.4.2 android you have to rename Wi-fi Direct device name.
    To do that you have to go:
    WiFi - then 3 dots - WiFi Direct - 3 dots - Rename Device - HTC One.
    2
    Sorry guys, I found solution 3 days ago, but didn't post it thinking I was the only with this problem. To solve it, go in settings, Wi-Fi, click on three dots up on the right, advanced and then mark the last voice in the menu (in italian I nave "IP automatico DLNA", and I think in english is " IP automatic DLNA"). It turn works in Wep, wpa, wpa2...everything)
    1
    1. go to your router setting>> wireless setting>> disable the password required.
    2. connect to your home WiFi from your device, see if connected (hope it does)
    3. go to your router setting>> wireless setting>> enable password required (WPA/2)
    4. connect to your home WiFi from your device with the new password.

    It works for me, hope i helped.
    1
    Thanksssss!!!!!!!!!!!

    To fix wi-fi problem on 4.4.2 android you have to rename Wi-fi Direct device name.
    To do that you have to go:
    WiFi - then 3 dots - WiFi Direct - 3 dots - Rename Device - HTC One.

    thank you very very very very very much !!!!!! me also register an account to thank you. :D:D:D:D:D:D
    1
    the final solution of this issue

    i tried it on htc one max 4.4.2 update and its working successfully :laugh::laugh::
    firstly itsn't a problem in your device or in the update its your internet confregration on your wirless router

    open your router page on the internet then go to interface setup then go to wireless tap

    on the left you will see a topic named : Multiple SSIDs Settings infront of it you will see
    Authentication Type : choose this choice : WPA2-PSK

    i think it will solve this issue if the wireless internet connection already working with you on your other devices like laptop or any other phone

    thank you :good::good::good::