WIFI AUTOMATICALLY DISCONNECTS and then connects on android phone :(

Search This thread

bballer_sid

Member
Jan 7, 2013
5
0
Someone please help me out of this ! Have been trying to correct it for a while! Nothing seems to work out for me. Thought of posting it on XDA. I hope u guys help me asap... \\\\first time on XDA/////

So the problem is: I have an android phone MOTOROLA FIRE XT530. I have got wifi , belkin router in my home , which i use to connect my laptop and cell phone to browse on internet! There is no problem in browsing from laptop indicating there is no problem with my wifi settings or anythng related to wifi!

BUT, on my phone, when i turn wifi 'ON' , the wifi works for 2-3 minutes then it automatically disconnects and then instantly reconnects itself! I dont really have problem with this thng but the other day i was upgrading my swype to swype beta and had to download this application but the app is too large sized that in the middle of the downloading my wifi went off thereby stopping the download(n sadly its non resumable). I am a huge fan of swype and have been using it for quite a while now. I want it upgraded at any cost!:mad:


I know this wifi turn on/off problem is faced by many but this is quite a headache nw! I have come to know about 'POWER SAVING MODE' n stuff, but sadly i can't even get to that menu coz i dont know how to! :confused:


Someone plz plz plz , help me as i am stuck with it from a long tym nw! anticipating early n useful replys :fingers-crossed:

-Sid:good:
 

aweosomeabhijeet

Senior Member
Oct 4, 2012
886
972
25
Jaipur
next2tech.net
Someone please help me out of this ! Have been trying to correct it for a while! Nothing seems to work out for me. Thought of posting it on XDA. I hope u guys help me asap... \\\\first time on XDA/////

So the problem is: I have an android phone MOTOROLA FIRE XT530. I have got wifi , belkin router in my home , which i use to connect my laptop and cell phone to browse on internet! There is no problem in browsing from laptop indicating there is no problem with my wifi settings or anythng related to wifi!

BUT, on my phone, when i turn wifi 'ON' , the wifi works for 2-3 minutes then it automatically disconnects and then instantly reconnects itself! I dont really have problem with this thng but the other day i was upgrading my swype to swype beta and had to download this application but the app is too large sized that in the middle of the downloading my wifi went off thereby stopping the download(n sadly its non resumable). I am a huge fan of swype and have been using it for quite a while now. I want it upgraded at any cost!:mad:


I know this wifi turn on/off problem is faced by many but this is quite a headache nw! I have come to know about 'POWER SAVING MODE' n stuff, but sadly i can't even get to that menu coz i dont know how to! :confused:


Someone plz plz plz , help me as i am stuck with it from a long tym nw! anticipating early n useful replys :fingers-crossed:

-Sid:good:

Open app drawer>>Settings>>Wireless and Network>>Wi-Fi settings>>(now tap first soft key to see options)>>select advanced.
Now just tap on Wi-Fi sleep than tap on "Never"
Actually as the screen turns off wifi too turns off with that.
Hope it fixes your issue.

Sent from my XT530 using xda app-developers app
 
  • Like
Reactions: gameplayerdo2

bballer_sid

Member
Jan 7, 2013
5
0
Open app drawer>>Settings>>Wireless and Network>>Wi-Fi settings>>(now tap first soft key to see options)>>select advanced.
Now just tap on Wi-Fi sleep than tap on "Never"
Actually as the screen turns off wifi too turns off with that.
Hope it fixes your issue.

Sent from my XT530 using xda app-developers app



Thnx for ur response but I knew this thing and my setting is already set to never! still the problem presists! :(
 

xoulseekr

Member
Oct 20, 2012
28
6
Try data reset. If that doesn't work, the issue is with router.

Sometimes I too have similar problem with my xperia. But the problem disappear after rebooting the phone and/or router.
I think it related to your phone's uptime. As the more the uptime, the memory tends to be fragmented and it has impact to wifi drivers (?).
:D
 

dougieescobar

Member
Jan 8, 2013
10
0
Kingston
it happens regardless of the never option

Try data reset. If that doesn't work, the issue is with router.

Sent from my XT530 using xda app-developers app

Hey I'm a noob but I have been having the same issue, When I initially got the phone there was no issue I have a Netgear router at home which uses wireless G, my dad bought me a wireless n router, belkin to be exact and i have notices that the wifi drops ever so often. My wifi settings is also set to never.
 

bballer_sid

Member
Jan 7, 2013
5
0
Hey I'm a noob but I have been having the same issue, When I initially got the phone there was no issue I have a Netgear router at home which uses wireless G, my dad bought me a wireless n router, belkin to be exact and i have notices that the wifi drops ever so often. My wifi settings is also set to never.

hey mate, plz hit me up if u solve this issue! I dont want a factory reset.. Backing up all data is itself a pain in the butt! :\
 

bballer_sid

Member
Jan 7, 2013
5
0
yap.. and probably it's because the hardware problem.. have you tried to connect to another router wifi?

bro, i didn't connect my phone to any router oder than mine. But, i work on my pc with the same belkin router. No issues come up with that. Are u trying to indicate that my phone might have a hardware issue?
 

bballer_sid

Member
Jan 7, 2013
5
0
Solved

Guys hang on looks like a found a solution to this crap.

I carefully observed what happened when my wifi turned off automatically. My phone flashed a message "Get IP address fail, please check wifi password or wifi app status"..

I thought of making my wifi setting from dynamic to static. I used "ipconfig/all" in my cmd to get the details for setting up static ip. i rebooted both my phone and router. And bang!!! It has not been showing the problem now.! I've been using it for 10 minutes now at a stretch ( for the first time).. Am happy and hope that it doesnt recur. Will let u guys know , if the prob comes back!
 

Dim4ou

New member
May 26, 2014
1
0
Hello guys

Guys hang on looks like a found a solution to this crap.

I carefully observed what happened when my wifi turned off automatically. My phone flashed a message "Get IP address fail, please check wifi password or wifi app status"..

I thought of making my wifi setting from dynamic to static. I used "ipconfig/all" in my cmd to get the details for setting up static ip. i rebooted both my phone and router. And bang!!! It has not been showing the problem now.! I've been using it for 10 minutes now at a stretch ( for the first time).. Am happy and hope that it doesnt recur. Will let u guys know , if the prob comes back!

Hello guys i have a problem it is simmilar to your's. Im a noob maybe but the problem is that i connect to my internet in PC and phone to phone works good atleast till i go to google play or some internet apk then it starts the tragedy connect dissconnect connect dissconnect connect dissconnect connect dissconnect connect dissconnect all this for a 3 seccond window !!! please help me this is very stupid i cant use nothing i go to my browser and same connect dissconnect connect dissconnect connect dissconnect connect dissconnect Please find something i just dont know what to do and its making me mad/Crazy
 

bhasayMUFC

New member
Apr 7, 2015
1
0
I'm so pissed now

Someone please help me out of this ! Have been trying to correct it for a while! Nothing seems to work out for me. Thought of posting it on XDA. I hope u guys help me asap... \\\\first time on XDA/////

So the problem is: I have an android phone MOTOROLA FIRE XT530. I have got wifi , belkin router in my home , which i use to connect my laptop and cell phone to browse on internet! There is no problem in browsing from laptop indicating there is no problem with my wifi settings or anythng related to wifi!

BUT, on my phone, when i turn wifi 'ON' , the wifi works for 2-3 minutes then it automatically disconnects and then instantly reconnects itself! I dont really have problem with this thng but the other day i was upgrading my swype to swype beta and had to download this application but the app is too large sized that in the middle of the downloading my wifi went off thereby stopping the download(n sadly its non resumable). I am a huge fan of swype and have been using it for quite a while now. I want it upgraded at any cost!:mad:


I know this wifi turn on/off problem is faced by many but this is quite a headache nw! I have come to know about 'POWER SAVING MODE' n stuff, but sadly i can't even get to that menu coz i dont know how to! :confused:


Someone plz plz plz , help me as i am stuck with it from a long tym nw! anticipating early n useful replys :fingers-crossed:

-Sid:good:

I have a weird problem. I own a Sony Xperia M and a Toshiba Satellite Laptop. Whenever I turn on the wifi of my phone, the laptop's wifi no longer works. Not only on my home's wifi but this condition applies on each and every wifi I've ever tried connecting. Can anyone help me, please?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Someone please help me out of this ! Have been trying to correct it for a while! Nothing seems to work out for me. Thought of posting it on XDA. I hope u guys help me asap... \\\\first time on XDA/////

    So the problem is: I have an android phone MOTOROLA FIRE XT530. I have got wifi , belkin router in my home , which i use to connect my laptop and cell phone to browse on internet! There is no problem in browsing from laptop indicating there is no problem with my wifi settings or anythng related to wifi!

    BUT, on my phone, when i turn wifi 'ON' , the wifi works for 2-3 minutes then it automatically disconnects and then instantly reconnects itself! I dont really have problem with this thng but the other day i was upgrading my swype to swype beta and had to download this application but the app is too large sized that in the middle of the downloading my wifi went off thereby stopping the download(n sadly its non resumable). I am a huge fan of swype and have been using it for quite a while now. I want it upgraded at any cost!:mad:


    I know this wifi turn on/off problem is faced by many but this is quite a headache nw! I have come to know about 'POWER SAVING MODE' n stuff, but sadly i can't even get to that menu coz i dont know how to! :confused:


    Someone plz plz plz , help me as i am stuck with it from a long tym nw! anticipating early n useful replys :fingers-crossed:

    -Sid:good:

    Open app drawer>>Settings>>Wireless and Network>>Wi-Fi settings>>(now tap first soft key to see options)>>select advanced.
    Now just tap on Wi-Fi sleep than tap on "Never"
    Actually as the screen turns off wifi too turns off with that.
    Hope it fixes your issue.

    Sent from my XT530 using xda app-developers app
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone