• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

wifi calling on Xfinity Mobile with Pixel OG

Search This thread

bvogt

Member
Jan 7, 2011
10
0
Hello, I have an OG Pixel (Pixel 1) and I had been on Google Fi but recently switched to Xfinity Mobile (Verizon MVNO) and can't get the wifi calling to work. Xfinity mobile says that it is activated on their end. It's activated on the phone. I checked the Testing Menu (dial *#*#4636#*#* on dialpad) and Wifi calling is provisioned (it's also grayed out so I can't change it).

So, when I put the phone in airplane mode and try to make a wifi call I get the message, " turn off airplane mode or connect to a wireless network to make a call".

I'm on Android 10. I've gone through this forum and tried the suggestions that others have had with similar problems on Verizon, but can't find anything that works.

Suggestions?
 

bbarnes1

Senior Member
Dec 2, 2008
66
9
I'm experiencing the exact same issue on Verizon. No matter what I do, i can't place a wifi call. Tried wfc_ims_mode 2, tried reprovisioning, switch to LOS, same issues....

Sorry that i'm no help
 

bvogt

Member
Jan 7, 2011
10
0
I fixed it, but not in the way I had hoped. I ended up doing a factory reset of the phone and after the factory reset the wifi calling started working. The factory reset is a pain because it requires lots of backing up and redoing settings, but I'm glad I was able to finally get it to work.
 

bbarnes1

Senior Member
Dec 2, 2008
66
9
I've done several factory resets.... Thats why i tried lineage OS. The frustrating part is it just stopped working at one point.... Verizon support also said everything is setup on their end

---------- Post added at 09:48 PM ---------- Previous post was at 09:35 PM ----------

I'm going to relock the bootloader and see if that does it.... which will factory reset it again
 

bbarnes1

Senior Member
Dec 2, 2008
66
9
I've done several factory resets.... Thats why i tried lineage OS. The frustrating part is it just stopped working at one point.... Verizon support also said everything is setup on their end

---------- Post added at 09:48 PM ---------- Previous post was at 09:35 PM ----------

I'm going to relock the bootloader and see if that does it.... which will factory reset it again

Should not have done that..... didn't fix it.... can't unlock my bootloader again