WiFi Calling / VoLTE on Mi 9

Search This thread

lightcao

Senior Member
Dec 25, 2014
54
34
Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*


Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. When you first enable VoWiFi, it is important that you get into this menu and change it to WiFi preferred or WiFi Calling won't work.

UPDATE:

Manually creating your carrier APN worked great for me. Been testing it for about 2 weeks and I haven't had any issues with VoLTE/VoWiFi. For example, for me on T-Mobile, I created a new one with the following settings. The important part I'm guessing is the APN type. Also make sure that your carrier has enabled WiFi Calling on their end as well.

APN: fast.t-mobile.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMC : 310
MNC: 260
APN type: default,supl,mms,ims,cbs
APN protocol: IPv4/IPv6
APN roaming protocol: IPv4/IPv6
 
Last edited:

fp1707

Senior Member
Feb 25, 2016
709
116
Los Angeles
Can verify, works with Chinese Mi 9 8GB 128GB version. I'm also on T-Mobile. Now there is "HD" written on the signal icon.

---------- Post added at 08:24 AM ---------- Previous post was at 08:22 AM ----------

On a side note, since you're on T-Mobile US, are you getting LTE+? I was showing LTE+ on my Mix 2S and Mi 8, but doesn't show up on my Mi 9.
It does when I'm outside. RN it isn't showing tho, I'm in the basement. I'm pretty sure I've seen it before when I'm on the bus or something
 

mNiosu

Senior Member
Mar 4, 2010
256
61
Bucharest
Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*


Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. Another thing is that WiFi calling might glitch out if you have cellular on. It just randomly loses WiFi Calling. To solve this, I've been keeping my phone airplane mode with WiFi on and haven't experienced any type of disruption of service. Calls sounds great.
Worked like a charm on Romania's Orange network. Both VoLTE and VoWiFi seem to work well.
Thank you for the tip.
On a side note, since you're on T-Mobile US, are you getting LTE+? I was showing LTE+ on my Mix 2S and Mi 8, but doesn't show up on my Mi 9.
I don't know if it helps, but in Romania on Orange I have 4G+ almost all the time while on my old Oneplus 5T I didn't...
 
  • Like
Reactions: marko94

sushi143

Senior Member
Oct 8, 2009
113
16
Michigan
Hmm...I've activated both too but only get the volte option, no wifi calling toggle switch. Tmobile USA running no root, stock miui 10.2.3. Did anyone on tmobile USA get wifi calling to work? Also, if you did, does it also activate wifi texting?

Update: guessing the volte doesn't require a restart but wifi calling requires a restart. To those who run into the same prob as me.
 
Last edited:

crying

Senior Member
Apr 2, 2007
235
20
Paris
unlike you, since the last update 10.2.24.0 I lost the option volte/vowifi, when I try to reactivate it, the phone tell me it's enabled for the SIM 2 but I have no sim two,
if i swap the sim card it tell me activated for the sim 1 ...
 

age-pi

Member
Dec 8, 2015
14
4
I activated volte and wifi calling, but when I go on flight mode and activate wifi, wifi calling is not working and there is no sign in status bar too. I am Vodafone Germany and on my Samsung it was working.
How did you get it working?

Sent from my [device_name] using XDA-Developers Legacy app

Did a quick test on mine (T-Mobile/Germany) and it's working. I just used the dial-codes and enabled wifi calling. Had to change the preferred connection type to wifi-prio though - wasn''t working with cellular-prio and flight mode before.
 

Attachments

  • 2019-05-08_161510.jpg
    2019-05-08_161510.jpg
    47.7 KB · Views: 4,300
  • 2019-05-08_162238.jpg
    2019-05-08_162238.jpg
    97.6 KB · Views: 4,308
  • Like
Reactions: putti71

mslezak

Senior Member
Dec 12, 2016
326
289
Houston
It works!

Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*


Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. Another thing is that WiFi calling might glitch out if you have cellular on. It just randomly loses WiFi Calling. To solve this, I've been keeping my phone airplane mode with WiFi on and haven't experienced any type of disruption of service. Calls sounds great.

Awesome it said not supported by carrier on Xiaomi.eu ROM but now it is working
 

Attachments

  • Screenshot_2019-05-08-10-04-20-521_com.miui.home.jpg
    Screenshot_2019-05-08-10-04-20-521_com.miui.home.jpg
    189 KB · Views: 2,413

gui.aguiar

Senior Member
Jan 13, 2011
163
3
These codes Wlworks well to enable volte. But there isnt Amy volte symbol in my phone. So os volte working in my mi9? My s7 always had a symbol for volte.
 

jhs39

Senior Member
Oct 8, 2015
2,486
718
Chicago
These codes Wlworks well to enable volte. But there isnt Amy volte symbol in my phone. So os volte working in my mi9? My s7 always had a symbol for volte.
Download a signal app from the Play Store and make a phone call. If you still have 4G when making the call Volte is working. If the signal drops to 3G after the call connects Volte is not working.
 
  • Like
Reactions: gui.aguiar

gui.aguiar

Senior Member
Jan 13, 2011
163
3
I have a Mi 9 global version running the latest stable global Room. I'm trying to turn VOLTE on, but I'm nota being sucessfully.

I've tried enable It via MCC code (*#*#4636#*#*) but It doesnt work. The option to enable VOLTE os greyed out.

How can I enable It? My old s7 suport VOLTE with the same sim card.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

    Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

    VoLTE *#*#86583#*#*
    VoWIFI *#*#869434#*#*


    Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

    Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. When you first enable VoWiFi, it is important that you get into this menu and change it to WiFi preferred or WiFi Calling won't work.

    UPDATE:

    Manually creating your carrier APN worked great for me. Been testing it for about 2 weeks and I haven't had any issues with VoLTE/VoWiFi. For example, for me on T-Mobile, I created a new one with the following settings. The important part I'm guessing is the APN type. Also make sure that your carrier has enabled WiFi Calling on their end as well.

    APN: fast.t-mobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMC : 310
    MNC: 260
    APN type: default,supl,mms,ims,cbs
    APN protocol: IPv4/IPv6
    APN roaming protocol: IPv4/IPv6
    5
    I'm updating my last post with the "definitive" fix for Wifi & VoLTE, including problems with IMS registration & RCS.
    - For those on mi.com, don't hesitate to go to this post
    - I'm ranting a bit on mi.com, but the way they build roms is an absolute nightmare - we know where the money was saved now....


    FIX FOR VOLTE & VOWIFI, RCS on MIUI STOCK ROM
    - Root needed
    - ActivityManager 3.3.0 strongly recommended (com.sdex.activityrunner)
    - Tested on STOCK EEA 10.2.30
    - Please CANCEL any "dialer code" you might have input before, as it only works on one card slot ( VoLTE *#*#86583#*#* VoWIFI *#*#869434#*#* )

    > It should say "Carrier check enabled"

    I. Edit the SYSTEM/BUILD.PROP file
    Remove the Xiaomi blocking lines in the build.prp & add/modify :
    persist.dbg.ims_volte_enable=1
    persist.dbg.volte_avail_ovr=1
    persist.dbg.vt_avail_ovr=1
    persist.dbg.wfc_avail_ovr=1
    persist.radio.VT_ENABLE=1
    persist.radio.rat_on=combine
    persist.radio.data_ltd_sys_ind=1
    persist.radio.data_con_rprt=1
    persist.radio.calls.on.ims=1
    persist.radio.volte.dan_support=true
    persist.data.iwlan=1
    persist.data.iwlan.ipsec.ap=1
    persist.sys.cust.lte_config=true
    persist.rcs.supported=1

    >> Check for duplicates !

    2. Reset and empty the app: "Google Carrier Services" (com.google.android.ims.apk)
    3. Reboot
    4. You should now have "IMS registered" when typing *#*4636#*#*

    Additionnal fixes if needed====================================

    Additionnal fixing can be made using the app "Activity Manager" listed at the beginning
    > Launch "Modem Config" (com.xiaomi.mbnloader), find your carrier, enable, reboot
    > Launch "com.qualcom.qti.ims.ImsSettings", input your number using the international version (+01999999999 for example)

    More Additionnal checking if it still doesn't work
    Check apns-conf.xml for your carrier IMS config, try IPV4V6 where necessary

    NOTE : VoLTE has to be enabled by your carrier on your phone plan. Sometimes they will tell you "Your phone isn't listed as compatible - Of course because Xiaomi blocked it - but I can activate VoLTE anyway - Say yes"

    To continue, the /system/etc/APNS-conf.xml is absolutely outdated, most of the info here seems to have been taken on a bad google check.
    - I suggest everyone check this file and their carrier, add IPV4V6 support, etc
    3
    I have a Mi 9 global version running the latest stable global Room. I'm trying to turn VOLTE on, but I'm nota being sucessfully.

    I've tried enable It via MCC code (*#*#4636#*#*) but It doesnt work. The option to enable VOLTE os greyed out.

    How can I enable It? My old s7 suport VOLTE with the same sim card.

    The codes enable/disable checking for VOLTE. You should do the codes until both say disabled. Then you can go into configuration where the options will no longer be greyed out so you can force to use or not use.
    2
    Are you on the EEA ROM? Xiaomi is having problems with bugs in MIUI builds that are supposed to be stable but the EEA ROM for the MI 9 seems to be especially snake bitten.
    If you are on the EEA ROM I would seriously consider switching to the Global instead which doesn't seem to be experiencing issues as serious as those on EEA.

    Nope, that's just Xiaomi doing an absolute garbage on that phone.
    There is a line, in the build.prop, REMOVING VOLTE in EUROPE on PURPOSE.
    WTF ?!!!

    There is a specific code to remove VoLTE and it's even called MIUI DELETE, I'm beyond words
    #set ims related prop
    # MIUI DEL: START
    #persist.dbg.ims_volte_enable=1
    #persist.dbg.volte_avail_ovr=1
    #persist.dbg.vt_avail_ovr=1
    #persist.dbg.wfc_avail_ovr=1
    # END

    You have to be rooted
    MAKE A BACKUP
    Remove the # on that build.prop on the 4 persists
    Add the other two persist if they aren't here by default
    Save and reboot

    On a side note, I will consider going to the global rom, but there might be some specific vendor shiz in the EEA Rom i'm currently investigating. I'm also trying to get the Google DIaler Visual VoiceMail to be set up, and it's a nightmare to get carrier info (vvm_type_OMTP parameters for example)
    - For those being rooted and having a problem on EEA roms with the above activated, try downloading Activity Manager 3.3.0 (not on the play store for obvious reasons)
    - Look for Modem Config
    - Check if your country is in here, and your operator if you're lucky
    > Path is Vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/eu for europe, I'm unsure about which folder is the generic/generic one (for MVNO for example, my guess is on "DT" but unsure)
    2
    I think I found a fix for good. Create a new APN and call it whatever you want. Here are the settings I used for T-Mobile. The most important thing I think is adding ims to the APN type.

    APN: fast.t-mobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMC : 310
    MNC: 260
    APN type: default,supl,mms,ims,cbs
    APN protocol: IPv4/IPv6
    APN roaming protocol: IPv4/IPv6

    With these settings, no more issues with VoLTE calls or WiFi Calls. Sound has gone through for me for every call I've gotten since and WiFi calling stays on forever instead of more than 5 mins at a time. Missed calls are no longer a concern. I hope this helps someone.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone