WiFi Calling / VoLTE on Mi 9

Search This thread
D

drnikhilp

Guest
Works with Three (3) UK on Mi 10 Ultra MIUI 12.0.13

VoLTE *#*#86583#*#*
VoWIFI *#*#869434#*#*
Thank you very much- this works for me! :good:
I'm using Xiaomi Mi 10 Ultra running MIUI 12:good:.0.13 stable verison with Chinese ROM
My carrier is Three (3) UK.
Many thanks once again!
 

Danchibald

Senior Member
Dec 10, 2006
498
126
Zagreb
1. Go to Settings->SIM cards and mobile networks->choose appropriate primary SIM if You have two SIM's and edit APN's from this SIM (use guide from the beginning of this post to do this, just throw out "mms". MMS service has it's own separate APN)



2. Install com.google.android.ims.apk (download this apk from apkmirror).



3. Install com.activitymanager.apk



4. Run activitymanager app, find com.xiaomi.mbnloader and choose Your carrier.



5. Again in activirymanager app find com.qualcom.qti.ims.ImsSettings and enter Your SIM international number.



6. After this, best will be to reboot and after successful reboot enter dial codes from beginning of this guide to activate (in fact this disables checking from provider side) VoLTE and VoWiFi, after this best will be to again reboot your phone.



I hope that this answers will help You?!



P.S.

For God sake please use different color to emphasize Your question second time, this yellowish is horrible and unreadable!!!

And you did all that without root? I have Mi 10T Pro, tried to follow your steps, but I cannot find com.xiaomi.mbnloader and com.qualcom.qti.ims.ImsSettings?! Maybe because of MIUI 12?
 

Jehonan

Senior Member
Apr 27, 2018
362
107
And you did all that without root? I have Mi 10T Pro, tried to follow your steps, but I cannot find com.xiaomi.mbnloader and com.qualcom.qti.ims.ImsSettings?! Maybe because of MIUI 12?

Yep!
All without root access on MIUI 10!
But You have a right, let's just say that this "guide" is old and obsolete now.
Unfortunately new MIUI comes with new issues and obstacles but usually keeps errors and miss features from previous ROM iterations.
Beauty of Xiaomi's MIUI ecosystem.
 

Danchibald

Senior Member
Dec 10, 2006
498
126
Zagreb
Yep!

All without root access on MIUI 10!

But You have a right, let's just say that this "guide" is old and obsolete now.

Unfortunately new MIUI comes with new issues and obstacles but usually keeps errors and miss features from previous ROM iterations.

Beauty of Xiaomi's MIUI ecosystem.
Suddenly today... I didn't do anything [emoji23][emoji23][emoji23] Screenshot_2020-11-24-12-10-32-725_com.teslacoilsw.launcher.jpg
 

holymoz

Senior Member
Oct 25, 2013
868
263
Ragusa
tried almost everything but never had volte on my mi 9 lite despite is compatible from carrier.
anyway cant try the modem config thing because on miui12 there is any modem config option, anyone can help?
 

T-lander

New member
May 6, 2021
1
0
Thanks!

This works on my Xiaomi MI 9 (M1902F1G) too using MIUI 12.0.5 in Sweden. I.e. settings for VoLTE and VoWiFi show up in Settings > SIM Cards & mobile networks > Sim Card Settings for both SIMs in my phone. The status bar doesn't change though, so it seems that my carriers and the current WiFi support neither VoLTE or VoWiFi.

I've included the settings both before and after entering the codes in the dialer.
 

Attachments

  • Screenshot_2021-05-06-14-18-12-502_com.android.phone.jpg
    Screenshot_2021-05-06-14-18-12-502_com.android.phone.jpg
    191.1 KB · Views: 63
  • Screenshot_2021-05-06-14-30-39-587_com.android.phone.png
    Screenshot_2021-05-06-14-30-39-587_com.android.phone.png
    194.6 KB · Views: 63

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    Just wanted to share my experience with WiFi Calling. I am in the US on T-Mobile and WiFi calling has been working for me surprisingly. VoLTE has also been working wonderfully. I've tested this on a Global Mi 9 running Stock and the Xiaomi.eu rom.

    Enter these codes into the Dialer to enable the options in Settings. (Settings < SIM Cards & mobile networks < Sim Card Settings < VoLTE Enabled/Make Calls using WLAN)

    VoLTE *#*#86583#*#*
    VoWIFI *#*#869434#*#*


    Things should work after you enable the two options. This depends on whether or not your carrier supports it and your e911 address set (US only?).

    Some issues you might run into is that the option for Network Preference is greyed out and you will unable to change that option. I've had some success if you disable it and re-enable it and click on that option really fast, it will go through. When you first enable VoWiFi, it is important that you get into this menu and change it to WiFi preferred or WiFi Calling won't work.

    UPDATE:

    Manually creating your carrier APN worked great for me. Been testing it for about 2 weeks and I haven't had any issues with VoLTE/VoWiFi. For example, for me on T-Mobile, I created a new one with the following settings. The important part I'm guessing is the APN type. Also make sure that your carrier has enabled WiFi Calling on their end as well.

    APN: fast.t-mobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMC : 310
    MNC: 260
    APN type: default,supl,mms,ims,cbs
    APN protocol: IPv4/IPv6
    APN roaming protocol: IPv4/IPv6
    5
    I'm updating my last post with the "definitive" fix for Wifi & VoLTE, including problems with IMS registration & RCS.
    - For those on mi.com, don't hesitate to go to this post
    - I'm ranting a bit on mi.com, but the way they build roms is an absolute nightmare - we know where the money was saved now....


    FIX FOR VOLTE & VOWIFI, RCS on MIUI STOCK ROM
    - Root needed
    - ActivityManager 3.3.0 strongly recommended (com.sdex.activityrunner)
    - Tested on STOCK EEA 10.2.30
    - Please CANCEL any "dialer code" you might have input before, as it only works on one card slot ( VoLTE *#*#86583#*#* VoWIFI *#*#869434#*#* )

    > It should say "Carrier check enabled"

    I. Edit the SYSTEM/BUILD.PROP file
    Remove the Xiaomi blocking lines in the build.prp & add/modify :
    persist.dbg.ims_volte_enable=1
    persist.dbg.volte_avail_ovr=1
    persist.dbg.vt_avail_ovr=1
    persist.dbg.wfc_avail_ovr=1
    persist.radio.VT_ENABLE=1
    persist.radio.rat_on=combine
    persist.radio.data_ltd_sys_ind=1
    persist.radio.data_con_rprt=1
    persist.radio.calls.on.ims=1
    persist.radio.volte.dan_support=true
    persist.data.iwlan=1
    persist.data.iwlan.ipsec.ap=1
    persist.sys.cust.lte_config=true
    persist.rcs.supported=1

    >> Check for duplicates !

    2. Reset and empty the app: "Google Carrier Services" (com.google.android.ims.apk)
    3. Reboot
    4. You should now have "IMS registered" when typing *#*4636#*#*

    Additionnal fixes if needed====================================

    Additionnal fixing can be made using the app "Activity Manager" listed at the beginning
    > Launch "Modem Config" (com.xiaomi.mbnloader), find your carrier, enable, reboot
    > Launch "com.qualcom.qti.ims.ImsSettings", input your number using the international version (+01999999999 for example)

    More Additionnal checking if it still doesn't work
    Check apns-conf.xml for your carrier IMS config, try IPV4V6 where necessary

    NOTE : VoLTE has to be enabled by your carrier on your phone plan. Sometimes they will tell you "Your phone isn't listed as compatible - Of course because Xiaomi blocked it - but I can activate VoLTE anyway - Say yes"

    To continue, the /system/etc/APNS-conf.xml is absolutely outdated, most of the info here seems to have been taken on a bad google check.
    - I suggest everyone check this file and their carrier, add IPV4V6 support, etc
    3
    I have a Mi 9 global version running the latest stable global Room. I'm trying to turn VOLTE on, but I'm nota being sucessfully.

    I've tried enable It via MCC code (*#*#4636#*#*) but It doesnt work. The option to enable VOLTE os greyed out.

    How can I enable It? My old s7 suport VOLTE with the same sim card.

    The codes enable/disable checking for VOLTE. You should do the codes until both say disabled. Then you can go into configuration where the options will no longer be greyed out so you can force to use or not use.
    2
    Are you on the EEA ROM? Xiaomi is having problems with bugs in MIUI builds that are supposed to be stable but the EEA ROM for the MI 9 seems to be especially snake bitten.
    If you are on the EEA ROM I would seriously consider switching to the Global instead which doesn't seem to be experiencing issues as serious as those on EEA.

    Nope, that's just Xiaomi doing an absolute garbage on that phone.
    There is a line, in the build.prop, REMOVING VOLTE in EUROPE on PURPOSE.
    WTF ?!!!

    There is a specific code to remove VoLTE and it's even called MIUI DELETE, I'm beyond words
    #set ims related prop
    # MIUI DEL: START
    #persist.dbg.ims_volte_enable=1
    #persist.dbg.volte_avail_ovr=1
    #persist.dbg.vt_avail_ovr=1
    #persist.dbg.wfc_avail_ovr=1
    # END

    You have to be rooted
    MAKE A BACKUP
    Remove the # on that build.prop on the 4 persists
    Add the other two persist if they aren't here by default
    Save and reboot

    On a side note, I will consider going to the global rom, but there might be some specific vendor shiz in the EEA Rom i'm currently investigating. I'm also trying to get the Google DIaler Visual VoiceMail to be set up, and it's a nightmare to get carrier info (vvm_type_OMTP parameters for example)
    - For those being rooted and having a problem on EEA roms with the above activated, try downloading Activity Manager 3.3.0 (not on the play store for obvious reasons)
    - Look for Modem Config
    - Check if your country is in here, and your operator if you're lucky
    > Path is Vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/eu for europe, I'm unsure about which folder is the generic/generic one (for MVNO for example, my guess is on "DT" but unsure)
    2
    I think I found a fix for good. Create a new APN and call it whatever you want. Here are the settings I used for T-Mobile. The most important thing I think is adding ims to the APN type.

    APN: fast.t-mobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMC : 310
    MNC: 260
    APN type: default,supl,mms,ims,cbs
    APN protocol: IPv4/IPv6
    APN roaming protocol: IPv4/IPv6

    With these settings, no more issues with VoLTE calls or WiFi Calls. Sound has gone through for me for every call I've gotten since and WiFi calling stays on forever instead of more than 5 mins at a time. Missed calls are no longer a concern. I hope this helps someone.