• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question Wifi connectivity problem - Redmi note 10 pro

Search This thread

maxbuzz

New member
Sep 7, 2011
1
0
Hi,

On my new redmi note 10 pro the wifi connection seems to work only in spurts. Even in an app like whatsapp if a send a message it will change from the clock to tick only after a few minutes. And it seems to be working in a batch. Suddenly all messages are sent and received then it will sleep again for some time. WhatsApp web will indicate that phone is disconnected. Mind you have have 2 high speed connections at home and all other devices including some older redmi devices work fine on them.

There is no problem when the phone is connected on the network providers data connection.

Is this a settings issue or a problem with the device

Thanks,
 

Hendik S.

Member
Apr 10, 2019
7
1
Secret
i have problems with wifi connectivity when the signal is low (1 bar). When I play mobile legends, HI3rd or genshin impact, my wifi connectivity turns off and switches to mobile data. I will auto-connect to wifi again after a few seconds. Even though the location of the wifi is not too far and the signal is fast.
 

BlackWhite24

Account currently disabled
Sep 22, 2021
6
0
In the majority cases in the majority of cases WiFi connectivity issues, they can be traced back to the cause of something in the device. The cause can be any small alteration in the settings to a massive hardware issue.

There are a few things that you could take to resolve the issue. The steps to take are listed below. Try each one at a time until you can resolve the problem.
 

HarshaniS

Member
Oct 13, 2021
6
3
Mumbai
www.quickmobile.in
Although it is true that the problem may be caused by some other failure, in most cases the spontaneous disconnection of the WiFi connection is caused by a bad MIUI configuration, specifically, its automatic connection to the networks with better signal . Go to Settings> WiFi> Wi-Fi Assistant.
 

Hendik S.

Member
Apr 10, 2019
7
1
Secret
IMG_20211025_203643.jpg

Sometimes it appears like this.
Turning off the wifi assistant didn't work either.
The problem is solved if you only turn on wifi
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Go to settings>Wifi>Wifi assistant>Disable all options and Your issue will fix.