Wifi disconnected periodically

Search This thread

zihaoyu

New member
Aug 25, 2012
2
0
0
Hi guys this is my first post in HOX forum, I just got mine 1 week ago.

So the main problem I have so far is that my HOX gets disconnected from wifi at home periodically. It just suddenly drops and then reconnects by itself. Does anyone experience the same? If not I'm considering exchange a new one.

Thanks guys!
 
Last edited:

mirGantrophy

Senior Member
Jan 6, 2011
2,103
1,432
0
Hi guys this is my first post in HOX forum, I just got mine 1 week ago.

So the main problem I have so far is that my HOX gets disconnected from wifi at home periodically. It just suddenly drops and then reconnects by itself. Does anyone experience the same? If not I'm considering exchange a new one.

Thanks guys!

I do.. but my router's a POS without an external antennae. so I can't give good answer on that.
 

Vendetta-NY

Senior Member
Jul 30, 2007
198
53
0
Mine does, frequently. I've seen posts regarding the problem, and maybe even a fix. But it doesn't bother me enough to risk breaking something else in the process.

Sent from my HTC One X using XDA Premium HD. In between Force Clo...
 

ECEXCURSION

Senior Member
Aug 20, 2010
2,262
521
0
Minneapolis, MN
www.lego.com
Hi guys this is my first post in HOX forum, I just got mine 1 week ago.

So the main problem I have so far is that my HOX gets disconnected from wifi at home periodically. It just suddenly drops and then reconnects by itself. Does anyone experience the same? If not I'm considering exchange a new one.

Thanks guys!

I upgraded to the beastmode kernel and this started happening to me too.

Running the normal CleanROM 4.5 Rom fixed the problem for me.

Last night I took a logcat of when this disconnect happens... But I dont really know how to debug it. :eek:
 

codyrt

Senior Member
Feb 23, 2010
152
16
0
I have the same issue, with an additional problem. When WiFi disconnects I lose mobile data too. Toggling airplane mode brings back mobile data. WiFi may or may not connect for a little bit afterwards.

Sent from my One X using xda app-developers app
 

18th.abn

Senior Member
Oct 27, 2011
1,531
1,882
0
Why don't you all post up what bands your running on and what you have set on your router. We can map it out a little better:D
 

ECEXCURSION

Senior Member
Aug 20, 2010
2,262
521
0
Minneapolis, MN
www.lego.com
Why don't you all post up what bands your running on and what you have set on your router. We can map it out a little better:D

Good idea 18th.abn. I'll start.

With BeastMode Kernel v3 I have this problem. However I don't have the problem with the stock CleanROM 4.5 kernel. I will test CleanROM V with CleanKernel tonight and see if the problem is still there.

I did get a logcat while the disconnect happened... I took a couple and will have to remember which one was which... I don't really know how to read a logcat file though. Anyone good with linux? Does that help at all?

Problem happens with 2 separate routers. I'm a BAMF so I have 2 routers on my home network, 1 to service each band, and only that band.

Router 1:
Name: Linksys WRT320N
Firmware: DD-WRT v24-sp2 (04/16/10) mega
(SVN revision 14289)
Band: 5Ghz N-only, 40Mhz channel width, control channel lower, wireless channel auto.
Security: WPA2-PSK (Personal), AES

Router 2:
Name: Netgear WGR614v10
Firmware: Stock
Band: 2.4Ghz G-only, channel 11, "up to 54mbps mode"
Security: WPA2-PSK, AES


EDIT: added logcats.

Okay, so I suck at this and have forgotten which one is which. I believe it was my latest one that shows the disconnect (logcat 3). I can make another soon enough.

Logcat1
Logcat2
Logcat2
 
Last edited:
  • Like
Reactions: 18th.abn

18th.abn

Senior Member
Oct 27, 2011
1,531
1,882
0
Do you have the same issue on both routers?


In logcat3, it looks like it connects for just a little bit, then once disconnected, it attempts but can't get fully connected again....it was a quick glance but is that the case?

---------- Post added at 04:24 PM ---------- Previous post was at 04:07 PM ----------

I believe your issue is right here...could be wrong but

W/wpa_supplicant( 7594): [EAP-MSG] EAP [email protected]: eap_methods not available
I/wpa_supplicant( 7594): [SeamLess] This is already connected so rejected to 00:23:69:eb:98:6a
I/wpa_supplicant( 7594): [SeamLess] flag_disconnect is reset i.e., Seamless is give it up


Here is the why its not working, its looking for sim authentification-

To run an EAP-SIM/AKA authentication you will need a client as wpa_supplicant which has access to a (U)SIM. The WLAN access point on the network has to support EAP (which is often transcribed as WPA(2)-RADIUS or WPA(2)-ENTERPRISE). The WLAN AP has to have access to a RADIUS server who handles the authentication and session key generation. The RADIUS server in a productive environment needs for EAP-SIM/AKA access to the home location register (HLR) of the MNO where the (U)SIMs are registered. For testing a file with precreated values for authentication is sufficient.

I think your security is possibly on Wpa2-EAP, Which would explain the eap-sim call, and I doubt you have a RADIUS server giving out session keys to authenticate....double check your security settings
 
Last edited:
  • Like
Reactions: ECEXCURSION

18th.abn

Senior Member
Oct 27, 2011
1,531
1,882
0
To add. Here's a good little write up in optimum router settings with your wireless n. I see a few things in your setup that could be killing or seriously slowing your wireless connections...
http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed

I would DEF. drop to 20mhz from 40mhz, that alone might fix your problem. I had big problems with tabs and phones connecting at 40mhz. 20 should help a lot and don't select auto, keep at 20.

Wireless channel, u have set on lower channels, lower channels are usually busier, there's an app, wifi analyzer, it will show you the least busy channels and then choose A channel, don't let it bounce around and choose for you.

Dd-wrt has an infinite amount of twee king/tuning options, as you already know:) but is extremely easy to make a great connection a worthless one all the same...

Try just switching to 20mhz and nothing else at first......it just might be the root issue for you also
 
Last edited:
  • Like
Reactions: ECEXCURSION

ECEXCURSION

Senior Member
Aug 20, 2010
2,262
521
0
Minneapolis, MN
www.lego.com
Thanks, I'll try that out and report back.

---------- Post added at 12:19 PM ---------- Previous post was at 11:34 AM ----------

Do you have the same issue on both routers?


In logcat3, it looks like it connects for just a little bit, then once disconnected, it attempts but can't get fully connected again....it was a quick glance but is that the case?
My problem is that WiFi was fine for a while, then would disconnect, and then reconnect a second or two later. However, I did take a look at that guide you posted (I really like smallnetbuilder) and made some changes to my setup that they (and you) suggested. I'm still in the process of testing it.


---------- Post added at 04:24 PM ---------- Previous post was at 04:07 PM ----------

I believe your issue is right here...could be wrong but

W/wpa_supplicant( 7594): [EAP-MSG] EAP [email protected]: eap_methods not available
I/wpa_supplicant( 7594): [SeamLess] This is already connected so rejected to 00:23:69:eb:98:6a
I/wpa_supplicant( 7594): [SeamLess] flag_disconnect is reset i.e., Seamless is give it up


Here is the why its not working, its looking for sim authentification-

To run an EAP-SIM/AKA authentication you will need a client as wpa_supplicant which has access to a (U)SIM. The WLAN access point on the network has to support EAP (which is often transcribed as WPA(2)-RADIUS or WPA(2)-ENTERPRISE). The WLAN AP has to have access to a RADIUS server who handles the authentication and session key generation. The RADIUS server in a productive environment needs for EAP-SIM/AKA access to the home location register (HLR) of the MNO where the (U)SIMs are registered. For testing a file with precreated values for authentication is sufficient.

I think your security is possibly on Wpa2-EAP, Which would explain the eap-sim call, and I doubt you have a RADIUS server giving out session keys to authenticate....double check your security settings

My security was (and still is) set as WPA2 Personal with "AES" as the WPA algorithm. This is correct for my home network, is it not? At least that's what I set in the "wireless security" tab of dd-wrt under wireless. I see that there is something under "advanced settings" called "authentication type" which has a radio button for "auto" and "shared key". Right now it's on auto. Think I should change it to "shared key"?

"Authentication Type:
You may choose from Auto or Shared Key. Shared key authentication is more secure, but all devices on your network must also support Shared Key authentication."

To add. Here's a good little write up in optimum router settings with your wireless n. I see a few things in your setup that could be killing or seriously slowing your wireless connections...
http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed

I would DEF. drop to 20mhz from 40mhz, that alone might fix your problem. I had big problems with tabs and phones connecting at 40mhz. 20 should help a lot and don't select auto, keep at 20.

Wireless channel, u have set on lower channels, lower channels are usually busier, there's an app, wifi analyzer, it will show you the least busy channels and then choose A channel, don't let it bounce around and choose for you.

Dd-wrt has an infinite amount of twee king/tuning options, as you already know:) but is extremely easy to make a great connection a worthless one all the same...

Try just switching to 20mhz and nothing else at first......it just might be the root issue for you also
I just made some changes based on the guide you posted. I also made sure to drop the channel width down to 20mhz (I didn't know that made so much of an impact. Kudos for that piece of advice. I chose to use channel 36, 5.180Ghz, based on my testing with wifi analyzer. No one else in the neighborhood has a 5Ghz router (Apparently).

I'll see what tonight's testing yields.
 
Last edited:

18th.abn

Senior Member
Oct 27, 2011
1,531
1,882
0
Awesome, hope it helps! As far as the disconnecting, catalog shows it searching for aes-sim authentification and I don't know why. Its connected, then disconnects because already connected....*LIGHT BULB* Make sure WiFi settings on device is set to 5ghz and not auto.....that may be why its giving a already connected in catlog:)
 

ECEXCURSION

Senior Member
Aug 20, 2010
2,262
521
0
Minneapolis, MN
www.lego.com
Awesome, hope it helps! As far as the disconnecting, catalog shows it searching for aes-sim authentification and I don't know why. Its connected, then disconnects because already connected....*LIGHT BULB* Make sure WiFi settings on device is set to 5ghz and not auto.....that may be why its giving a already connected in catlog:)

Are you saying the WiFi settings on my phone? I won't be able to set it to 5ghz only as I connect to various 2.4ghz networks throughout the day.

I haven't seen the error again yet *knock on wood*

Maybe you fixed it.
 

ECEXCURSION

Senior Member
Aug 20, 2010
2,262
521
0
Minneapolis, MN
www.lego.com
I spoke too soon. I was browsing XDA on my phone, clicked a new page and it disconnected for a second and reconnected immediately.

New logcat. I saved this one only a few seconds after it reconnected. It should say something about WiFi at the very bottom of the logcat file. Do these things even help you guys?

Logcat #4
 

M_J_Nazari

Inactive Recognized Developer
Jul 14, 2010
1,545
2,577
0
35
Bushehr
pda-planet.com
I don't care about the date of threads, i just care about the solution and help others! you just do your job, every forum has a admin moderator, and you are not one of them! so do your job.

Best regards
 
Last edited:
  • Like
Reactions: BIBISIAH

pandasa123

Senior Member
Jul 20, 2013
1,562
1,534
0
South Grafton
I don't care about the date of threads, i just care about the solution and help others! you just do your job, every forum has a admin moderator, and you are not one of them! so do your job.

Best regards
You're solving an issue that doesn't really pertain to the original bug. If anything, start a new thread in general here, but don't bring back this thread because of its lack of relevance.

The issue deals with the WiFi on 4.2.2 (not kitkat) dropping out and coming back in. It's an issue that's based on the kernel we had. Your solution is based on timing out. It's not the same bug.

And just for the record, I'm a user. Just like you are. So what would my job exactly be? Yes, I just started to develop too, but don't accuse me of not caring about helping others. I've been helping out for a long while now. I don't believe we really have "jobs" on this forum because none of us are obligated do anything. It's a bunch of people following etiquette and helping each other.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I don't care about the date of threads, i just care about the solution and help others! you just do your job, every forum has a admin moderator, and you are not one of them! so do your job.

    Best regards
    You're solving an issue that doesn't really pertain to the original bug. If anything, start a new thread in general here, but don't bring back this thread because of its lack of relevance.

    The issue deals with the WiFi on 4.2.2 (not kitkat) dropping out and coming back in. It's an issue that's based on the kernel we had. Your solution is based on timing out. It's not the same bug.

    And just for the record, I'm a user. Just like you are. So what would my job exactly be? Yes, I just started to develop too, but don't accuse me of not caring about helping others. I've been helping out for a long while now. I don't believe we really have "jobs" on this forum because none of us are obligated do anything. It's a bunch of people following etiquette and helping each other.
    1
    Why don't you all post up what bands your running on and what you have set on your router. We can map it out a little better:D

    Good idea 18th.abn. I'll start.

    With BeastMode Kernel v3 I have this problem. However I don't have the problem with the stock CleanROM 4.5 kernel. I will test CleanROM V with CleanKernel tonight and see if the problem is still there.

    I did get a logcat while the disconnect happened... I took a couple and will have to remember which one was which... I don't really know how to read a logcat file though. Anyone good with linux? Does that help at all?

    Problem happens with 2 separate routers. I'm a BAMF so I have 2 routers on my home network, 1 to service each band, and only that band.

    Router 1:
    Name: Linksys WRT320N
    Firmware: DD-WRT v24-sp2 (04/16/10) mega
    (SVN revision 14289)
    Band: 5Ghz N-only, 40Mhz channel width, control channel lower, wireless channel auto.
    Security: WPA2-PSK (Personal), AES

    Router 2:
    Name: Netgear WGR614v10
    Firmware: Stock
    Band: 2.4Ghz G-only, channel 11, "up to 54mbps mode"
    Security: WPA2-PSK, AES


    EDIT: added logcats.

    Okay, so I suck at this and have forgotten which one is which. I believe it was my latest one that shows the disconnect (logcat 3). I can make another soon enough.

    Logcat1
    Logcat2
    Logcat2
    1
    Do you have the same issue on both routers?


    In logcat3, it looks like it connects for just a little bit, then once disconnected, it attempts but can't get fully connected again....it was a quick glance but is that the case?

    ---------- Post added at 04:24 PM ---------- Previous post was at 04:07 PM ----------

    I believe your issue is right here...could be wrong but

    W/wpa_supplicant( 7594): [EAP-MSG] EAP [email protected]: eap_methods not available
    I/wpa_supplicant( 7594): [SeamLess] This is already connected so rejected to 00:23:69:eb:98:6a
    I/wpa_supplicant( 7594): [SeamLess] flag_disconnect is reset i.e., Seamless is give it up


    Here is the why its not working, its looking for sim authentification-

    To run an EAP-SIM/AKA authentication you will need a client as wpa_supplicant which has access to a (U)SIM. The WLAN access point on the network has to support EAP (which is often transcribed as WPA(2)-RADIUS or WPA(2)-ENTERPRISE). The WLAN AP has to have access to a RADIUS server who handles the authentication and session key generation. The RADIUS server in a productive environment needs for EAP-SIM/AKA access to the home location register (HLR) of the MNO where the (U)SIMs are registered. For testing a file with precreated values for authentication is sufficient.

    I think your security is possibly on Wpa2-EAP, Which would explain the eap-sim call, and I doubt you have a RADIUS server giving out session keys to authenticate....double check your security settings
    1
    To add. Here's a good little write up in optimum router settings with your wireless n. I see a few things in your setup that could be killing or seriously slowing your wireless connections...
    http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed

    I would DEF. drop to 20mhz from 40mhz, that alone might fix your problem. I had big problems with tabs and phones connecting at 40mhz. 20 should help a lot and don't select auto, keep at 20.

    Wireless channel, u have set on lower channels, lower channels are usually busier, there's an app, wifi analyzer, it will show you the least busy channels and then choose A channel, don't let it bounce around and choose for you.

    Dd-wrt has an infinite amount of twee king/tuning options, as you already know:) but is extremely easy to make a great connection a worthless one all the same...

    Try just switching to 20mhz and nothing else at first......it just might be the root issue for you also
    1
    Awesome, I bet it was the 40mhz that was doing it:) glad u got it!
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone