• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Wifi keeps turning on automatically

Search This thread

buschris

Senior Member
Jan 20, 2011
506
106
OnePlus 9 Pro
okay fellas, I'm at my Wit's end about this and I really don't like this about Android pie but my Wi-Fi for some reason keeps turning on when I have EVERYTHING turned off! I have Wi-Fi said not to turn on automatically, I have location services turned off I just don't know what to do at this point and I'm really getting sick and tired of my wife I coming on when I don't want it on, is I very RARELY use wifi. I feel this is a gross invasion of privacy. my question is, do I need to root my phone and somehow disable something to get my Wi-Fi to stay off?
 

axelryder

Member
Dec 3, 2010
11
1
okay fellas, I'm at my Wit's end about this and I really don't like this about Android pie but my Wi-Fi for some reason keeps turning on when I have EVERYTHING turned off! I have Wi-Fi said not to turn on automatically, I have location services turned off I just don't know what to do at this point and I'm really getting sick and tired of my wife I coming on when I don't want it on, is I very RARELY use wifi. I feel this is a gross invasion of privacy. my question is, do I need to root my phone and somehow disable something to get my Wi-Fi to stay off?

Did you ever find a solution? I'm having the same problem since the Android 10 update
 

jaseman

Senior Member
Aug 27, 2012
639
172
Spring
I am willing to guess that you both turned off > settings > Wi-Fi & internet > Wi-Fi > Wi-Fi preferences > Turn on Wi-Fi automatically???
If you did, and it is still turning on automatically, then a NETWORK reset may be in order. Also, it may take a removal, or to "forget" a particular Wi-Fi address for it to stay off. Mine stays off, so I hope some of this helps.
 

axelryder

Member
Dec 3, 2010
11
1
I am willing to guess that you both turned off > settings > Wi-Fi & internet > Wi-Fi > Wi-Fi preferences > Turn on Wi-Fi automatically???
If you did, and it is still turning on automatically, then a NETWORK reset may be in order. Also, it may take a removal, or to "forget" a particular Wi-Fi address for it to stay off. Mine stays off, so I hope some of this helps.

I had that off already, but I actually just figured out right after what went wrong; after I made a factory reset to install the Android 10 uprade, one program that I was using "Wifi password key show" reverted back to its default configurations, and they included a setting to turn off and on the Wifi upon turning off and on the screen.