• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Wifi not working (brand new phone, just rooted)

Search This thread

cheshyre

Senior Member
Got a brand new KB2005
I haven't put in a SIM Card yet; haven't even connected it to my Google account (I want to get everything set up first)
So, my first actions were to unlock the bootloader, and root the phone using Magisk.
Build number Oxygen OS 11.0.8.13.KB05AA

My phone won't connect to wifi.
If I go to Wifi Settings, Wifi is off.
If I turn it on, it shuts itself off again.
Wifi was working before I rooted, because it has 1 saved network.

Is this a known issue - no wifi without a Sim - or is something wrong?
Any troubleshooting tips?

Thanks in advance!
 

ULTRAJC

Senior Member
Feb 2, 2021
51
19
Better use "dd" command in modified recovery or use Payload Dumper get boot.img directly form your system or full update.zip.
Otherwise very easy got mistake, the source may be wrong in the first place.

You can use same version full update.zip update again, or fastboot flash the correct boot.img.
 

ULTRAJC

Senior Member
Feb 2, 2021
51
19
My magisk patched boot.img from 11.0.8.13 KB05AA.

img MD5: 8d:60:d9:38:6d:f4:f1:2d:16:59:a6:a1:e0:4d:13:70
 

Attachments

  • magisk_patched-23000_QSMLR.img.tar.gz
    18.1 MB · Views: 6
  • Love
Reactions: cheshyre

cheshyre

Senior Member
If you have to use online source patched boot.img, don't flash, only do "fastboot boot boot.img", if it can successfully boot into the system, then use magisk patch current system boot.img and reboot.
Sorry, saw this too late.

Was about to post a new Q because I can't install the OTA update, but maybe you know the answer?

Download and install update returns "Installation problem"
In Magisk, Uninstall Magisk > Restore Images says "Stock backp does not exist"

Help me, Obi-Wan Kenobi...
 

ULTRAJC

Senior Member
Feb 2, 2021
51
19
Sorry, saw this too late.

Was about to post a new Q because I can't install the OTA update, but maybe you know the answer?

Download and install update returns "Installation problem"
In Magisk, Uninstall Magisk > Restore Images says "Stock backp does not exist"

Help me, Obi-Wan Kenobi...
Incremental update requires the system has not been modified, and little tricky, do not directly patch inactive slot befor reboot, let upgrade process boot up system say successful, then patch.

Original boot.img (11.0.8.13 KB05AA):
MD5: 75ba083950c2a75c6b423442ef2dfc37
 

Attachments

  • boot_b_11.0.8.13.KB05AA.img.gz
    17.3 MB · Views: 1
  • Love
Reactions: cheshyre

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    My magisk patched boot.img from 11.0.8.13 KB05AA.

    img MD5: 8d:60:d9:38:6d:f4:f1:2d:16:59:a6:a1:e0:4d:13:70
    1
    Sorry, saw this too late.

    Was about to post a new Q because I can't install the OTA update, but maybe you know the answer?

    Download and install update returns "Installation problem"
    In Magisk, Uninstall Magisk > Restore Images says "Stock backp does not exist"

    Help me, Obi-Wan Kenobi...
    Incremental update requires the system has not been modified, and little tricky, do not directly patch inactive slot befor reboot, let upgrade process boot up system say successful, then patch.

    Original boot.img (11.0.8.13 KB05AA):
    MD5: 75ba083950c2a75c6b423442ef2dfc37