WiFi >> obtaining ip address _loop

Search This thread

dan0zone

Senior Member
Mar 4, 2007
428
19
LYNN
For those of you, who like me ,flashed JK6 or newer 2.2 rom , and ended up with WiFi issues , here's a fix posted by another user..... with wifi off ,
First using rootExplorer or adb , delete ....data/wifi/bcm_supp.conf
Restart then ...
With rootExplorer or adb, again, delete.... data/misc/wifi/dhcp/dhcp_list ..
then turn on wifi and BAM!!!! .... Just sharing some info i found ... hope this helps...




I had the same issue on my Tab and my Bell Vibrant (after upgrading to Froyo). The devices would get stuck in "Obtaining IP Address".

This is what worked for me:

To Fix Android going into “Obtaining IP Address” loop:
rm /data/misc/dhcp/dhcp_list

It seems to come from the fact that the phone requests its previous IP address to the access point, without any discover message, whereas the lease has expired from the AP point of view...

The previous leases are stored in /data/misc/dhcp/dhcpcd-eth0.lease and /data/misc/dhcp/dhcp_list. You just have to remove the second file (dhcp_list) to force the phone to start a new dhcp negotiation.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I had wifi issues ounce and nothing worked to fix it but resetting my router and modem:)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone