WiFi plaguing Android Marshmallow

Search This thread

7-down

Senior Member
Feb 14, 2012
89
30
After using 6.0 for a day or so, I noticed that the WiFi was draining huge amount of juice from the phone, even taking the top spot on the battery chart. This seems to happen even if the WiFi is turned off.

http://i.imgur.com/X2YoNvv.png

So how can we fix this? Well, we'll have to go through bunch of settings to do so. It seems like Google deliberately hid this deep inside location settings. This is how we can "temporarily" fix this issue: Head to Settings -> Location -> Click those 3 dots at the top right corner -> Scanning -> Turn off both WiFi scanning and Bluetooth scanning.

Even with this "fix" I noticed that it keeps draining battery life for no reason, not as much, but the problem still exists. This shouldn't happen! Especially when Marshmallow was built around battery life improvements. The fact that this bug has been causing problems since M Preview #3 shows either Google "missed" this chaos of a bug (or) only cares about that juicy location data. This should be a straightforward-user-friendly option, not one that is buried behind buttons and menus.

It's not a bug, it's a feature
 

jdawg0024

Senior Member
Jul 5, 2007
790
170
Had the same issue after flashing the factory image. So I flashed 5.1.1 again booted the phone then rebooted into recovery and sideloaded the 6.0 OTA. Booted the phone and preformed a factory reset. Now I don't have that problem.
 

jdawg0024

Senior Member
Jul 5, 2007
790
170
Had the same issue after flashing the factory image. So I flashed 5.1.1 again booted the phone then rebooted into recovery and sideloaded the 6.0 OTA. Booted the phone and preformed a factory reset. Now I don't have that problem.

Pics
 

Attachments

  • 1444245863919.jpg
    1444245863919.jpg
    36.3 KB · Views: 10,681
  • 1444245873753.jpg
    1444245873753.jpg
    36.1 KB · Views: 10,489

DaimonPl

New member
Sep 25, 2013
4
1
I had same problem also tried disabling Wi-Fi scanning and automatically turning off Wi-Fi when idle but it did not give better results.

Just today i switched phone Wi-Fi to 2.4 GHZ only mode - this workaround seem to work, no drain any more.
 
  • Like
Reactions: eyesore

eyesore

New member
Aug 16, 2010
4
1
I had same problem also tried disabling Wi-Fi scanning and automatically turning off Wi-Fi when idle but it did not give better results.

Just today i switched phone Wi-Fi to 2.4 GHZ only mode - this workaround seem to work, no drain any more.

Thanks for that. This actually sounds possible.

On the first day when I flashed 6.0 with OTA, I really felt that the battery life has extended.
Then I switched through a lot of settings and also ended up with 2.4 and 5 (auto) on wifi.
Disabling all wifi related options did not help at all....

Will try this out now. :good:
 

5hifty

New member
Jul 15, 2013
3
0
Chicago
I'm having severe delays with my wifi on my N5 with 6.0. In speedtest I'm pushing over 90mbps on 5GHz band, but it takes over 30 seconds to load a webpage/ apps. It's not gradually loading it's almost like a stall. Then after the page or app loads instantly. Why is this happening? Is it a severe delay to the server? IDK wtf is going on... I don't have battery drain issues from the wifi this is a different issue.
 

verdiken

Member
May 8, 2013
5
0
Antwerp
Same problem... Scanning and wifi off! Wifi drain. At first sight problem only seems to manifest while no wifi available. Tried the 2.4ghz only and seems to reduce though not eliminate the problem...
 

eyesore

New member
Aug 16, 2010
4
1
I had same problem also tried disabling Wi-Fi scanning and automatically turning off Wi-Fi when idle but it did not give better results.

Just today i switched phone Wi-Fi to 2.4 GHZ only mode - this workaround seem to work, no drain any more.


Works indeed better.. Wifi disappears from the Battery Usage chart, but when it was supposed to went on idle while I put it away, draining started again it seems.
There is a fat bug in the Power-Management in Android M 6.0 final, if you ask me... :(
 

eddiehk6

Senior Member
Dec 18, 2010
1,506
666
London
All, please check whether it is actually drain or merely incorrect reporting of battery statistics. Symptoms seem similar to this thread

Remember battery 'drain' is where the level is falling at an abnormally fast rate. If WiFi is merely appearing at the top of the stats, but your battery life is actually fine, then it's not drain.

You need to leave your phone over several hours, and take measurements. When investigating or troubleshooting, then logically change one thing at a time, and re-measure again over a long period of time for comparison.
 

eyesore

New member
Aug 16, 2010
4
1
All, please check whether it is actually drain or merely incorrect reporting of battery statistics. Symptoms seem similar to this thread
Remember battery 'drain' is where the level is falling at an abnormally fast rate. If WiFi is merely appearing at the top of the stats, but your battery life is actually fine, then it's not drain.
You need to leave your phone over several hours, and take measurements. When investigating or troubleshooting, then logically change one thing at a time, and re-measure again over a long period of time for comparison.

There is definitely a drain problem... because of Google Play Services not letting System into sleep mode and pulling constantly on Wifi...
That is how I think it comes to the problem.

Mine is now running smoothly, after I went into: Settings > Apps > Google Play Services (and maybe also Google Play Store) > hit menu ... > Deinstall Updates > Restart
If you go back into Play Store later on, it updates to the current version.

I also reseted the Network Settings... somewhere.
 
Last edited:

aagha

Senior Member
Oct 10, 2010
90
4
I tried what was suggested by others in this thread and din't have any luck. I posted how I solved the issue here:

reddit dot com/r/Nexus5/comments/3npesh/wifi_drain_persists_in_android_m_final_release/cvwo3x5
 

DaimonPl

New member
Sep 25, 2013
4
1
I did another modification. In Location settings I changed mode to device only (GPS).

So together:
- set WIFI to 2GHz only
- disable wifi scanning in location settings
- set location scanning to device only (GPS)
- set WIFI to automatically turn off in idle mode (advanced wifi settings)

WIFI is no longer main battery consumer (screen is now as expected). I'm not sure which of those is crucial but they all look like may improve things a bit (and together give big difference)
 

edwinek

Senior Member
Jan 5, 2011
58
5
I thought this was bugging me too. WiFi is top of the list in battery stats. But then I disabled ElementalX gestures (doubletap2wake in my case) and that improved things a lot. Even though WiFi is still reported as the biggest power user.
This may be just me and of course it could always be better, but it might be worth giving this a try.
 

jb3p76

Senior Member
Nov 6, 2014
63
33
I'm having his exact issue. It's with any resources I access through WiFi, from sftp to ftp to web data, internal and external lans, internet, etc. It's definitely a 6.0 issue. I had it on preview 3 as well, and it was bad enough make me downgrade at the time. Now the official release is out and doing the same thing, I'm REALLY hoping they can fix this soon. It's practically unusable if you don't have dial-up time to kill.
 

grujea

Member
Apr 3, 2011
37
6
I've experienced the same issue, after a week from the ota update (week in which I had a great battery lifetime), the problem arose out of the nowhere, and after searching the web for a workaround, it seems that putting the wifi in 2.4 ghz only made the trick...
Really hope that google will fix this soon...
 

if_it_is?

New member
Oct 21, 2015
1
0
There is definitely a drain problem... because of Google Play Services not letting System into sleep mode and pulling constantly on Wifi...
That is how I think it comes to the problem.

Mine is now running smoothly, after I went into: Settings > Apps > Google Play Services (and maybe also Google Play Store) > hit menu ... > Deinstall Updates > Restart
If you go back into Play Store later on, it updates to the current version.

I also reseted the Network Settings... somewhere.

This is the only thing that worked fully for me. Getting it to 2GHz made it a little bit better but didn't actually solve it. Uninstalling updates from play services and play store solved it for good and I didn't have to flash 5.1.1 and ota update.

:good:Thanks eyesore!
 

madiweb

Senior Member
Dec 6, 2012
115
3
Hello. I have this issue... I disabled localisation through WiFi and I have also done a network settings reset but the problem still persists (not too much as before -45%- but around 25%).
How can I solve?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    All, please check whether it is actually drain or merely incorrect reporting of battery statistics. Symptoms seem similar to this thread

    Remember battery 'drain' is where the level is falling at an abnormally fast rate. If WiFi is merely appearing at the top of the stats, but your battery life is actually fine, then it's not drain.

    You need to leave your phone over several hours, and take measurements. When investigating or troubleshooting, then logically change one thing at a time, and re-measure again over a long period of time for comparison.
    2
    After using 6.0 for a day or so, I noticed that the WiFi was draining huge amount of juice from the phone, even taking the top spot on the battery chart. This seems to happen even if the WiFi is turned off.

    http://i.imgur.com/X2YoNvv.png

    So how can we fix this? Well, we'll have to go through bunch of settings to do so. It seems like Google deliberately hid this deep inside location settings. This is how we can "temporarily" fix this issue: Head to Settings -> Location -> Click those 3 dots at the top right corner -> Scanning -> Turn off both WiFi scanning and Bluetooth scanning.

    Even with this "fix" I noticed that it keeps draining battery life for no reason, not as much, but the problem still exists. This shouldn't happen! Especially when Marshmallow was built around battery life improvements. The fact that this bug has been causing problems since M Preview #3 shows either Google "missed" this chaos of a bug (or) only cares about that juicy location data. This should be a straightforward-user-friendly option, not one that is buried behind buttons and menus.

    It's not a bug, it's a feature
    1
    I had same problem also tried disabling Wi-Fi scanning and automatically turning off Wi-Fi when idle but it did not give better results.

    Just today i switched phone Wi-Fi to 2.4 GHZ only mode - this workaround seem to work, no drain any more.
    1
    Best fix for me...
    Use DS battery saver
    1
    Change WiFi settings to 2.4 ghz only. Fixed my issues...
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone