WiFi Problem in Oreo: NETWORK SELECTION DISABLED ASSOCIATION REJECTION

Search This thread

Acir

Member
Jan 4, 2012
24
2
Curitiba
Hi guys, I'm a bit frustrated since I bought my Nokia 8 TA-1012.

[INTRO]
Besides the seller sent me a used phone, with an already opened screen, my real issue right now is with the Wifi.
My phone came from Israel and I'm using it in Brazil.
The Android is in the 8.1 version, still waiting for the camera update.

[ISSUE]
I'm having huge problems with Wifi Networks, both 5GHz and 2,4GHz, where after some time connected, the phone will disconnect and give me the following message when I try to connect again:
NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION = #
where # is a number counter that increments everytime the phone tries to reconnect.
All my other devices are working fine on my networks, including a Galaxy S7 Edge, a Moto X 2013, a Motorola Moto Z2 Play, my Nintendo Switch, PS3, notebooks and guest devices that come here.

[WHAT I TRIED ALREADY]
  • setting a fixed IP in the router
  • resetting the router configs to default
  • clearing the phone cache and rebooting (solves temporarily)
  • rebooting in safe mode (still happens)
  • factory reset on the phone, install nothing and wait (still happens. Google Play Store is the first app to update)
  • changing network from 2,4GHz to 5GHz
  • changing networks channels and bands

[DISCOVERIES]
I have enabled the Developer mode and the extended Wi-Fi registry, where I can see the error message mentioned above. I see that a score is set to the network and when this error happens, the score is set at ZERO.
I read that Pixels phones had a similar issue, but none of the information provided on different sites solved for me.

[END]
I'm waiting for the camera update and hoping to fix it bt that. But, what if it don't solve it?
Does anyone have any idea how to solve this?
 

Attachments

  • Screenshot_20180530-222126.png
    Screenshot_20180530-222126.png
    197.4 KB · Views: 3,084
  • Screenshot_20180602-115227.jpg
    Screenshot_20180602-115227.jpg
    259.8 KB · Views: 3,073
  • Screenshot_20180528-085420.jpg
    Screenshot_20180528-085420.jpg
    257.8 KB · Views: 2,610
  • Screenshot_20180528-085427.jpg
    Screenshot_20180528-085427.jpg
    256.8 KB · Views: 2,767

Acir

Member
Jan 4, 2012
24
2
Curitiba
Device with unknown name

I found out that my device has no name at any router. Could be that be the issue, since all other devices have their name attached in the device list of the router?

When looking at the device name in the WiFi setting, it is set as Nokia 8.

Could be possible that all the routers are rejecting my phone because it has no name transmitted? I think the MAC address it's the only necessary information.

Somebody??? Please???
 

Acir

Member
Jan 4, 2012
24
2
Curitiba
Debug info

I've got some information from the debug.

The file is huge, but there some information related to the WiFi, as follows:

06-13 20:38:49.639 1000 1441 1913 D WifiService: New client listening to asynchronous messages
06-13 20:38:49.640 1000 1441 1913 D WifiService: CONNECT nid=-1 uid=1000 name=android.uid.system:1000
06-13 20:38:49.640 1000 1441 1913 D WifiService: Connect with config ID: 0 SSID: "Rezende" PROVIDER-NAME: null BSSID: null FQDN: null PRIO: 0 HIDDEN: false
06-13 20:38:49.640 1000 1441 1913 D WifiService: NetworkSelectionStatus NETWORK_SELECTION_TEMPORARY_DISABLED
06-13 20:38:49.640 1000 1441 1913 D WifiService: mNetworkSelectionDisableReason NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION
06-13 20:38:49.640 1000 1441 1913 D WifiService: NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION counter:5

06-13 20:38:49.640 1000 1441 1913 D WifiService: hasEverConnected: true
06-13 20:38:49.640 1000 1441 1913 D WifiService: numAssociation 8
06-13 20:38:49.640 1000 1441 1913 D WifiService: validatedInternetAccess
06-13 20:38:49.640 1000 1441 1913 D WifiService: KeyMgmt: WPA_PSK Protocols: WPA RSN WAPI
06-13 20:38:49.640 1000 1441 1913 D WifiService: AuthAlgorithms: OPEN
06-13 20:38:49.640 1000 1441 1913 D WifiService: PairwiseCiphers: TKIP CCMP
06-13 20:38:49.640 1000 1441 1913 D WifiService: GroupCiphers: WEP40 WEP104 TKIP CCMP
06-13 20:38:49.640 1000 1441 1913 D WifiService: PSK: *
06-13 20:38:49.640 1000 1441 1913 D WifiService: sim_num
06-13 20:38:49.640 1000 1441 1913 D WifiService:
06-13 20:38:49.640 1000 1441 1913 D WifiService:
06-13 20:38:49.640 1000 1441 1913 D WifiService:
06-13 20:38:49.640 1000 1441 1913 D WifiService:
06-13 20:38:49.640 1000 1441 1913 D WifiService: Enterprise config:
06-13 20:38:49.640 1000 1441 1913 D WifiService: IP config:
06-13 20:38:49.640 1000 1441 1913 D WifiService: IP assignment: DHCP
06-13 20:38:49.640 1000 1441 1913 D WifiService: Proxy settings: NONE
06-13 20:38:49.640 1000 1441 1913 D WifiService:
06-13 20:38:49.640 1000 1441 1913 D WifiService: blackListed: 1528932708sec cuid=1000 cname=android.uid.system:1000 luid=1000 lname=android.uid.system:1000 lcuid=1000 userApproved=USER_UNSPECIFIED noInternetAccessExpected=false roamingFailureBlackListTimeMilli: 1000
06-13 20:38:49.640 1000 1441 1913 D WifiService: recentFailure: Association Rejection code: 1
06-13 20:38:49.666 wifi 952 952 W wificond: Scan is not started. Ignore abort request
06-13 20:38:50.698 wifi 952 952 I wificond: Connect timeout
06-13 20:38:50.740 wifi 796 796 E [email protected]: Failed to get firmware debug dump: NOT_SUPPORTED
06-13 20:38:50.740 wifi 796 796 E [email protected]: Failed to get driver debug dump: UNKNOWN

I hope can help someone to help me.
 

Attachments

  • bugreport-TA-1012_00WW-OPR1.170623.026-2018-06-13-20-39-24.zip
    4 MB · Views: 377

timajus

New member
Dec 22, 2018
1
0
Dear Sirs, i have the same problem with my Samsung J3 2017 with Android 8.0. All other devices can connect to the hotspot; my J3 can't connect and i have the same NETWORK_SELECTION_TEMPORARY_DISABLED and NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION.

The phone can connect seamless to other wifi networks.

Could you please tell me how can i solve this issue?

Thank you very much in advance.
 

Joao_Silva

New member
Dec 25, 2018
1
1
Hello.
=> can't connect and i have the same NETWORK_SELECTION_TEMPORARY_DISABLED and NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION.

Exact same problem from the beginning with new Galaxy A8 (december 2018), Oreo 8.0.0 updated Tue 4 dec, + updated today -did not change anything re: Wifi).

Any luck with solution?

PS:
- this happens when I try to connect to my windows Asus Laptop dual band 2.4 and 5.0 Ghz wifi hotspot (from 2015);
- the new A8 connects perfectly on my old S5 hotspot, and various other wifi hotspots;
- the old S5 connects perfectly to the windows Asus Laptop dual band 2.4 and 5.0 Mhz wifi hotspot, just as any other android phone in the past 3 years.
Wifiman sees the hotspot created with Intel Dual Band Wireless AC 7265, sees SSID, sees channel 11 2452 - 2472 MHz - 38 dBm, does not see anything at 5.2 MHz.

Device manager on Laptop lets me change channel for Ad Hoc Channel 802.11b/g, but WifiMan still detects only channel 11 (channel number parameter change has no effect after restarting hotspot).

Of course: resetting network settings didn't do anything (Only sugestions by Samsung Members Experuence, other than Factory reset cellphone just out of box + updated).
 
Last edited:
  • Like
Reactions: Frizy687

Xdadev is good 4U

New member
Jul 17, 2016
3
0
Private DNS?

Maybe some help:

Some people mentioned to remove the auto DNS option, but that would not make sense in the context of DHCP options.... But....

There is this new Private DNS setting that you might wanna turn off (from auto)

Follow these steps to setup Private DNS on Android:

Open Settings and go to Network & Internet – Advanced – Private DNS or just search for “Private DNS” in settings search bar.
It s been good for me so far, but I let you confirm that it last for you too.
 

CQMantis

Member
Sep 27, 2013
8
0
Hello,
Have faced similar problem with "Xiaomi Mi A2 Lite" and I've fixed it by changing 5G band from AC to A/N (in my case) worked fine, but once I change to A/N/AC doesn't works (my router MikroTik AC Lite)
Hope helps for somebody
 

florisz1

Member
Apr 29, 2008
24
2
Aalsmeer
Possible solution association rejection

Rebooting the phone has always worked for me. But issue will come back in days. I connect to a lot of different WiFi networks during the week, but happens with my home network only.

The second solution that works often is turn off Bluetooth and mobile data and then set the phone in airplane mode for a couple of minutes.(not too shortly)
 
D

Deleted member 8413550

Guest
Have you tried another network? I had this issue in a ****ty hotel in Norway but home it works fine. Also, everyone else had the network working perfectly. Maybe this phone is a bit picky with networks.
 

lilissupiati

New member
Feb 14, 2020
1
0
I found the same problem with Redmi A2, the problem was solved after disabling the 5 GHz band in the Access Point configuration, in other words my AP only uses the 2.4 GHz band.
 

dbpm1

Senior Member
Apr 2, 2018
84
59
Sampa
Hi guys, I'm a bit frustrated since I bought my Nokia 8 TA-1012.

[INTRO]
Besides the seller sent me a used phone, with an already opened screen, my real issue right now is with the Wifi.
My phone came from Israel and I'm using it in Brazil.
The Android is in the 8.1 version, still waiting for the camera update.

[ISSUE]
I'm having huge problems with Wifi Networks, both 5GHz and 2,4GHz, where after some time connected, the phone will disconnect and give me the following message when I try to connect again:
NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION = #
where # is a number counter that increments everytime the phone tries to reconnect.
All my other devices are working fine on my networks, including a Galaxy S7 Edge, a Moto X 2013, a Motorola Moto Z2 Play, my Nintendo Switch, PS3, notebooks and guest devices that come here.

[WHAT I TRIED ALREADY]
  • setting a fixed IP in the router
  • resetting the router configs to default
  • clearing the phone cache and rebooting (solves temporarily)
  • rebooting in safe mode (still happens)
  • factory reset on the phone, install nothing and wait (still happens. Google Play Store is the first app to update)
  • changing network from 2,4GHz to 5GHz
  • changing networks channels and bands

[DISCOVERIES]
I have enabled the Developer mode and the extended Wi-Fi registry, where I can see the error message mentioned above. I see that a score is set to the network and when this error happens, the score is set at ZERO.
I read that Pixels phones had a similar issue, but none of the information provided on different sites solved for me.

[END]
I'm waiting for the camera update and hoping to fix it bt that. But, what if it don't solve it?
Does anyone have any idea how to solve this?

Oo @Acir aqui é dbpm1 direito de Santa Catarina rs

It may be a little too late but have you tried the "Reset Wi-Fi, mobile and Bluetooth" option in the 3dots top right corner on Network & Internet settings?

That by itself should resolve the issue, but if you did a factory restore and even after that if the wifi isn't connecting, you may have (had?) a defective device or an incorrect rom written to it.

Let us know in a reply below!

xau brigadu :silly:
 

psyray

New member
Oct 28, 2014
4
0
Hi, now i have the some problema, how did you solve it?
Thanks

Try to disable Protected Management Frames and Wi-Fi Agile Multiband in your router option.
I have an ASUS RT-AX58U and this was the problem for me.
I was trying to connect an old Galaxy TAB 3 10.1, with a 14.1 lineage OS (Android 7.2).

FYI
This 2 options permits to prevent hack by eavesdropping & forging management packets. source: wi-fi.org/knowledge-center/faq/what-are-protected-management-frames
I think it's safe to remove in home condition, not for sensible network
 
Last edited:

AxRabby

New member
Sep 1, 2021
3
0
Hello,
Have faced similar problem with "Xiaomi Mi A2 Lite" and I've fixed it by changing 5G band from AC to A/N (in my case) worked fine, but once I change to A/N/AC doesn't works (my router MikroTik AC Lite)
Hope helps for somebody
How to change 5G band? Please tell the process. I am facing same problem now.
 
Feb 20, 2016
31
2
JAMMU
Have similar issue with my redmi Note 4 while it is trying to connect to iphone12's hotspot it is not having any issues with connection to any other network it's just very specific to this iPhone only.
Tried changing the network band tried resetting wifi setting tried disabling wifi assistant nothing is working this error of (NETWORK_SELECTION_TEMPORARY_DISABLED,33m12s)NETWROK_SELECTION_DISABLED_AUTHENTICATION_FAILURE=1
 

Attachments

  • tmp-cam-1774788630186835970.jpg
    tmp-cam-1774788630186835970.jpg
    66.6 KB · Views: 21
  • IMG_20220703_222139.jpg
    IMG_20220703_222139.jpg
    1.3 MB · Views: 21

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello.
    => can't connect and i have the same NETWORK_SELECTION_TEMPORARY_DISABLED and NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION.

    Exact same problem from the beginning with new Galaxy A8 (december 2018), Oreo 8.0.0 updated Tue 4 dec, + updated today -did not change anything re: Wifi).

    Any luck with solution?

    PS:
    - this happens when I try to connect to my windows Asus Laptop dual band 2.4 and 5.0 Ghz wifi hotspot (from 2015);
    - the new A8 connects perfectly on my old S5 hotspot, and various other wifi hotspots;
    - the old S5 connects perfectly to the windows Asus Laptop dual band 2.4 and 5.0 Mhz wifi hotspot, just as any other android phone in the past 3 years.
    Wifiman sees the hotspot created with Intel Dual Band Wireless AC 7265, sees SSID, sees channel 11 2452 - 2472 MHz - 38 dBm, does not see anything at 5.2 MHz.

    Device manager on Laptop lets me change channel for Ad Hoc Channel 802.11b/g, but WifiMan still detects only channel 11 (channel number parameter change has no effect after restarting hotspot).

    Of course: resetting network settings didn't do anything (Only sugestions by Samsung Members Experuence, other than Factory reset cellphone just out of box + updated).