WiFi problems: "Network disabled because Internet connection is slow"

Search This thread

Spere

Senior Member
Aug 7, 2013
473
167
What does it do? Will it affect my battery life?

I have honestly to say, I don't know

I believe it does affect your battery life (since it's called Power Save Mode)
Haven't got any need to try it.

(I got same kind issue with wlan on my old-old Nokia. For that helped disabling power save mode --> increased radio power (or something) so that wlan connection came a lot more stable)

Just posted that here because I saw that option on menu while playing with my Note. I't might help, or it might not, dunno :)
 

Riccosf1

New member
Jun 11, 2007
2
0
same here.. burned through my data plan due to this poor network thinggy
hopefully unticking the boxes fixes things
ill let u guys know in a few days
 

mesubbu

Member
Nov 28, 2012
6
1
Bangalore
It worked!!

Thanks!! after updating my Note II to 4.1.3 i was having this wifi issue at home and office. for nearly all week i was on 3G connectivity. Your suggestion solved the problem. Now i am able to connect like a breeze!! Thanks a lot.

Subbu


goto wifi setting and advanced .left click.and uncheck as in pic



Sent from my SM-N9005 using Tapatalk 2
 

kaos217

Senior Member
Jun 5, 2008
67
7
I have a GS3, but I am experiencing this identical issue on 4.3

The dilemma (coming from 4.1.2) is that without checking "Auto Network Switch" under advanced wireless settings, I could not send or receive any MMS. I was getting the download prompt for inbound mms which never downloaded, and the sending message for outbound. Once unchecked, MMS works as it should. And as is pointed out here, that is somehow because the phone chooses mobile data over wireless because the connectivity integrity check of wireless determines 'Network disables because Internet connection is slow'. Which is not the case at all. I can clearly see my signal strength is excellent and the bandwidth test confirms that I am getting a good deal of my 75/35 FiOS pipe.

This only leaves the following options:

1. Uncheck 'Auto Network Switch' (under wireless>advanced) which will reconnect device to Wireless AP, but prevent MMS in or out. (should be noted that on 4.1.2, there was no 'auto network switch' option. If you were on wireless and sent/received mms, it briefly connected to mobile data to handle message.)

2. Check 'Auto Network Switch'. This allows MMS to work as expected but only because your device remains on mobile data. Indefinitely. No matter how good any wireless connection actually is, the phone defaults to disabling Wi-Fi in favor of mobile data. I can confirm there is no issue with my network connection being slow. I have excellent signal to my AP and to the Internet.


Desktop Speedtest Results
SJ7nFC4.png



Mobile Speedtest Results
G2b5Mdw.png



So this issue appears to be related to more than one device... is this an overall Samsung 4.3 issue?
 

tbrand68

Member
Mar 16, 2010
12
2
I have a GS3, but I am experiencing this identical issue on 4.3

The dilemma (coming from 4.1.2) is that without checking "Auto Network Switch" under advanced wireless settings, I could not send or receive any MMS. I was getting the download prompt for inbound mms which never downloaded, and the sending message for outbound. Once unchecked, MMS works as it should. And as is pointed out here, that is somehow because the phone chooses mobile data over wireless because the connectivity integrity check of wireless determines 'Network disables because Internet connection is slow'. Which is not the case at all. I can clearly see my signal strength is excellent and the bandwidth test confirms that I am getting a good deal of my 75/35 FiOS pipe.

This only leaves the following options:

1. Uncheck 'Auto Network Switch' (under wireless>advanced) which will reconnect device to Wireless AP, but prevent MMS in or out. (should be noted that on 4.1.2, there was no 'auto network switch' option. If you were on wireless and sent/received mms, it briefly connected to mobile data to handle message.)

2. Check 'Auto Network Switch'. This allows MMS to work as expected but only because your device remains on mobile data. Indefinitely. No matter how good any wireless connection actually is, the phone defaults to disabling Wi-Fi in favor of mobile data. I can confirm there is no issue with my network connection being slow. I have excellent signal to my AP and to the Internet.


Desktop Speedtest Results
SJ7nFC4.png



Mobile Speedtest Results
G2b5Mdw.png



So this issue appears to be related to more than one device... is this an overall Samsung 4.3 issue?


I was having the same issue (dropping wifi until I unticked the Auto Network Check)... did that and wifi was stable...
I started getting the MMS sending fail...
I looked around forever trying to figure this out... and while putting the Auto Network Check back on would enable MMS, I knew this couldn't be the cause of the problem (in my case)... How did I know this?? My wife has the exact same phone.. and she could send MMS messages just fine with that checked or not... so I figured it had to be something else.
I read that an MMS has to be sent via the DATA network... so I looked for an app on my phone that might "force" things through some other connection... I found it. ADBLOCK... it sets up a local proxy to block the ads... it also blocks the dns lookup for the MMS data site...
I uninstalled that and I can send MMS messages with or without the AUTO NETWORK CHECK checked now... just like my wifes phone...
The problem now is all those pesky ads popping up in the free apps... damned if you do and damned if you don't! ;)
Anyway, just my 2 cents on this "issue".

Tim
 
  • Like
Reactions: maxh

Andrewtst

Senior Member
Aug 4, 2009
4,839
1,792
Johor
Un-tick both as screenshot at WiFi Advanced will solved the WiFi issue.

This is common issue at 4.3 for all Android phone, this new feature in 4.3 is silly useless.

11798639725_34e0ec6b4f_c_d.jpg
 

staycanuca

Member
Mar 3, 2012
19
1
Strange thing

Very strange:
After a Factory reset, when I connected to my network, I have same problem.
But what is strange is: my network have a proxy !!!! By default, whitout any app installed or any change made by me.
I found on advanced settings proxy set to localhost and port 2020.


I know a app wich use this settings, but that app is not installed.
 
D

dtchky

Guest
Nobody is understanding the problem

The cause of this problem is 'internet connectivity' - period.

The phone checks (once per connection attempt) that it can connect to some remote host, if it can it allows the WiFi connection to stay up. If it can't, it throws up the 'internet is slow' message and refuses to connect.

This is very much a "WTF is samsung thinking" moment. There is no way on the UI to disable this stupidity.

What does this break? Intranets, any network connection that doesn't have wider internet connectivity - Corporate networks. Networks that requrie further authentication.

Sigh.
 

Hammer_drum

Senior Member
Jan 21, 2013
75
9
I have the exact same issue as this after upgrading to Kit Kat.

Wifi either says connection is too slow or the connection is unstable - either way, if I can connect to wifi then the connection doesn't work.

This is incredibly irritating!!
 

kushang9928

Member
Dec 26, 2013
24
5
surat
Solution

First try to Forget the network and re-connect it.
if not work than do the following steps.
go to settings->Application
press meny key and select "reset app preferences"
 
  • Like
Reactions: Hammer_drum

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    My One X worked with my home and work WiFi networks just fine. Now, my Note 3 has a lot of trouble holding on to the connection, and usually just disables them (see screenshot).
    3HUh4Jy.png


    Also, one day I had WiFi off all day, and the battery chart showed it was on all day! So what's wrong here?
    O5JGtWTh.png

    goto wifi setting and advanced .left click.and uncheck as in pic



    Sent from my SM-N9005 using Tapatalk 2
    9
    My One X worked with my home and work WiFi networks just fine. Now, my Note 3 has a lot of trouble holding on to the connection, and usually just disables them

    try unticking auto network switch option in wifi settings


    Also, one day I had WiFi off all day, and the battery chart showed it was on all day!

    try unticking scanning always available option in wifi settings
    4
    It's because they want to make sure you have the fastest connection and when it notices that your wifi is being used up by something else it wants to switch to a faster connection.

    Sent from my SM-N9005 using XDA Premium 4 mobile app
    2
    My One X worked with my home and work WiFi networks just fine. Now, my Note 3 has a lot of trouble holding on to the connection, and usually just disables them (see screenshot).
    3HUh4Jy.png


    Also, one day I had WiFi off all day, and the battery chart showed it was on all day! So what's wrong here?
    O5JGtWTh.png
    2
    possible solution?

    I was getting this same error before, and now I'm not. Some notes first -

    1) Sprint, Galaxy Tab 3, T217S model.

    2) I was (previously) running a custom ROM. I restored my backup of the original device ROM. I'm not sure if this was part of the problem or not.

    So after about an hour on the phone and talking to 3 different rep's I finally got my wifi working right. The steps he told me were really strange but they seemed to work.

    First you open the calculator, yes, the calculator. In there you type the following -

    (+30012012732+

    This will open a "Factory Settings" window with a dialer pad, and in there you type -

    ##72786#

    This will reboot your device, and after rebooting it will bring up a setting in your notification panel about "Updating PRL Network Settings" and soon it will bring up a "Hands Free Activation" window and blah blah, basically you just hit Okay, it'll reboot again, it'll update PRL Network Settings again and then that's all.

    He did mention this ONLY works on Tab 3 and 2 and no other devices.

    Hope this helps!