• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Will there be a Custom Rom?

Search This thread

Hlcpereira

Recognized Developer
@Hlcpereira i got a working boot animation so the display is working

Yeah I noticed that too. I'm still trying to figure out what's causing the driver stall, if it's audio or if it's any change from tucana-p-oss that I missed or so as display changes (drivers/dpu/drm) are inline with tucana-p-oss already.

I'm thinking it's something about audio drivers causing it or a missed driver change (such the BQ2597X charger pump one).

The only non-working list atm is: Display, audio and camera. Camera seems to try to start, but same as display, dies due the Fake VSync cause by the driver stall.
 
  • Like
Reactions: Jcs4

alibei

Senior Member
Jan 1, 2017
364
520
22
Deggendorf
Yeah I noticed that too. I'm still trying to figure out what's causing the driver stall, if it's audio or if it's any change from tucana-p-oss that I missed or so as display changes (drivers/dpu/drm) are inline with tucana-p-oss already.

I'm thinking it's something about audio drivers causing it or a missed driver change (such the BQ2597X charger pump one).

The only non-working list atm is: Display, audio and camera. Camera seems to try to start, but same as display, dies due the Fake VSync cause by the driver stall.

I tried to compile your kernel with the stock xiaomi audio kernel. With this I'm getting the Fake VSync cause by the driver stall too but now i will see the setupwizard on the screen.
The touchscreen is not working and after some time the phone crashes
 

alibei

Senior Member
Jan 1, 2017
364
520
22
Deggendorf
So i added these blobs:
# Citsensorservice
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]_vendor.so
vendor/lib/[email protected]
vendor/lib/[email protected]_vendor.so
vendor/lib/[email protected]
vendor/lib/libnanopb.so
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]_vendor.so
vendor/lib64/[email protected]
vendor/lib64/[email protected]_vendor.so
vendor/lib64/[email protected]
vendor/lib64/libnanopb.so

# Displayfeature
system/bin/displayfeature
system/lib/libdisplayfeature.so
system/lib/libdisplayfeatureservice.so
system/lib/[email protected]
system/lib64/libdisplayfeature.so
system/lib64/libdisplayfeatureservice.so
system/lib64/[email protected]
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]

# Touchfeature
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]


and added to the init.target.rc:
service displayfeature /system/bin/displayfeature
class late_start
user root
group root
on property:init.svc.surfaceflinger=stopped
stop displayfeature
on property:init.svc.surfaceflinger=running
start displayfeature
on property:init.svc.surfaceflinger=restarting
stop displayfeature

I used your kernel with the stock audio kernel with a few modifications so it can get compiled but the audio is not working. I tired to boot it with the kernel, build from the source from xiaomi. There the display didn't work but the audio.
Link: https://github.com/alibei/kernel_xiaomi_tucana

With all this the device is booting up with a working display but the touchscreen is still dead and I'm getting the fake vsync warning. And it isn't crashing anymore.
 
  • Like
Reactions: alex99aon and Jcs4

Hlcpereira

Recognized Developer
So i added these blobs:
# Citsensorservice
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]_vendor.so
vendor/lib/[email protected]
vendor/lib/[email protected]_vendor.so
vendor/lib/[email protected]
vendor/lib/libnanopb.so
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]_vendor.so
vendor/lib64/[email protected]
vendor/lib64/[email protected]_vendor.so
vendor/lib64/[email protected]
vendor/lib64/libnanopb.so

# Displayfeature
system/bin/displayfeature
system/lib/libdisplayfeature.so
system/lib/libdisplayfeatureservice.so
system/lib/[email protected]
system/lib64/libdisplayfeature.so
system/lib64/libdisplayfeatureservice.so
system/lib64/[email protected]
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]

# Touchfeature
vendor/bin/hw/[email protected]
vendor/etc/init/[email protected]
vendor/lib64/hw/[email protected]
vendor/lib64/[email protected]
vendor/lib/hw/[email protected]
vendor/lib/[email protected]


and added to the init.target.rc:
service displayfeature /system/bin/displayfeature
class late_start
user root
group root
on property:init.svc.surfaceflinger=stopped
stop displayfeature
on property:init.svc.surfaceflinger=running
start displayfeature
on property:init.svc.surfaceflinger=restarting
stop displayfeature

I used your kernel with the stock audio kernel with a few modifications so it can get compiled but the audio is not working. I tired to boot it with the kernel, build from the source from xiaomi. There the display didn't work but the audio.
Link: https://github.com/alibei/kernel_xiaomi_tucana

With all this the device is booting up with a working display but the touchscreen is still dead and I'm getting the fake vsync warning. And it isn't crashing anymore.

Just to see if I got it: You used the kernel on lineage-17.1 branch on my repo, added these blobs and the displayfeature init on a init.*.rc and then display worked, but audio don't, and then using tucana-p-oss, display didn't even work but audio did, that's right?
 

Hlcpereira

Recognized Developer
Update of the situation (again): About the custom ROM start up progress: As it seems to be clear a lead was taken on what's wrong about the display (finally and kudos for @alibei for sharing his finds) things should start go more smoothly. I'm rebasing the sources and double checking everything ATM. And about the device that @Genomey found on eBay, well that didn't go well... He then sent 200 USD to covering up money for me buying a tucana here at Brazil, and so do it, I did start looking already for a device in here since then. I should be be buying definately around this week (that's my hopes at least)
 

Hlcpereira

Recognized Developer
Any progress with the ROM? ... looking forward to trying at least one beta

Still trying to figure out about the main cam sensor. Took those days off due the fact I am a student after all and had a bunch of works from collage to do. As I said to another people: until I get, at least, the main cam working from the not working list (which also includes NFC and proximity sensor), I won't do a public release and that's final. All the other camera sensors are being registered properly FYI.
 

iSonik

Senior Member
Dec 7, 2010
157
55
Still trying to figure out about the main cam sensor. Took those days off due the fact I am a student after all and had a bunch of works from collage to do. As I said to another people: until I get, at least, the main cam working from the not working list (which also includes NFC and proximity sensor), I won't do a public release and that's final. All the other camera sensors are being registered properly FYI.

Thank you for your work! Is everything else working besides NFC & Main camera?
 

Kosecki99

Senior Member
Dec 9, 2016
173
14
It is very difficult to solve the main camera and NFS ?, What do you think about it ?, Will we have something this month? ... Thanks Henrique
 

Hlcpereira

Recognized Developer
It is very difficult to solve the main camera and NFS ?, What do you think about it ?, Will we have something this month? ... Thanks Henrique

Well I'm bagging my head in a wall about the main camera. NFC I have not much of a clue atm as I decided to focus on solving the main camera first.
 

iSonik

Senior Member
Dec 7, 2010
157
55
Well I'm bagging my head in a wall about the main camera. NFC I have not much of a clue atm as I decided to focus on solving the main camera first.

I see you added camera blobs, did that fix the main camera :)?

Btw since you are not providing flashabe zips until you got most things stable (which i understand() maybe you could do a closed beta programm?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    Ok, a bit of updates, mainly because I do feel that you guys deserve.

    First one: I'm going to temporary close the crowdfunding. "Why? The goal wasn't reached yet neither is being one and a half month" I know, yet @Genomey could found a cheap Mi Note 10 on eBay and got it for about 252 USD. I'm going to wait for him get the device on his end and check and if everything is ok I'll send the money to him while he send me the device. "What will happen with the remaining amount?" 63.74 USD (or 347.01 BRL) are from me, I already had it or got it by my own in the meanwhile.

    The total amount donated was of 267.22 USD. (1454.61 BRL).

    Second is: In the meanwhile me and @0201m were working on the device sources and testing (huge shout out for him for helping in testing and troubleshooting) and so far: Kernel boots, everything builds, but yet depending of which blobs/vendor binaries you use the device reboots to recovery. Also when we managed to make it boot, the display service was dead (which means it's stuck on the Mi logo while the system already booted) XD (Not joking at all, me and him almost lost our minds cause of that ;_; ). At least the vibrator is confirmed to be working. So far that's the progress.
    8
    https://forum.xda-developers.com/mi-note-10/how-to/custom-development-t4018813

    In short:there are same some efforts trying to get custom Roms but nothing groundbreaking yet.
    I am working on the device tree right now to compile from source. Not ready yet and don't have the device in hand right now (should arrive soon) s.o. else is trying with treble images.
    7
    Any progress with the ROM? ... looking forward to trying at least one beta

    Still trying to figure out about the main cam sensor. Took those days off due the fact I am a student after all and had a bunch of works from collage to do. As I said to another people: until I get, at least, the main cam working from the not working list (which also includes NFC and proximity sensor), I won't do a public release and that's final. All the other camera sensors are being registered properly FYI.
    7
    @Hlcpereira How's the progress btw ?
    Well. I got the device already, unlocked it too. Main camera, IR and NFC are dead at the moment. Rest is working

    Sent from my MI 8 using XDA Labs
    6
    Update of the situation (again): About the custom ROM start up progress: As it seems to be clear a lead was taken on what's wrong about the display (finally and kudos for @alibei for sharing his finds) things should start go more smoothly. I'm rebasing the sources and double checking everything ATM. And about the device that @Genomey found on eBay, well that didn't go well... He then sent 200 USD to covering up money for me buying a tucana here at Brazil, and so do it, I did start looking already for a device in here since then. I should be be buying definately around this week (that's my hopes at least)