• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Win] [Multi tool] [all in one][2.0] Recovery backup extractor, apktool,Mod.

Search This thread

geevh

Senior Member
Sep 5, 2009
165
31
Does this work with CWM nandroid backup with compression set to high?
I tried to open the files with 7zip without but I see only first part. I can't open second part.
I have data.ext4.tar.gz (0 bytes), data.ext4.tar.gz.a (1,5G) and data.ext4.tar.gz.b. I tried joining the files but I still can't see files in second zip.
 

laptopmd

Member
Aug 20, 2015
11
0
Hello !

I have downloaded the tool and it is working perfectly until tar.e , but i have now backup that goes until TAR.M , and the tool doesn't support more than tar.e , what can i do ? There is a special command parameter to increase the file size ?

thanks
Dave
 

Isrgish

Senior Member
Jan 5, 2018
91
11
I'm having the problem that many mention that Cat 7 Tar are recognized as internal or external commands.

I'm on a windows 7 and the PATH has "C:\Program Files (x86)\GnuWin32\bin" in it. I also tried to copy tar.exe and cat.exe into the same folder that has your tool, but still get the same message.
 

CVAngelo

Senior Member
Mar 24, 2015
1,014
390
Praia
investincv.blogspot.com
How can I go in reverse? I have a CWM backup but I want to replace the system. tar files that are in the backup folder with a different system.img. Can this utility tool take my NEW system.img file and pack in into tar, tar.a, tar.b etc files that I can then move to the backup folder so I can restore it?

I do not need warnings about the MD5 checksum file (I already know how to get around that), or about bricking my device (I know how to recover from a brick...done it dozens of times). I JUST WANT TO KNOW HOW TO USE CWM TO RESTORE A DIFFERENT VERSION OF THE SYSTEM.IMG THAN THE ONE CURRENTLY IN THE DEVICE. I just need to know how to solve my problem.

I have no other options as the device was already soft-bricked with no backup when I got it, the system partition could not be mounted (I was unable to obtain a full CWM backup...I first had to format the system partition to get a working CWM backup but of course the system image is blank), and the only current working mode is the CWM recovery on the device. So I can restore a CWM backup (I have a replacement system.img).
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    Utility Tool
    Here go a tool for every thing called utility tool

    I had already posted a tool which can Extract the cwm backups and create a zip of files Click here to find that post.


    SYSTEM_2.jpg

    What is Utility tool :-

    1. When you have any backup from cwm / twrp / image files / split tar files, this tool will help to extract them
    2. extract data
    3.extract system
    4. After extract you can Odex / Deodex
    5. Odex / Deodex can be done by extraction of backup file Or also by Pull of apps from your device
    6. After Odex / Deodex it zipalign / zip it / sign.
    7. All the above options can be done individually as per need.
    8. All these processes works with almost all the devices ( detects )
    9. supported all the devices and all versions from 2.2+ - 4.4+

    How to use :-
    1. Download the zip ( of latest version )
    2.Extract it and place it as per your pc ( no specified folder/path is needed )
    3.enter to that folder of utility tool
    4.Run the uyility tool.bat as Administrator ( if you need to install the drivers )
    5. Then choose your option as per required .

    Screen Shots

    For the first steps follow this link Click here :-

    image.jpg



    XDA:DevDB Information
    Utility tool, Tool/Utility for all devices (see above for details)

    Contributors
    venkat kamesh

    Version Information
    Status: Stable
    Current Stable Version: v1.1
    Stable Release Date: 2014-11-22

    Created 2014-11-20
    Last Updated 2014-11-30
    8
    Credits / Changelog/ F.A.Q / Video

    Credits:-
    Thanks to
    @iBotPeaches for Awesome apktool.jar
    @MatrixDJ96 for Providing the Odex Script
    @jazzespresso for Assisting the options which made me to make utility tool
    @rjt.rockx for Tuning the optional sequencing words for the tool
    @blueeagle69 For testing the tool
    and @ Users for using my tool

    Please suggest your view / options that can help the tool to be good and will be appreciated

    Changelog :-
    Version 1.0
    • Initial Update
    • Added Odex/Deodex
    • Signer
    • and more

    Version 1.1
    • Apktool
      -Decompile
      -Dompile
      -Zipalign
      -Sign
    • Alignment of all the utility tool
    • TWRP option
    • CWM option
    • Tar- inbuilt binary fix
    • Rom maker ( create your own rom.zips)
    • Dexer alignment
    • A lot more minor fixes (typo's)

    Version 1.2
    • TWRP System Files Typo fix
    • Added inbuilt Driver support
      - it able you to install the Tar / cat Binaries
    • set an option to install drivers
    • Deleted Unused files
    • and some minor fixes

    Version 2.0
    • Fixed Drivers path
    • Drivers updated
    • apktool compile/decompile/output path
    • detects the recovery files extensions
    • Deleted Unused files
    • and some minor fixes



    Download :- Click here

    Video :-

    4
    1.1 doesn't appear to be working :(

    I selected option 1 (backup files extractor)
    I then get the screen to choose your option.
    I select option 2 for TWRP recovery
    Select 2 (If System_files) (the file system.ext4.win is in the System_files folder).
    It then immediately goes back to the previous screen (Choose your Option) :(

    Is it me or the utility:confused:

    ---------- Post added at 11:03 PM ---------- Previous post was at 10:53 PM ----------


    I then tried it on the CWM option and got 'cat is not recognised' (again)

    Didn't work for me at first too, googled cat.exe and put it in c:\windows\system32 and that problem solved but not all.

    Get that from
    http://unxutils.sourceforge.net/

    Anyways it looked like problem was still exist in script somehow calling tar from dependencies folder as it's showing me file doesn't exist so I moved tar and its two needed dll files into system folder and called tar directly instead of calling it from dependencies folder and it worked properly.

    Sorry i have tested and unsaved it, so it caused those small things to mistakes.
    i have solved those things and i hope some systems are not configured with these small utilities
    i am now going to add an install option for those who dont have cat and tar ...
    just tested and gonna post it now as Utility tool v_1.2
    thanks for your check so it was solved thanks
    1
    will be this addressed? "'tar' is not recognized as an internal or external command"
    I am pretty sure many will get this error it is because, speaking for Windows, windows never going to find cat.exe nor tar.exe because it is not in windows system variable user path, so installing it from :http://gnuwin32.sourceforge.net/packages/gtar.htm, is not going to work. The way I found solution is i copied cat.exe and tar.exe under the same location where your tool script runs, and then modified:

    call cat.exe system.ext4.tar system.ext4.tar.a...etc..
    and
    call tar.exe -xvf temp.tar

    this may not be the best solution, but believe if both cat.exe and tar.exe (and related DLLs, and binaries) included in the same folder where your script runs, maybe not many people get the "'tar' is not recognized as an internal or external command" error...

    just suggestion, you may be already addressed this that I am not aware of, if so, ignore this post :laugh:

    hahaha thank you mate for the suggestion

    but i had now already solved the problem .
    no need to install by any user anymore from now

    now i had include few more options which makes user friendly
    rom maker
    apk tool
    individual file select
    and many more gonna update in hours ;)
    Ver.1.1
    thank you
    any more suggestions are really appreciable

    best regards,
    venkat kamesh
    1
    Will wait for 1.1
    Out of interest, Do I need to rename the extensions of TWRP files?
    The system archives have .win extensions.
    And the multipart data extensions are win000 & .win001 etc.

    Many thanks.

    hopefully yes
    need to change the extension from .win to .tar and place it :)
    i will try to add this code to change the extension in version 1.1 tool