• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Windows 11 complains after reboot "Why did my PC restart?".

Search This thread


New member
Jul 10, 2021
Hello everyone!

I'm installing the Windows 11 (10.0.22000.51) in a (unsupported) MacBook Pro Late 2013 using BootCamp from Apple.
I'm following the XDA article bellow:
- "How to install Windows 11 on almost any unsupported PC"

I've tried to install a Windows 10 and then changed to Dev Channel using script and it didn't work well, the best options to me is:
- Burn Windows 11 to a USB ; and
- Create a hybrid installer .

In both cases, after the installation process finished and when the first reboot was finishing, I've got the message:
- Why did my PC restart?
Windows 11 - Why did my PC restart.jpg

In this screen, I can access the prompt using SHIFT+F10 and then be able to run "explorer", but with limited access to the system. In this same screen, there is a "Next" button, but if I click on it, the PC restart and come back to the same screen. I cannot install the Wifi driver to be able to access internet.

I'm using a MacBook Pro Late 2013 via BootCamp, specs in the following link:

The ISO was created based on "Windows 11 Insider Preview 10.0.22000.51 (co_release) amd64" from the UUP Dump site:

Please, could you help me to bypass this error and resume my Windows 11 instalation?

Thank you in advance!

Jose Silva.
Last edited:


New member
Jul 10, 2021
Hey, I'm back to post my solution.

I've mentioned that I tried to install the WiFi driver for the "Broadcom
802.11ac Wi‑Fi wireless networking", to do it, I've used the file:
- Broadcom-FORCED-10x64-BCM43x_7.77.119.0-drp.

The installation was not so easy because I didn't have full access to the system, I did it by calling Control Panel from the command line. Unfortunately, even the installation was successful I'm not able to connect to my WiFi network, even trying by netsh command.

The solution for this case is to use a USB to Ethernet Adapted, in this case:
- Airlink101 USB 3.0 to Ethernet Gigabit Adapter (AGE-1000)

I've connected it directly to the router ethernet port and this device was detected by Windows 11 without any other driver installation.

After one or two reboots, Windows 11 was able to connect to the internet and concludes successfully its own installation.


New member
Nov 19, 2008
I wanted to add my experience on a Mac Mini 2014.
Same thing happened. Shift F10 command prompt showed a network connection but the setup would not proceed.

I ran the BootCamp setup program on D:\BootCamp\Setup.exe (The install thumbdrive was D:) and that installed the wifi drivers.
Disconnecting the ethernet cable and connecting to wifi was the trick that allowed the setup to continue.