• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

WINDOWS 7 & 10 PC's don't detect my amazfit pace

Search This thread

onisimos

New member
Aug 22, 2017
2
1
larisa
I own an amazfit pace smartwatch,bought 2 weeks ago.When i connect it with my PC and laptop(windows 10 & 7) via usb cable they don't recognize it as hard disk in order to see watch folders and import some music following the correct instructions.I hear the characteristc sound when i connect usb.When i browse to device manager i notice that in windows 10 there is no problem with drivers but in windows 7 there are drivers missing.I try to use the download online function but with no result.I feel that is a very simple problem but i am very frustrated because i can't find any solution.Also i am really impressed that it isn't reported such a problem in your great forum,or i didn't notice it browsing the threads.Thank you in advance for your help!!!
 

onisimos

New member
Aug 22, 2017
2
1
larisa
i used new usb cable--> problem remains
i restarted watch-->problem remains
i cleaned the contact point-->problem remains
i uninstalled the driver(windows 10) and reinstalled it-->problem remains
i uninstalled the driver(windows 7) and reinstalled it-->PROBLEM SOLVED

But my main PC runs windows 10.There must be a simple solution...

the last solution so far is the hard reset.I will inform you when i try it..:)
 
Last edited:
  • Like
Reactions: cristi_bv

BravoCharlie

Senior Member
Jun 2, 2008
102
26
i used new usb cable--> problem remains
i restarted watch-->problem remains
i cleaned the contact point-->problem remains
i uninstalled the driver(windows 10) and reinstalled it-->problem remains
i uninstalled the driver(windows 7) and reinstalled it-->PROBLEM SOLVED

But my main PC runs windows 10.There must be a simple solution...

the last solution so far is the hard reset.I will inform you when i try it..:)
Mine working on Windows 10, detected as MTP device. I do have ADB universal drivers installed but it also works on my Win 8 laptop with no additional drivers installed.
 

musquinoso

New member
Jan 16, 2009
1
0
I'm suffering the same problem after many changes of rom and music uploading in the last months. Now the watch is not recognized (unknown device error 43) under 3 w10 PCs, different cables and usb ports. Cleaned contatcs and charging properly but no way to connect with the PC. Desperated...
Any help or piece of advice are welcome
 

nisekvu

New member
Sep 15, 2017
2
0
i used new usb cable--> problem remains
i restarted watch-->problem remains
i cleaned the contact point-->problem remains
i uninstalled the driver(windows 10) and reinstalled it-->problem remains
i uninstalled the driver(windows 7) and reinstalled it-->PROBLEM SOLVED

But my main PC runs windows 10.There must be a simple solution...

the last solution so far is the hard reset.I will inform you when i try it..:)

Could you please share the driver link by any chance? .....I couldn't find one ...as I saw from internet I need something like MTP driver...tho all the things are done manually .. so complicated..im using win10 64bit as well, a surface pro4 and my amazfit rom is 1.3.4f thank you!
 

fzelle

Senior Member
Mar 19, 2006
1,009
143
Windows 10 comes with the MTP driver, so that is not the problem.

I have seen it numerous times that the watch charges but it doesn't get a pc connection.
It is always connected to a bad contact on the back.
Either you have to clean the contacts better or your dock is not working reliable.
A co worker of mine had that and he tried my dock and it worked, so he ordered a cheap one ( not that "bridge" thing ) from ali.
Working since then.
 

Kash Malaysia

New member
Dec 4, 2017
1
3
Problem solved

I had same issue but manage to resolve. Go to device manager - USB controllers - right click on the device not found - Update driver s/w - Browse my computer for driver s/w - Let me pick from a list - Untick "show compatible hardware" - Choose Manufacture: standard USB host Controller & Model: USB Composite Device - click next.
 

slackovic

Senior Member
Sep 14, 2010
107
13
Zagreb
I don't know what happened to my Pace. I could connect to it with no problems until now (last PaceFIED I installed was rel 30). Back then (two weeks ago) everything went smoothly, but now when I connect my Pace, "adb devices" can't find the watch. Adb drivers are installed (minimal_adb_fastboot_v1.4_setup.exe). I have changed NOTHING on my computer since the last time I connected the watch, but now it can't find it.
I have cleaned the contacts, restarted the Pace... Nothing is helping. Anyone have any idea? :(

EDIT: Never mind. The post right above helped :)
 
Last edited:

radofurianin

New member
Mar 21, 2015
1
0
quick fix

I had installed adb correctly so what I do ?
For me worked to clean pins in smartwatch gently with toothpick and after that connect it again to the docking station/charger.
 

zelitrex36

Member
Feb 29, 2012
17
6
I don't have your luck guys. Watch is new so clean (but I still tried to clean the pins), I have no "device not found" and not a single sound when connecting the watch on 3 different computers.

The charge indicators is showing tho... so the watch receive power from computer usb ports...

any idea ?
 

seadoh

New member
Oct 10, 2015
1
0
Has anyone tried changing the USB port settings to control power? It's in the device manager for the USB ports (properties). That worked for me (found it on the net with a similar issue)
 

zelitrex36

Member
Feb 29, 2012
17
6
I solved my problem with the most stupid change I could do...
I read somewhere (can't even find it) that some people have had problems with the original usb cable... After 5 hours of adb drivers installations, factory reset and whatever, I just remembered that sentence and changed my usb cable. Now it's working perfectly.

While it's so simple that you can think "how couldn't he think of that before?"
Answer is : the watch is charging so no reason to be suspicious...

That could help someone would just bought it...
 

greg_h_w

Senior Member
Aug 22, 2011
85
48
Yogyakarta
As stated in my previous message, I'd solved my problem by plugging another USB cable. Did you try a wire of yours?

Yeah, I already try to change the cable with another one, but still no luck. This is weird to me because before that I can use that cable to connect it with my PC and now it doesn't detect at all, only work for charging. And if I use that cable to connect phone it work normally :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Work for me like this
    1. connect amazfit, on
    2. open device and printer
    3. find amazfit pace on unspecified folder
    4. right klik, properties, open hardware tab, properties, on general tab open change setting
    5. open driver, you find uninstall driver is on, uninstall and check on the box "......." I forgot what it is. ok,
    6. automatically the driver installed again, or if nothing happen just refresh or reconnect the amazfit. the amazfit pace will showed in Computer
    3
    I solved my problem. When you connect amazfit it will appear in devices and printers. When you right click it and open properties (somewhere there) you can change the driver from google nexus adb interface to USB composite device. Then It will appear as disk in my computer.
    3
    Problem solved

    I had same issue but manage to resolve. Go to device manager - USB controllers - right click on the device not found - Update driver s/w - Browse my computer for driver s/w - Let me pick from a list - Untick "show compatible hardware" - Choose Manufacture: standard USB host Controller & Model: USB Composite Device - click next.
    2
    I face the same problem, I uninstall the driver from the device manager and re-plug again, now it can detect now.
    1
    Did you tried with restarting watch? Or maybe hard reset of watch? Try also another USB cable.