• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Windows 8 RTM x64 unsigned driver override ?

Search This thread

cristiano.orlando

Senior Member
Dec 22, 2010
93
5
Hello there

I was using Windows 8 CP and I managed to use unsigned driver with bcdedit stuff

But with RTM i use the same thing about about testsigning

bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS

bcdedit -set TESTSIGNING ON

I used Double D on DDISABLE for CP it worked, but now with double D or even with
bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS

It does not start with test mode

And about the group policy, same stuff

Changed code signing for driver to enabled/ignore warnings, and still no game

this is a copy from my bcdedit
C:\Windows\system32>bcdedit

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=\Device\HarddiskVolume2
description Windows Boot Manager
locale en-US
inherit {globalsettings}
integrityservices Enable
default {current}
resumeobject {ae6e608f-e990-11e1-a01d-c0bf5e481f67}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 8
locale en-US
loadoptions DISABLE_INTEGRITY_CHECKS
inherit {bootloadersettings}
recoverysequence {ae6e6091-e990-11e1-a01d-c0bf5e481f67}
integrityservices Enable
recoveryenabled Yes
nointegritychecks Yes
testsigning Yes
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \Windows
resumeobject {ae6e608f-e990-11e1-a01d-c0bf5e481f67}
nx OptIn
bootmenupolicy Standard

What am i doing wrong ?

tks !
 

cristiano.orlando

Senior Member
Dec 22, 2010
93
5
Hi

The problem with that trick is it because i use dual boot here and sometimes windows does not reboot proper with the test signing part

What is the proper way to actually make it permanent ?

The old way worked with CP but with RTM no go

tks
 

e.mote

Senior Member
Feb 16, 2011
2,160
887
Apparently the BCD options aren't enough. You'd need to edit the group policy as well, per below. (This is a copy-paste job, I haven't had the occasion to installed unsigned drivers.)

# Return to the Start Screen, start typing gpedit.msc and hit Enter.
# Navigate to User Configuration (2nd node) | Administrative Templates | System | Driver Installation | Code signing for device drivers
# Double-click the policy and set it to Disabled.
# Restart your computer.
 
  • Like
Reactions: 5murf3r23

danchar4

Senior Member
Feb 27, 2011
53
9
Seattle
Try this:
bcdedit /set {bootmgr} displaybootmenu yes
bcdedit /set testsigning on
bcdedit /set nointegritychecks on

If your driver is test signed, you should use the following to add the test cert into the local store:
certmgr.exe -add abc.cer -r localMachine -s root

If your system is capable of UEFI/secure boot and secure boot is enabled, you'll have to press F8 and select the disable enforcement option #7 manually each time you boot.


Or just hookup a kernel debugger and you can bypass all enforcement.
 
Last edited:

Cav3

Senior Member
Oct 4, 2011
160
22
Hello there

BLAH BLAH BLAH......

What am i doing wrong ?

tks !

do this...
1. Windows Key + R
2. Enter shutdown.exe /r /o /f /t 00
3. Click the "OK" button

remember the steps from here onwords as it will take you to the restart options and close your browser/apps
sooo where was we.?

4. You will now be on "Choose an option" screen
5. Select "Troubleshoot"
6. Select "Advanced options"
7. Select "Windows Startup Settings"
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement" (number 7 on the list)
11. Once the system starts, install the drivers as you would on Windows 7
:good::fingers-crossed:
 
  • Like
Reactions: akkumies

closurez

Senior Member
Jun 29, 2011
73
6
do this...
1. Windows Key + R
2. Enter shutdown.exe /r /o /f /t 00
3. Click the "OK" button

remember the steps from here onwords as it will take you to the restart options and close your browser/apps
sooo where was we.?

4. You will now be on "Choose an option" screen
5. Select "Troubleshoot"
6. Select "Advanced options"
7. Select "Windows Startup Settings"
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement" (number 7 on the list)
11. Once the system starts, install the drivers as you would on Windows 7
:good::fingers-crossed:

not sure if you'd know or not but would this make my video card driver run better? if i were to revert back to the 7 driver?

i have an nvidia 9800 which ran perfectly on 7 but on 8 it crashes and restarts and some times gets blurry and shakey. nvidia just released the windows 8 driver which has only crashed once but still has the shakey blurry problem at times.
 

Dr_Jefferson

Member
Dec 1, 2011
42
2
Zoetermeer
Any working solutions yet? I have the same problem with a sound card and custom drivers. (terratech aurion 5.1 pci with cmedia/dogbert drivers)
They work of I start up in advanced mode and disable integrity checks. But then when I reboot they don't work anymore. Tried all the above solutions.
 

FDisk80

Senior Member
Jun 17, 2012
1,059
364
Any working solutions yet? I have the same problem with a sound card and custom drivers. (terratech aurion 5.1 pci with cmedia/dogbert drivers)
They work of I start up in advanced mode and disable integrity checks. But then when I reboot they don't work anymore. Tried all the above solutions.

Try This.

Open a command prompt as an admin and type:

bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON
-Reboot-
-Install driver-
Admin command prompt again
bcdedit /deletevalue loadoptions
bcdedit -set TESTSIGNING OFF
 

netham45

Inactive Recognized Developer
Jun 24, 2009
886
567
Denver
Try This.

Open a command prompt as an admin and type:

bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON
-Reboot-
-Install driver-
Admin command prompt again
bcdedit /deletevalue loadoptions
bcdedit -set TESTSIGNING OFF


Clearing the testsigning and disable_integrity_checks would do nothing except cause it to not load them after the first reboot, even if it did load them in the first place.
 

Dr_Jefferson

Member
Dec 1, 2011
42
2
Zoetermeer
Try This.

Open a command prompt as an admin and type:

bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON
-Reboot-
-Install driver-
Admin command prompt again
bcdedit /deletevalue loadoptions
bcdedit -set TESTSIGNING OFF
When installing the driver it gives me an error. It says: "The non-Microsoft INF-file Doesn't include a digital signature."

The only time I don't get that message is when I boot in advanced bootmode with disabled signature checks and then install them. And in that mode the drivers work. But when I restart (even in test mode with integrity checks disabled) they don't.
 

5murf3r23

New member
Mar 23, 2015
1
0
Follow these steps
QUOTE=e.mote;32690034]Apparently the BCD options aren't enough. You'd need to edit the group policy as well, per below. (This is a copy-paste job, I haven't had the occasion to installed unsigned drivers.)

# Return to the Start Screen, start typing gpedit.msc and hit Enter.
# Navigate to User Configuration (2nd node) | Administrative Templates | System | Driver Installation | Code signing for device drivers
# Double-click the policy and set it to Disabled.
# Restart your computer.[/QUOTE]
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Apparently the BCD options aren't enough. You'd need to edit the group policy as well, per below. (This is a copy-paste job, I haven't had the occasion to installed unsigned drivers.)

    # Return to the Start Screen, start typing gpedit.msc and hit Enter.
    # Navigate to User Configuration (2nd node) | Administrative Templates | System | Driver Installation | Code signing for device drivers
    # Double-click the policy and set it to Disabled.
    # Restart your computer.
    1
    Hello there

    BLAH BLAH BLAH......

    What am i doing wrong ?

    tks !

    do this...
    1. Windows Key + R
    2. Enter shutdown.exe /r /o /f /t 00
    3. Click the "OK" button

    remember the steps from here onwords as it will take you to the restart options and close your browser/apps
    sooo where was we.?

    4. You will now be on "Choose an option" screen
    5. Select "Troubleshoot"
    6. Select "Advanced options"
    7. Select "Windows Startup Settings"
    8. Click "Restart" button
    9. System will restart to "Advanced Boot Options" screen
    10. Select "Disable Driver Signature Enforcement" (number 7 on the list)
    11. Once the system starts, install the drivers as you would on Windows 7
    :good::fingers-crossed: