• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Windows Phone 7 build 6176 Unlocked Emulator Image

Search This thread

RustyGrom

Senior Member
Apr 18, 2006
1,006
82
Orlando
Thankfully Microsoft didn't change anything in their 'protection' of the WP7 emulator image. Following the same steps as the previous build, I was able to unlock the new 'April Refresh' emulator image. It's largely the same but here's what I've noticed.

  • It seems a bit more buggy. I've noticed some odd screen drawing issues and even jaggy lines. Maybe it's my laptop?
  • Most apps seem slightly updated and more polished. A few quirks here and there.
  • Phone! Yup, you can see the dialer and it even fakes working.
  • Office is actually working. Looks like the apps shown in the videos they released.

v2... in my late night grogginess I missed the settings entries. This one should have all the settings unlocked now (including some new stuff that wasn't in the February build)
Unlocked Emulator bin v2 (multiupload) (fast mirror)

To launch it use the same process as before... "xde.exe WM70C1AprilUnlockedv2.bin"

Gizmodo posted a How to: Try Windows Phone 7 now. Although that was for the previous build, the same general steps apply. You'll just need to use the emulator bin above and the new Dev tools CTP - April Refresh. It will NOT work with the February release.


New long press menu?
longpress.jpg


The dialer, very basic
phonedialer.jpg


the 'call status' screen while in a call
callstatus.jpg


Call log w/ active phone call
calllog.jpg
 
Last edited:

NoWorthWhile

Senior Member
Sep 15, 2008
159
0
Bruxelles
Thanks mate, that was what I was looking for... I was able to add a gmail account, but no sync occured. Althought, it seems it can sync contacts, mail & calendar alltogether.

Trying to find a way to add a windows live ID to fully exploit the phone :)
 

svetius

User Experience Admin
Dec 23, 2009
4,787
8,612
Samsung Galaxy Z Fold2
OnePlus 9 Pro
Giving this a try just for fun =D.

I'm not getting any luck through the method that you mentioned to load up the BIN. Is there a way I can drop this file in a file, open up Visual Studio, and do an F5 to get the emulator going with the new image?
 

RustyGrom

Senior Member
Apr 18, 2006
1,006
82
Orlando
Giving this a try just for fun =D.

I'm not getting any luck through the method that you mentioned to load up the BIN. Is there a way I can drop this file in a file, open up Visual Studio, and do an F5 to get the emulator going with the new image?

Replace the original one in C:\Program Files\Microsoft SDKs\WindowsPhone\v7.0\Emulation\Images\

I haven't tried with this one but you couldn't debug with the previous version. It will launch it though.
 

tecfield

Member
Apr 27, 2009
10
0
Cannot run the ROM!

Hey guys,
When I try to run the ROM, it hangs at the "Loading...." stage and doesn't go further at all.
Do you have any idea what I might be doing wrongly?
The first version of ROM works perfectly though.


Thank you in advance
 

RustyGrom

Senior Member
Apr 18, 2006
1,006
82
Orlando
Hey guys,
When I try to run the ROM, it hangs at the "Loading...." stage and doesn't go further at all.
Do you have any idea what I might be doing wrongly?
The first version of ROM works perfectly though.


Thank you in advance
Are you using the old XDE or the one released yesterday? I haven't tried it in the previous one but I'm guessing this is the cause.
 

RustyGrom

Senior Member
Apr 18, 2006
1,006
82
Orlando
Anyone have any ideas as to why the other apps (mail, facebook, etc) won't connect? It's gotta be some stupid registry entry like the rest of the "unlocking" or maybe just in a XML file somewhere. I'm fairly certain that they're using "SNService" for windows live and facebook status update type stuff and ActiveSync with some new plugins for Live mail, etc.
 

berrytarts

Senior Member
Aug 27, 2009
126
22
Singapore
Suggestion for Hosting Of Files

replaced rapidshare with multiupload. If you have a better suggestion let me know.

Sorry for being fussy here, cause I've always been a user of Mediafire, it gets the job done easily, so I kind of like it. Multiupload usually causes Megaupload to reject my ip, saying I have an elevated number of requests, bla bla. Rapidshare works only after a number of tries with the different server under advanced options, and the only one i use is zShare, and it sucks cause it downloads at unstable speeds(i get a speed ranging from 30kbp/s and 100kbp/s) while my max speed is 300kbps! Well, thanks for reading. It's okay if you don't change, I can live on. :)

EDIT: I saw the 100mbits server website, thanks freedom! :D although this is still a suggestion for the hosting of your files. thanks :)
 
Last edited: