Windows Phone 7 build 7.0.0.6077--for WP7 emulator only

Search This thread

newshaggy

Member
Feb 7, 2010
32
1
BOOOFF and XIPPort

Can someone please upload and link compress.dll for BOOOFF as I do not have CE 6.0 Platform... thank you.
 

AnDim

Senior Member
Jan 21, 2007
168
529
Are you using hvedit.exe to crack open the .hv files? The version posted on xda seems to crash on large binary keys [HKEY_LOCAL_MACHINE\System\Notifications\DeviceReg]

1. Attach this .hv, please.
2. To edit .hv - use mregedit.exe

AnDim
 
Last edited by a moderator:

JesusFreak316

Senior Member
Aug 19, 2009
520
66
31
I still keep getting the error 'Connection failed because of invalid command-line arguments.' Emulator starts then disappears with above error. I have uninstalled and reinstalled it. Also tried with the shortcut version. Am on Windows 7. Downloaded VS 2010 express. I don't know what else to do. Please advise guys :(

UPDATE It seems this is a very common problem with no solution :( :(
h**p://social.msdn.microsoft.com/Forums/en-US/windowsphone7series/thread/e5a71d11-5af9-463d-970d-e2e6015b2e8d
I had that problem too; I just uninstalled all the files related to it, specifically vs2010 for phone, the windows phone developer tools, and dotnetfx. When I reinstalled, everything worked.

Crap, typed the above part then noticed you said you uninstalled it. lol. Did you uninstall all three of those parts?
 

tboy2000

Senior Member
Oct 21, 2006
2,320
429
London
Huawei Mate 20
Huawei Mate 20 X
I had that problem too; I just uninstalled all the files related to it, specifically vs2010 for phone, the windows phone developer tools, and dotnetfx. When I reinstalled, everything worked.

Crap, typed the above part then noticed you said you uninstalled it. lol. Did you uninstall all three of those parts?

I only installed vs2010. Was I supposed to install the developer tools and dotnetfx too or were they automatically installed when I installed the vs2010?

If not, any links for the other 2?

Thanks!
 

JesusFreak316

Senior Member
Aug 19, 2009
520
66
31
I only installed vs2010. Was I supposed to install the developer tools and dotnetfx too or were they automatically installed when I installed the vs2010?

If not, any links for the other 2?

Thanks!

I believe the sdk should check if those are installed and link to them, but if not, they are on the ms website. Just google them.
 

Tribulattifather

Inactive Recognized Developer
Apr 23, 2009
2,941
1,823
37
╠▒╣New╬York╠▒╣
If you want to try the emulation for yourself you need to have a Windows Vista or 7 PC and you should follow these steps:


* Download this.
* Download the image from here.
* Put the downloaded bin into C:\Program Files (x86)\Microsoft SDKs\WindowsPhone\v7.0\Emulation\Images\ .
* Go to C:\Program Files (x86)\Microsoft XDE\1.0\ and find the XDE.exe. Right click on it and then select "Create Shortcut" (you may be asked to save that shortcut on the desktop).
* Go to the properties of your new shortcut and modify the Target field as this: "C:\Program Files (x86)\Microsoft XDE\1.0\XDE.exe" "C:\Program Files (x86)\Microsoft SDKs\WindowsPhone\v7.0\Emulation\Images\WM70Full.bin"
(Copy the whole thing - meaning copy both ".." ".." and paste it in.)

Note that 64-bit Windows users must select Program Files (x86) folder instead the original Program Files.
 

Thr Guy 34

Member
Dec 9, 2008
13
0
ive ne all the steps and i go to run the emulator and it starts and says it is loading then it just closes. no error just goes away. whats wrong:(
 
If you want to try the emulation for yourself you need to have a Windows Vista or 7 PC and you should follow these steps:


* Download this.
* Download the image from here.
* Put the downloaded bin into C:\Program Files (x86)\Microsoft SDKs\WindowsPhone\v7.0\Emulation\Images\ .
* Go to C:\Program Files (x86)\Microsoft XDE\1.0\ and find the XDE.exe. Right click on it and then select "Create Shortcut" (you may be asked to save that shortcut on the desktop).
* Go to the properties of your new shortcut and modify the Target field as this: "C:\Program Files (x86)\Microsoft XDE\1.0\XDE.exe" "C:\Program Files (x86)\Microsoft SDKs\WindowsPhone\v7.0\Emulation\Images\WM70Full.bin"
(Copy the whole thing - meaning copy both ".." ".." and paste it in.)

Note that 64-bit Windows users must select Program Files (x86) folder instead the original Program Files.

Yay! It works!!

Almost...

When I tried to debug an application with this ROM using the VS2010 for Windows Phone I've got an error saying that the port was already in use.

I don't get such error with the original ROM.

It would be nice to be able to debug on a full version.
 

Genjinaro

Senior Member
Jan 16, 2007
1,722
352
Philadelphia, PA
How the hell to you get the unlocked ROM to connect online?


I keep getting this error after launching the emulator:

"a specified communication resource (port) is already in use by another application"

Which is bull****,

Anyone get around this? :(
 

caveman102

Member
Mar 31, 2010
27
3
NYC
it ran smooth on me no conection problem ohh if u runing 32bit take out program file(x86) just let program filefor those newbieee
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Cook your own WMp7 ROM

    You can cook your own emulator ROM with WP7

    Here is the tools:
    BOOOFF and XIPPort.

    With B000FF:
    1. Convert BIN->NB0
    2. In ReplaceFiles hit "NB0 map" to get the file listing of the ROM
    3. (PROFIT!)
    4. Apply changes to file (or remove them) (It's applying changes directly, so be carefull)
    5. Convert NB0->BIN
    6. Apply "Fix 12" (Select original .bin file, and the converted one)
    7. Run emulator
    "C:\%PROGRAM FILES%\Microsoft XDE\1.0\XDE.exe" "%YOUR BIN HERE"

    With XIPPort:
    You are able to make a full dump of ROM
    1. Hit "dump .bin". It will create an "OUT" folder with "FILES" and "MODULES" subfolder. You can modify files, or remove them.
    2. When you done,hit "write .nb0" it will create a .nb0 file from OUT folder.
    3. Use B000FF to convert nb0->bin and apply "Fix 12" (from step 5 in B000FF)
    1
    Can anyone post another link for the new WMP7 Unlocked Emulator,
    because the uploader decided to take down the link
    1
    Bump.

    The latest build I have is 7629. I'm struggling to find a dump of a more recent build. Does someone have a lead?

    You can always do it yourself, as long as you have the BIN.