• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Working REAL(!) 3g / 4g USB Modem-Sticks on PX5/PX3 Units

Search This thread

talrhv

Senior Member
Mar 17, 2020
51
0
what about px6

Is there a working LTE modem that is recognize by the head unit? I have the Dasaita Max6 px6 chip
and looking for a solution of using wireless Carplay (which is using the head unit wifi) and still have internet access on the head unit itself.

Thanks

---------- Post added at 12:08 PM ---------- Previous post was at 11:54 AM ----------

I finally got this working. Flashed the first two firmwares in Ubuntu on a e3372h-607 and it started working in Ubuntu in LTE mode, so I tried in HU and it works! I'm pretty sure it's lte/4g, but can't be 100% sure. See the speed test I did.

All apps work flawless.

Edit: to be clear: I did not flash the last file which is the hilink one. I also have the same issue as you that it takes some seconds to boot up. But this is worth it still.

View attachment 5026977

Sent from my Pixel 3 XL using Tapatalk


Hi,

Are you using a px6 unit or px5?
I'm looking also for an LTE working modem for my dasaita max6 head unit so i won't need to use the internal wifi to get internet connection (I need to internal wifi for apple wireless carplay)
is the E3372H-607 the best solution for this unit?

Thanks!
 

Rawb1

Senior Member
May 31, 2015
56
9
Is there a working LTE modem that is recognize by the head unit? I have the Dasaita Max6 px6 chip

and looking for a solution of using wireless Carplay (which is using the head unit wifi) and still have internet access on the head unit itself.



Thanks

---------- Post added at 12:08 PM ---------- Previous post was at 11:54 AM ----------







Hi,



Are you using a px6 unit or px5?

I'm looking also for an LTE working modem for my dasaita max6 head unit so i won't need to use the internal wifi to get internet connection (I need to internal wifi for apple wireless carplay)

is the E3372H-607 the best solution for this unit?



Thanks!
This is a px6. Following instructions further up and if you read my posts you should see how I did it. I used a 607, but i think it works with 153 also.

Sent from my Pixel 3 XL using Tapatalk
 
  • Like
Reactions: talrhv

mothu

New member
May 3, 2019
2
0
does it work with dasaita stock firmware or I must use one of the mods (hal9k etc)?
I am using e3372h-153 on a Dasaita device. At first with original firmware and now with hal9k rom, without any issues. My original Dasaita rom was an Android 8 rom, and now I use hal9k Android 9 rom. More info on how I made my modem be seen as a usb network device here
 

acvaristul

Member
Dec 4, 2010
41
14
Bucharest
I use the following combination:
- PX5 (a Seicane device) - Android 9 (Hal9k ROM),
- 4G LTE WiFi HotSpot Wingle Huawei e8372h-153 modem,
- everything works perfectly (4G and 3G).

2fcW973.jpg
 

Slim_Boy_Fat

Member
Mar 31, 2020
8
1
Finally managed to get my Huawei E3772h-153 working. I'd spent hours searching for a solution that worked but nothing did until I found this youtube vid.
https://www.youtube.com/watch?v=oRii6o6JeZI
I followed the instructions so that I had a downgraded firmware installed and then downloaded the firmware from this youtube vid
https://www.youtube.com/watch?v=EaOHIS2gadk&t
and only upgraded the second one. I did have to use an old laptop running Win 7 to get it to work.
 

rsm1024

New member
Oct 3, 2010
2
0
Dasaita max10 + e3372

I have a Dasaita MAX10 and the huawei e3372h-320 and it’s work without making any changes

(In the setting, it is recognised as Ethernet)
 

tlatech

Member
Dec 10, 2017
6
1
I have a Dasaita MAX10 and the huawei e3372h-320 and it’s work without making any changes

(In the setting, it is recognised as Ethernet)

I have a couple of questions:

1. Which version of Android are you running? Which MCU version? Is it a custom ROM?

2. Did you just plug the Modem in and it worked? Did you change it from stick mode to modem mode. If so, what procedure did you follow?

3. Is it working as a 3G or 4G connection.

I have one of these modems. I am seeing a "Signal Strength" icon on the status bar, but I have no data connection.

Thanks.
 

rsm1024

New member
Oct 3, 2010
2
0
I have a couple of questions:

1. Which version of Android are you running? Which MCU version? Is it a custom ROM?

2. Did you just plug the Modem in and it worked? Did you change it from stick mode to modem mode. If so, what procedure did you follow?

3. Is it working as a 3G or 4G connection.

I have one of these modems. I am seeing a "Signal Strength" icon on the status bar, but I have no data connection.

Thanks.

Android 10
No custom rom
Juste plugged and it work I have no signal strength I have Ethernet icon

And it work on 4G
 

Stefan McSleaze

Senior Member
Sep 5, 2014
197
92
Bochum, Rock City
www.facebook.com
I'm using a Seicane PX5 HU with Hal9k A9 rom. With the Huawei e160X, original Firmware, it connects to network only after checking the 'roaming' checkbox. Its a 3G Modem Stick, and it offers Data limitation in the Network settings too. Nothing grayed out. Connection stability is pretty good.
The only bad thing for me...if wifi is active,( i use it to connect my OBD2,) it has no 3G data connection, because android prior uses wifi for internet instead of 3G data and awaites data connection over wifi...
 
Last edited:

ojuniour

Senior Member
Feb 5, 2010
105
19
New Jersey
I've bought a ZTE MF833V.
It is not working out of the box as Windows 10 doesn't have drivers for it. Linux ones have drivers and show coverage, but connection doesn't happen.
My PX5 Joying installs a driver as well, as it shows mobile connection icon now, but connection doesn't happen.

So back to seller.

I have the seller send me the driver..if you are willing to try , I can send it to ya.
 

ojuniour

Senior Member
Feb 5, 2010
105
19
New Jersey
ZTE MF833V Confirmed!

Yep I can very much confirm that the mf833v works on T-mobile . I got the custmized version from amazon which should also work on AT&T (and i believe verizon also? - don't take my word for it).
Search amazon for
ZTE MF833V (Customized Version Covering Global Bands) 4G LTE Mobile USB Modem Dongle
https://www.amazon.com/ZTE-MF833V-C...child=1&keywords=mf833v&qid=1605635946&sr=8-1

Just follow te instruction by using AT command : AT+ZCDRUN=8 .
If you are not getting internet then, you need to first disable "auto connect" ) on the web interface (192.168.0.1) on windows/Mac before running the AT command.
You can reverse the setting to work on windows again by running command (directly on dc-unlocker command line):
AT+ZCDRUN=9,
AT+ZCDRUN=F,
This will put it back in CD Mode.
IF you don't have a the driver, let me know. Cheers.

Image attacked taken running on my 'idoing' PX6 android 10 stereo.
 

Attachments

  • IMG_20201117_103345__01.jpg
    IMG_20201117_103345__01.jpg
    240.9 KB · Views: 198

Master2093

New member
Sep 5, 2019
3
0
Dasaita PX6, Hal9k 9.0, Huawei E8372, working fine, no problems at all.
Hello, does the modem detect the 4G symbol in the radio notification bar? Does the Radardroid app detect the network?
I have a Dasaita px6 with android 10 and with the Huawei 8372 4G modem and I only have ethernet and the Radardroid app does not download the radar database, because it does not detect the network, instead Spotify, google chrome and playstore do have access to network.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    UPDATE 17th sep 2019: PROJECT CLOSED, see post #147 .


    Okay,

    we´ve got many threads about "3g/4g" USB-sticks für Car Androids powerd by PX3/PX5.

    BUT: most posts describe WiFi-Sticks and Sticks recognized as ethernet connection or ´WiFi-Hotspot Crap´ devices.....

    i think we need a thread for WORKING REAL MODEMS (detected as mobil-connection) on this devices.....

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    so! here the first modem i found that 100% worked as a MODEM:

    as 3G:
    Huawei E173u-1 (fully working w/o loosing connection, be sure to run Firmware 11.126.85.00.209; up- or downgrade!!!)
    Huawei E173u-2 (fully working w/o loosing connection, be sure to run Firmware 11.126.85.00.209; up- or downgrade!!!)

    (Huawei E173S-1 WILL NOT WORKING!)

    tested on PX5 with Malaysk 3.2 (oreo)

    Firmware 11.126.85.00.209 for E173:
    https://download.myusbmodem.com/home/Huawei Firmwares/E173/E173Update_11.126.85.00.209_B427.zip

    flash code generator:
    https://huaweiunlockcalculator.com/huawei-flash-code


    ----------------------------------------------------------------------------------------------------------------------------------------------------------------
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------

    today (14th March 19) i can confirm:

    also working with 3g:
    HUAWEI K3772 - HSPA USB Stick

    note:

    - working with ALL PX5 Android Systems (Stock Marshmallow, Malaysk Marshmallow, Stock Oreo, Malaysk Oreo, hal9k Oreo)
    - no problems with handover or switching between 3g/2g
    - perfect working surf-stick

    Pictures of the Stick (wtf... IMG bbcode doesn´t work :confused: )
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190314_2.jpg
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190314_1.jpg

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------
    today (15th March 19) i can confirm:

    also working with 3g:
    HUAWEI E3131s-1 3G Surfstick in ´Modem-Mode´ <recommended Device for ´Oreo´

    note:

    - working with ALL PX5 Oreo Android Systems (Stock Oreo, Malaysk Oreo, hal9k Oreo) > NOT working on any Marshmallow (only signal strength shown, no 3G connection)
    - no problems with handover or switching between 3g/2g
    - perfect working surf-stick
    - has the BEST RADIO LINK with PERFECT SPEED-RATE of all tested devices (til today; 15th March ´19)
    - has connection for an external antenna (CRC-9 jack) > great

    Pictures of the Stick (wtf... IMG bbcode doesn´t work :confused: )
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190315_1.jpg
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190315_2.jpg
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190315_3.jpg
    pictures.net-freaks.com:1073/user112718ef/2019/xda/20190315_4.jpg

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------



    /chris
    2
    Fyi folks just managed to get zte mf833v working with xtrons gs px5 Oreo with actual 4g, NOT RNDIS ethernet (see attached pic)

    The way I did it was to place the modem into non-usb mode so that it shows up as a cdc-gsm device.
    1: download DC unlocker on your windows pc (this is to get the modem to show up as a COM port)
    2: plug your modem into PC and launch DC unlocker as administrator. Select zte modem from the list and leave the rest of the fields on the default auto select. Hit search
    3: open up device manager on your PC and look for ports and you should see two COM porta for your zte modem each with a number next to them. Take note of the number next to the one that DOESN'T say diagnostic on it.
    4: download PuTy or any other terminal program of your choosing. Connect to the aforementioned COM port using serial connect and if it works well you should see a command line window where if you type AT and hit enter you will get OK as a response
    5: type AT+ZDCDRUN=8 and hit enter to place the modem into non-usb mode. If it goes well you should get a message saying updated modem mode or something similar.

    Unplug your modem and put it aside for now.

    6: if you are using an xtrons unit you need two more things. First you'll need the right MCU as the factory shipped MCU does NOT support cellular network. I've attached the one I'm using to this..make sure you update. Second is you'll need a network settings app to actually enter your APN settings. You can find one on the play store but you won't be able to enter APN settings until you plug in the modem

    7: plug your modem In ONLY WHEN YOUVE DONE EVERYTHING ABOVE.
    If all goes well it should now allow you to edit your APN. Enter it and hit save then restart your tablet.

    8: profit



    I've done some testing with this setup and it takes on average about 20 seconds from start for the tablet to have 4g internet. I toyed around with keeping the modem on a permanently powered usb port but have not been able to keep the connection stable.

    Driving around the tablet keeps data signal and switches between cell towers seamlessly.

    I do notice that if I turn my car on and off multiple times in succession that can cause the tablet to no longer see the modem. A simple USB reset when that happens does the trick.
    2
    do they configure the APN automatically?
    do you see mobile data settings in android settings by default or only after connecting the USB LTE stick?
    does it power up when unit turns on?
    how long till connection is established after boot?

    i'm also looking for a working LTE stick for a Xtrons PX5 octacore 4/32GB with 8.0....even their own Xtrons accesory is used as hotspot, not mobile data mode.

    hi,

    unfortunately NO LTE stick is working native at this moment. only 3g/2g sticks are working. the best working device is the Huawei E173u-1 and E173u-2 AS NATIVE MOBILE CONNECTION (be sure you run Firmware 11.126.85.00.209 on E173; link in post 1). the connection established after ´wake up´ in 20 sec and shown in the status bar. pls. do not use usb extention-cables to connect the stick. the surfstick use up to 300mA und will crash when the USB cable is over 1m.

    at this moment (mar2019) i´m working on a custom firmware for Huawei E398 LTE stick for native working on PX5 devices based on malaysk rom oreo. Hal9k ROM Oreo and mobile connection is NOT WORKING STABLE.

    regards
    /chris
    2
    confirm working 4G/LTE modem Huawei E3372h in ethernet-over-usb (CDC) mode.
    crazy speeds, stable connection. Works fine after sleep/shutdown. HU online in ~10-15sec.
    it has to be prepared as indicated by the comrades here. Tested on MTCE GS PX5, octacore, Android 8.0(!), 4GB RAM
    2
    Best method to get 4G - Huawei E8372 Wingle.
    Plug it into a cigarette lighter USB adapter and create a WiFi hotspot in your car that headunit then joins to.
    Be careful plugging this into a USB port on radio as some stay powered after the ignition is turned off - end result flat battery as the dongles are reasonable power drain.
    I use this and have full 4G speeds - far superior to any of the 3G modems suggested so far.

    https://consumer.huawei.com/en/mobile-broadband/e8372/