Working T-Mobile US MMS APN Settings.

Search This thread

eosrider

Senior Member
Feb 5, 2008
86
6
Mods - I know this is a question asked in most android builds "how do i get mms to send?" so i took some time and tried to work out a bug.

Devs - Ill be testing on all available builds tonight and post the results here.

Mods, Devs, and [Ref] Thread holders - want to use it ? go ahead.

Everyone else -

I cant believe that I have my CCNA (Cisco Certified Network Associate) i did not notice this.

IP address octets cannot have a octet begin with a 0

So. having said that. use these settings and have a great time sending messages.

NAME: T-Mobile US
APN: epc.tmobile.com
PROXY: Blank
PORT: Blank
USERNAME: Blank
PASSWORD: Blank
SERVER: wap.voicestream.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS PROXY: 216.155.165.50 <--------- THE .50 is the major change i found.
MMS PORT: Blank
MCC: 310
MNC: 260
AUTH TYPE: NONE <--this is another changed setting. do not leave blank.
APN TYPE: default,supl,mms <-- This also seems to be important.

Make sure after editing that you press the windows key and click save.

Initial test Winmo - Android setup: Miri 17.6, Radio 2.10.50.28_2 / Android; ShubCraft

_______________________________________________________________________________

Another test. This time with Miri 17.6 Radio 2.10.50.28_2 / Android MATTC

Settings from first boot allow me to send MMS. However, Serious degradation not seen in first test.

Settings are:

APN; epc.tmobile.com
prox blank
port none
user none
password none
server none
mmsc mms.msg.eng.t-mobile.com/mms/wapenc
MMS protocol wap 2.0
mcc 310
mnc 260
auth none
type not set
 
Last edited:

swaser18t

Senior Member
Oct 29, 2008
355
4
MN
Mods - I know this is a question asked in most android builds "how do i get mms to send?" so i took some time and tried to work out a bug.

Devs - Ill be testing on all available builds tonight and post the results here.

Mods, Devs, and [Ref] Thread holders - want to use it ? go ahead.

Everyone else -

I cant believe that I have my CCNA (Cisco Certified Network Associate) i did not notice this.

IP address octets cannot have a octet begin with a 0

So. having said that. use these settings and have a great time sending messages.

NAME: T-Mobile US
APN: epc.tmobile.com
PROXY: Blank
PORT: Blank
USERNAME: Blank
PASSWORD: Blank
SERVER: wap.voicestream.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS PROXY: 216.155.165.50 <--------- THE .50 is the major change i found.
MMS PORT: Blank
MCC: 310
MNC: 260
AUTH TYPE: NONE <--this is another changed setting. do not leave blank.
APN TYPE: default,supl,mms <-- This also seems to be important.

Make sure after editing that you press the windows key and click save.

Initial test Winmo - Android setup: Miri 17.6, Radio 2.10.50.28_2 / Android; ShubCraft

just tried with same set up.... minus the miri rom... running the chucky droid rom... these settings do not work for me....
NONE OF THE POSTED SETTINGS WORK FOR ME... CRAZY thing is i was able to send one last night. ONE! thats it????????????????
 

eosrider

Senior Member
Feb 5, 2008
86
6
tesing multiple message sending now. with initial settings.

Multiple mms on initial settings works. have sent 4 different pictures to multiple numbers. all confirmed working.
 
Last edited:

djdant

Senior Member
Nov 18, 2007
869
29
36
Elk Grove, Ca
I can confirm these settings work for US T-Mobile just sent one to myself
Using mattc froyo 1.4
Latest zImage
Miri 17.6
Radio 2.12.50
Tmous 1024
Sent from my HTC Desire using XDA App
 

dysprosi

Senior Member
Apr 14, 2010
219
25
Honolulu, HI
Got it to send one MMS to myself. It took about 15 minutes. Had to disable WiFi. Can't get any more to send.

Using DarkStone froyo
Latest zImage (8/3)
Miri 17.6
Radio 2.12.50
Tmous 1024
Honolulu, HI
 

anniehero

Member
Jul 5, 2010
12
0
i can receive them now, which i couldn't consistently before. still no luck getting them out however.

i should add that it shows the correct file size when i send it as far as i know, none of them have popped up as being 1kb.
 
Last edited:

Susasama

Senior Member
Apr 2, 2010
192
4
Cocoa, Florida
I beginning to think Miri's ROM is the factor that is allow those to be able to send. Cause i sent 3, and not a single one worked for over 15 min had the logo, wifi, no wifi, and different radios.
 

eosrider

Senior Member
Feb 5, 2008
86
6
Tried 2 other roms and 2 other android builds per winmo rom. nothing worked.
Did not try experimenting with radio tonight but after all was said and done. went back to the first setup ( Android; Shub / Miri 17.6
 

eosrider

Senior Member
Feb 5, 2008
86
6
ok... something really weird is going on. With different builds i sent all different pictures of random items ( lighters, coins, water bottles ). now those builds that failed my testing were all taken off. SD card was formated between builds. I ended up going back to the setup I had when i started this thread, because it works.

Now i have the people who's picture i sent randomly saying that they are getting their pictures. 3 different pictures and people. Keep in mind that this is AFTER I formatted and went back to the working setup. so i didnt have the same pictures on the sd card.

Thoughts?
 

simeezee

Senior Member
Mar 26, 2010
293
3
I think the problem is the windows rom. I tried many different android builds none of them allowed me to send mms. I was only able to receive them.
 
  • Like
Reactions: mjmcc92

pandnaka

Senior Member
Mar 31, 2010
150
2
USA
Mods - I know this is a question asked in most android builds "how do i get mms to send?" so i took some time and tried to work out a bug.

Devs - Ill be testing on all available builds tonight and post the results here.

Mods, Devs, and [Ref] Thread holders - want to use it ? go ahead.

Everyone else -

I cant believe that I have my CCNA (Cisco Certified Network Associate) i did not notice this.

IP address octets cannot have a octet begin with a 0

So. having said that. use these settings and have a great time sending messages.

NAME: T-Mobile US
APN: epc.tmobile.com
PROXY: Blank
PORT: Blank
USERNAME: Blank
PASSWORD: Blank
SERVER: wap.voicestream.com
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS PROXY: 216.155.165.50 <--------- THE .50 is the major change i found.
MMS PORT: Blank
MCC: 310
MNC: 260
AUTH TYPE: NONE <--this is another changed setting. do not leave blank.
APN TYPE: default,supl,mms <-- This also seems to be important.

Make sure after editing that you press the windows key and click save.

Initial test Winmo - Android setup: Miri 17.6, Radio 2.10.50.28_2 / Android; ShubCraft

_______________________________________________________________________________

Another test. This time with Miri 17.6 Radio 2.10.50.28_2 / Android MATTC

Settings from first boot allow me to send MMS. However, Serious degradation not seen in first test.

Settings are:

APN; epc.tmobile.com
prox blank
port none
user none
password none
server none
mmsc mms.msg.eng.t-mobile.com/mms/wapenc
MMS protocol wap 2.0
mcc 310
mnc 260
auth none
type not set

:D This setting work for me send and recive! Thank in a million!:p
 
  • Like
Reactions: Ms. K

chiasoft

Senior Member
Feb 7, 2007
177
6
NYC
..... I said this once already.


ROM's with no SenseUI and stock Messaging App should work without error as long as APN is correctly Set. Stock/Non-Sense UI Rom's APN:

Code:
NAME: T-Mobile US
APN: epc.tmobile.com
PROXY: <Not Set>
PORT: <Not Set>
USERNAME: <Not Set>
PASSWORD: <Not Set>
SERVER: <Not Set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS PROXY: <Not Set>
MMS PORT: <Not Set>
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
AUTH TYPE: None
APN TYPE: default,supl,mms


ROM's WITH SenseUI all have the same issue/bugs if you are on T-Mobile in the US (even with the correct APN's set).

MMS pictures are shrunk to tiny tiny 2kb images when receiving with that HTC Messaging App, this is because Sense sends in the user-agent string for MMS found in: /system/customize/MNS/default.xml

T-Mobile's MMS server's doesn't recognize the "HTC Desire" user-agent string therefore when receiving MMS, you get a tiny tiny thumbnail pic. I think you can set it to "NexusOne" Or was it "Nexus One/Build FRFxx". Forgot if it was one or the latter. (OH.. this is only for TMOUS People, I don't think this affects european peeps, since the Desire Rom was made for that region.) Problem with this is, I think those settings are loaded with the initial setup (first boot, and I'm not sure where it's stored afterwards. If you modify now and save it, it seems to have no effect. Also, customized SenseUI seems to ignore the file altogether?)

Those with incorrect, or missing APN's using any ROM with SenseUI. If you are on T-Mobile, your settings should be as follows (This will allow you to send and receive, but theres the file size restriction):

Code:
NAME: T-Mobile Data
APN: epc.tmobile.com
PROXY: <Not Set>
PORT: <Not Set>
USERNAME: <Not Set>
PASSWORD: <Not Set>
SERVER: <Not Set>
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS PROXY: <Not Set>
MMS PORT: <Not Set>
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
AUTH TYPE: None
APN TYPE: default,supl,mms

Actually, ignore this one, its apparently used for Firmware Over-The-Air updates.
Code:
NAME: T-Mobile FOTA
APN: epc.tmobile.com
PROXY: <Not Set>
PORT: <Not Set>
USERNAME: <Not Set>
PASSWORD: <Not Set>
SERVER: <Not Set>
MMSC: <Not Set>
MMS PROXY: <Not Set>
MMS PORT: <Not Set>
MMS Protocol: WAP 2.0
MCC: 310
MNC: 260
AUTH TYPE: None
APN TYPE: hipri
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Mods - I know this is a question asked in most android builds "how do i get mms to send?" so i took some time and tried to work out a bug.

    Devs - Ill be testing on all available builds tonight and post the results here.

    Mods, Devs, and [Ref] Thread holders - want to use it ? go ahead.

    Everyone else -

    I cant believe that I have my CCNA (Cisco Certified Network Associate) i did not notice this.

    IP address octets cannot have a octet begin with a 0

    So. having said that. use these settings and have a great time sending messages.

    NAME: T-Mobile US
    APN: epc.tmobile.com
    PROXY: Blank
    PORT: Blank
    USERNAME: Blank
    PASSWORD: Blank
    SERVER: wap.voicestream.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS PROXY: 216.155.165.50 <--------- THE .50 is the major change i found.
    MMS PORT: Blank
    MCC: 310
    MNC: 260
    AUTH TYPE: NONE <--this is another changed setting. do not leave blank.
    APN TYPE: default,supl,mms <-- This also seems to be important.

    Make sure after editing that you press the windows key and click save.

    Initial test Winmo - Android setup: Miri 17.6, Radio 2.10.50.28_2 / Android; ShubCraft

    _______________________________________________________________________________

    Another test. This time with Miri 17.6 Radio 2.10.50.28_2 / Android MATTC

    Settings from first boot allow me to send MMS. However, Serious degradation not seen in first test.

    Settings are:

    APN; epc.tmobile.com
    prox blank
    port none
    user none
    password none
    server none
    mmsc mms.msg.eng.t-mobile.com/mms/wapenc
    MMS protocol wap 2.0
    mcc 310
    mnc 260
    auth none
    type not set
    1
    I think the problem is the windows rom. I tried many different android builds none of them allowed me to send mms. I was only able to receive them.
    1
    Mods - I know this is a question asked in most android builds "how do i get mms to send?" so i took some time and tried to work out a bug.

    Devs - Ill be testing on all available builds tonight and post the results here.

    Mods, Devs, and [Ref] Thread holders - want to use it ? go ahead.

    Everyone else -

    I cant believe that I have my CCNA (Cisco Certified Network Associate) i did not notice this.

    IP address octets cannot have a octet begin with a 0

    So. having said that. use these settings and have a great time sending messages.

    NAME: T-Mobile US
    APN: epc.tmobile.com
    PROXY: Blank
    PORT: Blank
    USERNAME: Blank
    PASSWORD: Blank
    SERVER: wap.voicestream.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS PROXY: 216.155.165.50 <--------- THE .50 is the major change i found.
    MMS PORT: Blank
    MCC: 310
    MNC: 260
    AUTH TYPE: NONE <--this is another changed setting. do not leave blank.
    APN TYPE: default,supl,mms <-- This also seems to be important.

    Make sure after editing that you press the windows key and click save.

    Initial test Winmo - Android setup: Miri 17.6, Radio 2.10.50.28_2 / Android; ShubCraft

    _______________________________________________________________________________

    Another test. This time with Miri 17.6 Radio 2.10.50.28_2 / Android MATTC

    Settings from first boot allow me to send MMS. However, Serious degradation not seen in first test.

    Settings are:

    APN; epc.tmobile.com
    prox blank
    port none
    user none
    password none
    server none
    mmsc mms.msg.eng.t-mobile.com/mms/wapenc
    MMS protocol wap 2.0
    mcc 310
    mnc 260
    auth none
    type not set

    :D This setting work for me send and recive! Thank in a million!:p
    1
    How do I get to the apn adjustment?

    Thanks

    press windows button then click settings>wireless & networks>Mobile Networks>Access Points

    Just press the APN you want to edit then press windows button then click save.