X10 2.1 Root!

Status
Not open for further replies.
Search This thread

hayder.jabar

Member
Jul 28, 2010
13
0
Thanks to CLShortFuse


By using SuperOneClick v1.5.1 (Root, Unroot, Enable Non-Market App, Get UNLOCK code)

http://forum.xda-developers.com/showthread.php?t=803682


X10i 2.1 is Rooted now!.



2.jpg

1.jpg
 
Last edited:

Casmo

Senior Member
Sep 5, 2010
127
10
-
casmo.nl
Nope, it's failing for me as well, phone keeps popping up with connecting to phone, and then the root fails.
 

JoFly

Member
May 22, 2008
14
0
Thats strange... cause it worked first time for me... It connects the phone, then does the "running rageagainstthecage" thing a couple of times, but eventually roots my phone.
 

3dawg

Senior Member
Oct 22, 2010
799
187
Fails on running rageagainstthecage
It just keeps looping the whole process again from that point onwards.
 

MarylandCookie

Senior Member
May 13, 2010
1,317
351
Birmingham, UK
Can those who've rooted their 2.1 post some screenies and some details like original firmware, update firmware, any additional files added to root folder (super1click), operating system etc
Im assuming everyones using nordic 2.1
 

awojtas

Senior Member
Apr 20, 2005
348
72
Wellington
Says "rooted" for me - it froze halfway through, so I unticked "USB debugging" then re-ticked it (while plugged in and SOC running) and it seems to have worked.

Rebooted, installed BusyBox and it says "Your phone is rooted"

Sweet! Damn that was quick!

[was on Vodafone NZ 1.6, flashed Nordic, then SEUS to 2.1]

[Edit: Can't get Market fix to work yet]
 
Last edited:

saurabhkunte

New member
Jun 18, 2010
4
0
Prague
It just loops for me waiting for device .. OK.......

<<<<<UPDATE >>>>

Rebooting the phone and then trying again worked. Ti backup installed all my apps restored :) :) :) Hurraaaa

I am off to bed now .... Thanks much CLShortFuse and all the other devs :) Great Job !!
 
Last edited:

3dawg

Senior Member
Oct 22, 2010
799
187
Ok i just spammed it and tried it like 15 times and turned usb debugging on and off over and over and it suddenly worked.
 
Status
Not open for further replies.