[X82X&X910][TREBLE] LineageOS 18.1 (Android 11) for LeEco Le Max 2

jean_htc

Member
Apr 8, 2009
27
1
23
Hello,

I can't use TWRP with this rom, at each reboot it replace TWRP with LineageOS recovery.

Do you recommand to use the new version twrp-3.5.0_9-0-x2 ?
 

kayyappan

Senior Member
Mar 10, 2011
542
133
63
Heyyo @kayyappan , thanks man! Yeah it was pretty fast to bring up since we are a legacy device meow, so unfortunately we can't upgrade blobs and conform to Android 11... The only real negative to that with LineageOS is Wifi Display might have to be dropped for us if we can't find new blobs that aren't from CAF leaked bsp (since we don't have a public release license for Board Support Package like a stock ROM does) so hopefully a compatible device comes along that we can Kang blobs from for WFD on their stock ROM....

Also bro, unfortunately I can't see your attached logcat. Can you please PM it to me?
Hi, thank you. Did not visit XDA again for a long time. With broken screen I could not really check a lot of things. I did receive an LCD assembly which is different from the original and it does not work on my device. Goes on and off including backclight on any ROM - stock or otherwise. On your TWRP backlight is on but nothing on display. Wonder whether it is due to light sensor. But this on/off thing I have faced on some GSI from phhusson list long time back.
Sorry I forgot to add logcat - but it is too late now as I follow x2 dev channel on TG and read that except WiFi Dsiplay others work OK.
 

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@kayyappan oh no! Broken screen? Oof... sorry to hear about that bro. :(

The light sensor isn't factored in with TWRP as automatic brightness isn't set up in TWRP, so the display not lighting is likely the display itself is defective or maybe just the cable needs to be reseated?

Also, x2 is on the official LOS 18.1 initial devices roster! w00t! So hopefully seriously these days off I can sit down and seriously focus on replacing parts as I'm very comfortable with the future of LOS for x2. ;)
 

kayyappan

Senior Member
Mar 10, 2011
542
133
63
.....
The light sensor isn't factored in with TWRP as automatic brightness isn't set up in TWRP,.....

Also, x2 is on the official LOS 18.1 initial devices roster! w00t!
Thank you for the info on TWRP. Now I wonder if it's the lcd or motherboard.

Nice to know LOS 18.1 for X2 is moving up the ladder. Hope to be back with fully working unit soon...
 
  • Like
Reactions: ThE_MarD

arh91

Senior Member
Nov 29, 2016
86
55
18
Hello, i found a bug in LOS 18

After change the CPU frequency (with SmartPack-Kernel Manager) the new minimum CPU freq is always 1036 MHz and can't change it.

Restart, uninstall smartpack, using other kernel manager don't help...

I had to format; now with LOS 17 + Kernel Adiutor is fine.

Smartphone is X820.
 

arh91

Senior Member
Nov 29, 2016
86
55
18
Heyyo @arh91 , do you have that same behavior even without any mods?
I disable (rename) the thermal-engine.conf in vendor (for measure GIPS with the CPU Throttling Test app), maybe that create the bug.

Installation full clean
("Format Data", System, Vendor, ART/Dalvik, Cache, Data, Internal...).

Installed (With official TWRP 3.5)
- Firmware 466D
- Lineage 18
- Flame GApps basic
- Magisk 21
 

origin_de

Senior Member
Feb 29, 2012
86
50
38
Out of Rosenheim
@ThE_MarD: Heyo, hope you're doing well!
I installed your lineage-18.1-20210109-UNOFFICIAL-x2-recovery.img (fastboot), then sideloaded
lineage-18.1-20210109-UNOFFICIAL-x2.zip and FlameGApps-11.0-basic-arm64-20210201.zip.
During the sideload process of FlameGApps when Preparing Installer it seems not to recognize the Android-, SDK- and ARCH version. It then says "wrong android version detected" and stops installation. I also tryed
FlameGApps-11.0-basic-arm64-20210110-BETA.zip (close to your release date) but same thing. Any idea what I'm doing wrong here?
 

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
Heyyo @origin_de ! MindTheGapps is meow the recommended GApps for LineageOS 18.1 so give that a go

Also, a new test build is going up! As always, test builds are linked in the first post and I'm uploading meow so it'll be done within 30 minutes. lineage-18.1-20210212-UNOFFICIAL-x2 contains some perf fixes, another softAP (WiFi Hotspot) fix that was needed due to the changes in Dynamic WiFi Interfaces. @arh91 you'll want to test perf and cpufreq on this build.

Is there any max_plus/x910 users out there? Does all the audio functions work? Including the HiFi Audio DAC or no?

I know it has a been a bit delayed, but I think this upcoming set of days off I'll seriously rip open my x2 lol, things have been super busy for me between x2, payton, Z01R getting official 17.1 and zippo... so I think I'll have to give up on software a little these upcoming days off and focus on x2's hardware replacements. (y)
 
Last edited:
  • Like
Reactions: sugnuf

origin_de

Senior Member
Feb 29, 2012
86
50
38
Out of Rosenheim
@ThE_MarD: Thanks for your advise. With MindTheGapps install worked like a charm. On the Google side of the house, I was really struggling for almost a day to get Android Auto to work again with my 2019 Skoda Superb. I almost gave up and wanted to go back to 17.1 when I read that lots of OnePlus users have similar problems. Finally I got it to work by setting default USB to Data Transfer within developer settings. Maybe this info helps others.
Currently doing backup. Will test new version very soon, too. Thanks again for all the work you put into the x820!
 
  • Like
Reactions: ThE_MarD

origin_de

Senior Member
Feb 29, 2012
86
50
38
Out of Rosenheim
@@ThE_MarD: I installed lineage-18.1-20210212-UNOFFICIAL-x2. So far everything is fine. WiFi is flawless and reaches maximum throughput with 5-GHz of 90Mbit which compares well with my DSL Bandwidth. It feels a bit more responsive than the previous version but I cannot provide factual numbers. If you want me to run performance tests could you possibly point me to tools whose results you want to see.
 

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@origin_de that's good news that everything is working good including that usb permission to fix Android Auto (y)

As for perf? It is mainly testing if CPU goes all the way to top clock speeds all the way to lowest ones. You can either do 3D apps or benchmarks. I was just testing with Aida 64 by scrolling fast on the CPU info page which worked good enough, but always good if other x2 users try more extensive testing too
 

origin_de

Senior Member
Feb 29, 2012
86
50
38
Out of Rosenheim
@gorillalaci. I did the same and had no problems with the exception of rooting with Magisk failed. Actually I had to reflash Recovery as I could not boot into again. I couldn't investigate any further, cause accidentally my Power Button broke and I'm waiting for the replacement to arrive. What I observed though, was that installation of Opengapps didn't work. I only was successful with MindTheGapps.
 

origin_de

Senior Member
Feb 29, 2012
86
50
38
Out of Rosenheim
After replacing my Power Button I checked on the failed rooting. I only did a re-install of Magisk, which this time worked seamless.
Continue using the x820 as my daily driver. Have not found any shortcomings so far. Guess it's ready for release.
 
  • Like
Reactions: ThE_MarD