XDA DevDB FAQ / Feedback / Bug Reports

pix106

Senior Member
Oct 16, 2010
1,086
562
143
Thanks... Sad it still isn't solved after years.
In the past using an older XDA theme gave access to it, but updating variables didn't worked, only deleting and adding it new as a workaround.
for *years* ?
I could upload files to my devdb projects in august, and only tried 1-2 months ago, when TWRP 3.3.0 source was released
I was always surprised the upload component is a flash (?!?) component, but there must be a reason to install this proprietary lib only to upload files.
 

Android-Andi

Recognized Contributor
Mar 3, 2013
10,846
29,210
0
andi34.github.io
for *years* ?
I could upload files to my devdb projects in august, and only tried 1-2 months ago, when TWRP 3.3.0 source was released
I was always surprised the upload component is a flash (?!?) component, but there must be a reason to install this proprietary lib only to upload files.
Forget what I said, thought you've quoted my post.
 

pix106

Senior Member
Oct 16, 2010
1,086
562
143
I seem to be unable to upload files in my DevDB project here: https://forum.xda-developers.com/re...er-development/shinsoo-kernel-nougat-t3846456.

Every time I click the 'Add a file' button a window pops up that says 'Incorrect or missing project information'
i have had the same issue for weeks, it's still there.
For example in this thread : https://forum.xda-developers.com/devdb/project/?id=15969#downloads
The problem is still there, files sections of DevDB projects can't be updated for months.
Is "someone able to fix it" aware of this and reading this thread ?
Thanks
 

woodman

Senior Moderator / RC-RT & Moderator Committees
Staff member
Jul 21, 2012
12,549
23,397
263
40
France
The problem is still there, files sections of DevDB projects can't be updated for months.
Is "someone able to fix it" aware of this and reading this thread ?
Thanks
Yes we are reading this thread. I have contacted the server admin about this. I will let you know if I get an answer.
 

woodman

Senior Moderator / RC-RT & Moderator Committees
Staff member
Jul 21, 2012
12,549
23,397
263
40
France
The problem is still there, files sections of DevDB projects can't be updated for months.
Is "someone able to fix it" aware of this and reading this thread ?
Thanks
So I got an answer from the server admin, he said his plan is to rewrite a new uploading system because the current one for devdb is really old and his preference is to avoid a temporary fix. No ETA.

Yes we are reading this thread. I have contacted the server admin about this. I will let you know if I get an answer.
 

Lennoard

Recognized Developer
May 5, 2015
582
714
0
22
Teresina
hebfoptimizer.androidvip.com.br
I cannot create a new DevDb. When I click save or apply, the page just loads forever. Eventually ends with HTTP status 500 error. I've read before that the project is actually created but it redirects you nowhere so I stopped trying. When I checked though, nothing is there.

Edit: It's there so I'm reporting it as there is one duplicate.
 
Last edited:

Oswald Boelcke

Forum Moderator / Recognized Translator
Staff member
Apr 13, 2016
10,220
14,030
243
64
Preserving Air Supremacy over XDA
en.wikipedia.org
I cannot create a new DevDb. When I click save or apply, the page just loads forever. Eventually ends with HTTP status 500 error. I've read before that the project is actually created but it redirects you nowhere so I stopped trying. When I checked though, nothing is there.
I f you refer to "[APP][4.4+] SysctlGUI - Modify kernel parameters" it has been twice created (one unintentional dupliacte) here and here. And on my first glance, the DevDB threads look good.
 

Lennoard

Recognized Developer
May 5, 2015
582
714
0
22
Teresina
hebfoptimizer.androidvip.com.br
I f you refer to "[APP][4.4+] SysctlGUI - Modify kernel parameters" it has been twice created (one unintentional dupliacte) here and here. And on my first glance, the DevDB threads look good.
Yeah I realized moments later that the project hasn't been created in the original place I intended (Android software hacking I believe). I found them in my XDA profile page and asked a moderator to delete one of them. So at least it got addressed but the unresponsive (says Google Chrome) page is still a thing.
 

Ibuprophen

Senior Member
Sep 4, 2012
9,545
6,491
253
Upstate New York
Yeah I realized moments later that the project hasn't been created.........
Here's a couple of tips regarding (what I do) as a sorta workaround regarding DevDB Threads.

1) Creating a new DevDB Thread: Say that I wasn't to create a new DevDB Thread within the following area of the forum...

https://forum.xda-developers.com/android/apps-games

... I just have 2 browser tabs open to the above area.

I first go through the process of creating the thread using one of the tabs. Then when I submit it, I wait about 5-10 seconds of it loading, I then go to the second tab and refresh that page.

Once that page refreshes, I will see the New DevDB Thread. Once I see It, I just close the first tab and your all set.
2) Editing a DevDB Thread OP: This is the same as above but, I have 2 tabs open with that specific DevDB Thread.

Once I edit the DevDB OP Info on the first tab, I then wait about 5-10 seconds of it loading, and then go to the second tab and refresh that DevDB Thread page.

Once that page refreshes, I will see the Changes made on the DevDB Thread and then I just close the first tab and it's all set.
It seems like allot of work but, it really isn't. Though I'm stating this as someone who is used to doing this process for a while.

Just a personal tip as I experience this on both my PC and Android Browser's as well.

Quick Tip: Be sure that when you create a New DevDB Thread, you pay attention closely at the top portion of that page. It's specific to where the DevDB will be located and may not always reflect where your new thread will be. If not, you should be able to change this manually (before its created).

I hope this was helpful and I had explained this okay via text... :eek:


~~~~~~~~~~~~~~~
Unless asked to do so, PLEASE don't PM me regarding support. Sent using The ClaRetoX Forum App on my Apple Macintosh.
 
Last edited:

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,798
3,928
243
Sydney
  • Like
Reactions: Oswald Boelcke

Oswald Boelcke

Forum Moderator / Recognized Translator
Staff member
Apr 13, 2016
10,220
14,030
243
64
Preserving Air Supremacy over XDA
en.wikipedia.org
Yeah I realized moments later that the project hasn't been created in the original place I intended (Android software hacking I believe). I found them in my XDA profile page and asked a moderator to delete one of them. So at least it got addressed but the unresponsive (says Google Chrome) page is still a thing.
Personally, I won't preclude a "simple" browser issue. I don't have experiences with Chrome as it's by Google that I try to avoid. But pending on my used browsers - for Firefox even pending on the profile I use, I've different and quite often annoying experiences with XDA in general and DevDB is specific. Currently, my best experiences are with Firefox and a specially created profile for XDA; and for privacy reasons I don't do anything else but surfing XDA with this profile.
 
  • Like
Reactions: Ibuprophen

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,798
3,928
243
Sydney
...snip... Currently, my best experiences are with Firefox and a specially created profile for XDA; and for privacy reasons I don't do anything else but surfing XDA with this profile.
My secondary browser of choice is a portable"install" of the TOR browser, which of course is also Firefox based. The other benefit of TOR is that it will also help test region based issues with the net; in addition to the privacy:cool:.
 

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,798
3,928
243
Sydney
There are two threads for "ask anything" / "newbie friendly" It seems that some people may ask a question in one, and it gets missed by others who may be able to help, but are reading/responding in the other. Both are actively used.

[HELP THREAD] Ask ANY Question. Noob Friendly.
https://forum.xda-developers.com/showthread.php?t=2257421

[Ask Any Question][Newbie Friendly]
https://forum.xda-developers.com/showthread.php?t=2259645

All the obvious issues of duplication.
Now that I realise the above duplication, I noticed a duplicate post, also because they used such a large screen shot (a personal hate) that it was hard to miss, but the user has posted his question in both of the above threads. OK, so I'm a squeaky hinge...
https://forum.xda-developers.com/showpost.php?p=80143682&postcount=29467
https://forum.xda-developers.com/showpost.php?p=80143617&postcount=43862

Normally I would report duplicate posts, but in this case I could hardly hold it against them, and I wouldn't know which to report:confused:
 

TheReduxPL

Senior Member
Apr 14, 2012
559
183
0
Wrocław
I noticed that when you change the date format (eg. to European Short) in profile settings, it works in threads and posts, but it doesn't apply changes to the "Most thanked" element on the right side.
This different date format makes it a lot easier for me to read dates, is there a chance to have this fixed? :)
 

Ticklefish

Recognized Themer
Oct 27, 2011
6,741
8,536
263
Hampshire, UK
Hi all - I've got a bug on one of my DevDB threads. I recently uploaded a 32.34MB file to the downloads tab. It's been downloaded 9 times...and now it's showing a 404 error if anybody else tries to download it.
This is actually the 2nd time this has happened. I uploaded the same file yesterday and it hit 15 downloads before the 404 error.

Could somebody look into this please? The file's here: https://forum.xda-developers.com/devdb/project/dl/?id=31832

Thanks!