XDA DevDB FAQ / Feedback / Bug Reports

linuxnubee

Senior Member
Apr 19, 2012
181
40
0
Hi Svetius

Just a quick message to say that the bar at the top of xda forum style 2015 hides the thread location ie

General discussion > About xda-developers.com > XDA DevDB FAQ / Feedback / Bug Reports by svetius

makes it slightly awkward to go back when you have read 30 pages of threads.

I'm using an amazon hd8 ot sure if this is the same for other devices though.

Many thanks

Linuxnubee
 

Ticklefish

Recognized Themer
Oct 27, 2011
6,741
8,536
263
Hampshire, UK
Hi all - I've got a bug on one of my DevDB threads. I recently uploaded a 32.34MB file to the downloads tab. It's been downloaded 9 times...and now it's showing a 404 error if anybody else tries to download it.
This is actually the 2nd time this has happened. I uploaded the same file yesterday and it hit 15 downloads before the 404 error.

Could somebody look into this please? The file's here: https://forum.xda-developers.com/devdb/project/dl/?id=31832

Thanks!
As much as I hate bumping my own posts, I'm still getting this problem. Can anybody help?
 
  • Like
Reactions: woodman

AndDiSa

Senior Member
Dec 2, 2009
3,461
4,520
268
Heidelberg
I have some issues accessing my thread ([TOOLS][ZIPS][SCRIPTS]Android Backup and Restore Tools[Multiple Devices/Platforms]) created yesterday with mobile devices. Using the web interface I can access it, but on the mobile device the logcat says:
Code:
12-09 14:20:08.689  5598  5612 W System  : A resource failed to call close. 
12-09 14:20:36.140  5598  5598 W System.err: retrofit.RetrofitError: 400 Bad Request
12-09 14:20:36.141  5598  5598 W System.err: 	at retrofit.RestAdapter$RestHandler.invokeRequest(Unknown Source:445)
12-09 14:20:36.141  5598  5598 W System.err: 	at retrofit.RestAdapter$RestHandler.access$100(Unknown Source:0)
12-09 14:20:36.141  5598  5598 W System.err: 	at retrofit.RestAdapter$RestHandler$2.obtainResponse(Unknown Source:8)
12-09 14:20:36.141  5598  5598 W System.err: 	at retrofit.CallbackRunnable.run(Unknown Source:0)
12-09 14:20:36.141  5598  5598 W System.err: 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
12-09 14:20:36.141  5598  5598 W System.err: 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
12-09 14:20:36.141  5598  5598 W System.err: 	at retrofit.Platform$Android$2$1.run(Unknown Source:7)
12-09 14:20:36.141  5598  5598 W System.err: 	at java.lang.Thread.run(Thread.java:919)
12-09 14:20:36.143  5598  5598 E Utils   : XDA-ONE	{"error":{"code":400,"message":"Bad Request: Invalid thread id!"}}
I've just tried to clean data, re-install the xda app ... unfortunately without luck :(
Any ideas what might have happended?

A hint beside: I created the thread though a new devdb project entry and it ended up with two threads having the same name ... The second thread is already removed by the moderator, but still I cannot access the remaining one
 
  • Like
Reactions: woodman

woodman

Senior Moderator / RC-RT & Moderator Committees
Staff member
Jul 21, 2012
12,549
23,397
263
40
France
I have some issues accessing my thread ([TOOLS][ZIPS][SCRIPTS]Android Backup and Restore Tools[Multiple Devices/Platforms]) created yesterday with mobile devices. Using the web interface I can access it, but on the mobile device the logcat says:

I've just tried to clean data, re-install the xda app ... unfortunately without luck :(
Any ideas what might have happended?

A hint beside: I created the thread though a new devdb project entry and it ended up with two threads having the same name ... The second thread is already removed by the moderator, but still I cannot access the remaining one
It is now fixed. I had to use a workaround.

Your issue is related to this known bug (still pending): https://github.com/Wood-Man/XDA-Labs-Issues-and-Suggestions/issues/23
 
  • Like
Reactions: AndDiSa

londonadagio

Member
Oct 3, 2019
11
1
3
Welp, I just tried creating my first project and things didn't go smoothly. When I tried creating the project, I got a pretty long loading before receiving a 500 error. And of course, like a dumbass I tried again. Twice. And got 500 error each time.

As it happens the project is created, but it created three separate threads :
https://forum.xda-developers.com/android/apps-games/app-guitar-toolbox-metronome-guitar-t4025487
https://forum.xda-developers.com/android/apps-games/app-guitar-toolbox-metronome-guitar-t4025491
https://forum.xda-developers.com/android/apps-games/app-guitar-toolbox-metronome-guitar-t4025493

Any way I can delete the two extras?

Already addressed
 
Last edited by a moderator:

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,798
3,928
243
Sydney
Project dB update fail

I think this is the correct thread, but its the first post of the year; yeah, sure, the year has just started...

I have a project dB, which i have just updated (ie the OP with a new version). Updating Project dB's has been flakey for a while, but I can work around it by simply re-opening the project in another window, and manually checking it has updated. Normally, I get a page such as this after pressing either of the two save options.
View attachment 4928389
NB: I have tried saving it twice with the second one being a change in formatting to ensure it triggered a save.:p

However, when I look at the OP, it shows it being last updated by some other random user (ie not me), with some way historical date (ie not now)
View attachment 4928391

The project URL is: https://forum.xda-developers.com/android/apps-games/app-temefi-comprehensive-documentation-t3806260
 

sd_shadow

Recognized Contributor
Sep 21, 2011
16,975
7,730
253
South Dakota
goo.gl
I think this is the correct thread, but its the first post of the year; yeah, sure, the year has just started...

I have a project dB, which i have just updated (ie the OP with a new version). Updating Project dB's has been flakey for a while, but I can work around it by simply re-opening the project in another window, and manually checking it has updated. Normally, I get a page such as this after pressing either of the two save options.

NB: I have tried saving it twice with the second one being a change in formatting to ensure it triggered a save.:p

However, when I look at the OP, it shows it being last updated by some other random user (ie not me), with some way historical date (ie not now)


The project URL is: https://forum.xda-developers.com/android/apps-games/app-temefi-comprehensive-documentation-t3806260
He's an Administrator.
https://forum.xda-developers.com/member.php?u=450224
Certainly not random.


Sent from my mata using XDA Labs
 
Last edited:

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,798
3,928
243
Sydney
He's an Administrator.
https://forum.xda-developers.com/member.php?u=450224
Certainly not random.
Are you implying that the update was some mod edit / "adjustment" / correction? if so, I would of expected some kind of notification of the reason for the edit. ie what he felt needed to be "corrected", that I had done wrong / broken some XDA rule.

Also, I have done multiple updates of that devdb since the date shown, and I do not remember it showing that info. ie not me.

---------- Post added at 09:32 ---------- Previous post was at 08:59 ----------

He's an Administrator.
https://forum.xda-developers.com/member.php?u=450224
Certainly not random.
I actually found I could see what changes were made by the edit. And the edit would appear to only be changes I had made when releasing a new version (ie version number, file download location, date etc etc), but is definitely not the last edit. Especially since I have just edited it yesterday.

And, the edit jumps (as well as a few other minor edits such as MD5 and download URL etc etc)
- Current Stable Version: 1.0.36
- Stable Release Date: 2019-03-31

+ Current Stable Version: 1.0.55
+ Stable Release Date: 2019-12-10

And ALL my updates would of been by single increments to the version number, so it does not make any sense that it jumps 19 versions in a single edit:confused: let alone the date jump. and lets not forget, I edited it yesterday (and these changes are visible in the OP) but the last edited still shows the wrong values for date and user.
 

Oswald Boelcke

Forum Moderator / Recognized Translator
Staff member
Apr 13, 2016
10,220
14,030
243
64
Preserving Air Supremacy over XDA
en.wikipedia.org
Are you implying that the update was some mod edit / "adjustment" / correction? if so, I would of expected some kind of notification of the reason for the edit. ie what he felt needed to be "corrected", that I had done wrong / broken some XDA rule.

Also, I have done multiple updates of that devdb since the date shown, and I do not remember it showing that info. ie not me.

---------- Post added at 09:32 ---------- Previous post was at 08:59 ----------

I actually found I could see what changes were made by the edit. And the edit would appear to only be changes I had made when releasing a new version (ie version number, file download location, date etc etc), but is definitely not the last edit. Especially since I have just edited it yesterday.

And, the edit jumps (as well as a few other minor edits such as MD5 and download URL etc etc)
- Current Stable Version: 1.0.36
- Stable Release Date: 2019-03-31

+ Current Stable Version: 1.0.55
+ Stable Release Date: 2019-12-10

And ALL my updates would of been by single increments to the version number, so it does not make any sense that it jumps 19 versions in a single edit:confused: let alone the date jump. and lets not forget, I edited it yesterday (and these changes are visible in the OP) but the last edited still shows the wrong values for date and user.
I'm not familiar with DevDB and it's functionalities. Maybe @bitpushr @malybru or @MikeChannon have an explanation?
 

MikeChannon

Forum Admin
Staff member
Jun 7, 1972
15,096
12,679
0
Are you implying that the update was some mod edit / "adjustment" / correction? if so, I would of expected some kind of notification of the reason for the edit. ie what he felt needed to be "corrected", that I had done wrong / broken some XDA rule.

Also, I have done multiple updates of that devdb since the date shown, and I do not remember it showing that info. ie not me.

---------- Post added at 09:32 ---------- Previous post was at 08:59 ----------

I actually found I could see what changes were made by the edit. And the edit would appear to only be changes I had made when releasing a new version (ie version number, file download location, date etc etc), but is definitely not the last edit. Especially since I have just edited it yesterday.

And, the edit jumps (as well as a few other minor edits such as MD5 and download URL etc etc)
- Current Stable Version: 1.0.36
- Stable Release Date: 2019-03-31

+ Current Stable Version: 1.0.55
+ Stable Release Date: 2019-12-10

And ALL my updates would of been by single increments to the version number, so it does not make any sense that it jumps 19 versions in a single edit:confused: let alone the date jump. and lets not forget, I edited it yesterday (and these changes are visible in the OP) but the last edited still shows the wrong values for date and user.
I'm not familiar with DevDB and it's functionalities. Maybe @bitpushr @malybru or @MikeChannon have an explanation?
Well I'm an Admin but not expert on DevdB functionality either. DevdB is not as updated as it might be and is and is more in bitpushr's domain than mine. He's our chief systems person.
When bitpushr changes something he normally doesn't do so in order to act as a Moderator but more usually to correct some systems issue or something not showing correctly. Other times he's maybe just testing something, perhaps following a user saying something in the post/thread isn't working correctly.

Mike
 

Oswald Boelcke

Forum Moderator / Recognized Translator
Staff member
Apr 13, 2016
10,220
14,030
243
64
Preserving Air Supremacy over XDA
en.wikipedia.org
Hi all!
Please, help.
I cann't upload logo to my project - https://forum.xda-developers.com/devdb/project/dl/?id=38527
I get an error every time after selecting and adding my logo: HTTP ERROR 500
Hello, and good morning. If you provide me with your logo (or probably better a link to it; also fine via PM) and let me know where to place it in your project I give it a try. Afterwards we could go into some trouble shooting unless our admins @MikeChannon @the_scotsman already know the problem.
Regards
Oswald Boelcke
 
  • Like
Reactions: sd_shadow

MikeChannon

Forum Admin
Staff member
Jun 7, 1972
15,096
12,679
0
Hi all!
Please, help.
I cann't upload logo to my project - https://forum.xda-developers.com/devdb/project/dl/?id=38527
I get an error every time after selecting and adding my logo: HTTP ERROR 500
Hello, and good morning. If you provide me with your logo (or probably better a link to it; also fine via PM) and let me know where to place it in your project I give it a try. Afterwards we could go into some trouble shooting unless our admins @MikeChannon @the_scotsman already know the problem.
Regards
Oswald Boelcke
Is it definitely not working? Quite often the system returns a 500 error but has actually completed the task if you refresh the page.

Mike
 
  • Like
Reactions: Oswald Boelcke
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone