XenForo 2.2 Upgrade! Post Bugs, Issues and Comments Here

Search This thread

tiho5

Senior Member
  • Jun 21, 2010
    2,524
    950
    Bulgaria
    Thanks for working on the site.

    @osm0sis could you please add to the list email notification when quoted, mentioned or PMed.

    Say I want someone's help for a very old topic but he's not visiting XDA at all nowadays. I could mention him and he'll get an email. Communication is established and a topic is continued. Isn't that what XDA is all about?

    Also can we get rid of the banner on the top (see attachment). This is Chrome on Android in mobile view.
    It uses real estate. Or if it at least could disappear when one scrolls down the page and reappear when scrolling the opposite direction.
     

    Attachments

    • Screenshot_20210313-133456_Chrome.jpg
      Screenshot_20210313-133456_Chrome.jpg
      461 KB · Views: 12
    • Like
    Reactions: Timmmmaaahh!

    Timmmmaaahh!

    Forum Moderator
    Staff member
  • Sep 11, 2012
    4,457
    8,399
    Bruges
    the XDA app should have 4.5 stars not 1.9 I do not agree with the negative reviews
    Well it is just a web wrapper, notifications don't bring you to the actual topic, navigating is pretty clumsy... so I see where people are coming from. I think it's a handy tool to read some things on the go (even interact a bit) but it doesn't get anywhere near the desktop experience.
     

    Bill720

    Senior Member
    Mar 13, 2013
    699
    135
    AT&T HTC One
    Moto X Pure
    I've been seeing errors when trying to submit thread replies. They still end up posting successfully, but aren't visible until after performing a refresh of the page.

    Update: This one posted fine, so maybe it was just a fluke from yesterday.
     

    It_ler

    Recognized Contributor
  • Aug 23, 2011
    12,377
    17,020
    Samsung Galaxy S8
    Samsung Galaxy S10
    Whatever happened to the "Community App Dark" theme on PC browsers? I can't select it any more in the Style Chooser box and now I can't hide the right column any more.

    Please bring it back, that column wastes soooooo much space :cry:
    Should still be there ... At least via "Your account".
     

    Attachments

    • Screenshot_20210313-203843_Samsung Internet.jpg
      Screenshot_20210313-203843_Samsung Internet.jpg
      243 KB · Views: 14
    • Screenshot_20210313-203940_Samsung Internet.jpg
      Screenshot_20210313-203940_Samsung Internet.jpg
      302.9 KB · Views: 14

    b1283822

    Member
    Feb 8, 2017
    26
    8
    It seems like after the upgrade, it reset my Google OAuth association. When I attempt to use Google account to login as before, it shows an error.
    This account's email is already associated with another member. Please log into that account to associate this account.
    Since I have never set my password and always log in through Google, I had to reset my password to log in using password. Then I associate Google account in settings. After that, OAuth to work as before.
     
    • Like
    Reactions: J.Michael

    Patrick Morgan

    Senior Member
    Mar 20, 2008
    549
    450
    Montreal QC
    Eh.

    can't log into the forums on Edge browser ? ? ? ?

    I get this error.

    _________________


    Error 1010​

    Ray ID: 62fa7cb30c80f0c9 • 2021-03-14 03:41:34 UTC

    Access denied​

    What happened?​

    The owner of this website (forum.xda-developers.com) has banned your access based on your browser's signature (62fa7cb30c80f0c9-ua98).

    __________________
     
    • Like
    Reactions: J.Michael

    DADi590

    Senior Member
    Jan 4, 2017
    53
    9
    Well, as an example of a possible bug, I don't receive any emails about the 2 Factor Authentication. Waited already 5 minutes and also tried to send again, but nothing shows up. Is that a bug? If it is, can you please fix it? Thanks!

    EDIT: not sure this is helpful in this case, but goes anyway. Computer; Microsoft Edge; Windows 10.

    UPDATE: The 2 codes came 2:30 hours later and say they're valid for 15 minutes lol XD. And now tried again and the code came instantly. Working fine now! 2FA enabled!
     
    Last edited:
    • Like
    Reactions: sd_shadow

    tiho5

    Senior Member
  • Jun 21, 2010
    2,524
    950
    Bulgaria
    In the s21 forum marking read will mark read the entire forum, not just the category you've chosen to filter. This is not an intuitive or convenient solution. If it could be changed to mark read only the filtered category, it would make much more sense and be a sweet upgrade.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 7
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge.
      "osm0sis": Maybe this issue with displaying achievements in posts should be added to the bug list.
      It is the same for me and many user ATM. Still work in progress. So please be patient.

      "osm0sis": Maybe this issue with displaying achievements in posts should be added to the bug list.
      Yes, we should have a dedicated list or forum for achievement system bugs and feature requests (e.g. like for the new xda app)!
      I hope that it will be created as soon as the xenforo admins and devs are "finished" with this work in progress.

      Yes, obviously. I've played with any combination of ticking and unticking to no avail. I forgot to say that explicitly.
      I also tried nearly everything, but does not work for me either. Was just a kind of "worth a try" (as @the_scotsman tried to explain already in his post above).
      In the past, some strange actions in special sequence could solve a few issues. Just to name one: "Achievement Hunter" blocking some users (like me) from using different features (posting, searching, giving and receiving reactions, etc.) of the xda forum!

      ... Posts #3,201 and #3,202 exactly mirror my issue. Just because you have the 5 Year badge showing up doesn't mean the rest of us can.
      Yes, some users can select/show thosse achievements, and others not. I assume that this "weird" behavior is the cause that those issues could not be solved yet.

      My summary:
      Achievement system is still work in progress and a kind of "Beta" version.
      As I think that is might have a positive effect on many user's activity in xda forums, it is worth to be fixed. But we have to wait for it to be done.
      4
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge. @osm0sis Maybe this issue with displaying achievements in posts should be added to the bug list.
      I assume you selected the 5 year one in options? Maybe try unticking all of them, then go back and choose the 5 year one?
      3
      Absolutely not. Posts #3,201 and #3,202 exactly mirror my issue. Just because you have the 5 Year badge showing up doesn't mean the rest of us can.
      I wasn't saying that, I was just suggesting/asking things, given your post had little info...no need to be like that.
      2
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge. @osm0sis Maybe this issue with displaying achievements in posts should be added to the bug list.
      It's known they are not working
      Achievements aren't quite ready yet. Right now it's retroactively calculating XP by going through tens of millions of posts. -svetius
      and we would need a whole new list for all the Achievement bugs.
      2
      It's known they are not working

      and we would need a whole new list for all the Achievement bugs.
      I think that's more about when they appear in your list of selectable ones?
    • 57
      On 3/11/2021 at around 10am New York time, XDA will be upgrading our forum software to XenForo 2.2 which brings a bunch of new improvements, like a new thread preview tool, a Device Inventory tool to show off which phones you use, a most-thanked widget in every thread to easily spot the most important posts, plus a host of other new feature you can read about here. Not every feature of 2.2 will be available/active on XDA from day one, but we'll roll more things out soon as we settle in. :cool:

      Please use this thread to post about bugs, issues, or overall comments. If reporting a bug or issue, be sure to tell us about your configuration (device, browser, OS) and the steps to reproduce the issue. Screenshots help!

      In addition, later today we'll be updating the XDA app to work with 2.2. :cowboy:
      26
      Known Bugs/Regressions:
      1. Advanced forum user max title length is too short, truncating them (e.g. "Senior Recognized Developer / Recognized Contribut").
      2. Long forum names are truncated (e.g. "Android Software and Hacking General [Developers O").
      3. Thanks/Likes counts are reduced for most users, sometimes dramatically, seemingly from Aug 29 - Dec 2; possibly related to posts reverting to older versions.
      4. Various old forum emojis aren't mapped to new unicode ones, and ones in old posts that do exist (e.g. :cowboy:) don't display.
      5. Broken redirects from old links for many threads/posts.
      6. Disabling Alert in Preferences forces Mobile App Push enabled, one should be able to disable both.
      7. "Unfurl"ed URL links to posts sometimes show a preview of the OP instead of the correct post (e.g. [URL unfurl="true"]https://forum.xda-developers.com/t/welcome-to-xda-2021.4197018/post-84073623[/URL]
        ==
        )
      8. Colored/underlined user names to denote advanced forum users (e.g. Moderators/Admins and Recognized Contributors/Themers/Developers).
      9. Posts containing only quotes and no new text should be disallowed again.
      10. Ability to subscribe to an entire forum is missing for some forums.
      11. XDA Wiki pages are missing.
      12. [SIGPIC][/SIGPIC] functionality is broken and pics lost.
      13. Shell scripts are detected and rejected as attachments, even if renamed as .txt files.
      14. Search "this category" option never shows any results when used.
      15. Recognized Developers can't moderate their own threads anymore.
      16. Missing/broken legacy devices in Device Inventory (e.g. Galaxy Nexus is listed when you search but fails when you attempt to add it).
      17. Missing setting to receive emails for mentions and/or quotes.
      18. Reaction Score doesn't match between profile and "All" under Reactions Received.
      19. DevDB secondary thread contributors have completely lost access to updating these threads.

      See previous lists in the "Welcome To XDA 2021!" thread for items resolved up-to-and-including the XenForo 2.2 upgrade: https://forum.xda-developers.com/t/welcome-to-xda-2021.4197018
      21

      New XDA App Bugs and Requests



      New: How to Use New Questions and Answers Threads - (16 March 2021)
      Upvote or downvote replies, making the best answers listed at the top of the replies​

      Xenforo 2.2 New Features




      Device Inventory https://forum.xda-developers.com/account/xda-devices
      Screenshot 2021-03-11 115006.png



      Can't wait!
      12
      @svetius @bitpushr @MikeChannon @the_scotsman @Audentio

      Can you please add .tar.gz, .tgz, .tar.xz, .txz, etc. to the accepted attachment extension list? I'm trying to upload AIK-Linux v3.8 here and this is a bit of an annoying last minute snag. :p

      Please also look into allowing uploading simple shell scripts again. These used to be allowed at least when renamed to .sh.txt but currently they still get detected and blocked.

      This is a developers and power users forum, you would think these things would already be allowed! :)
      (y)I have added those extenstions.

      Mike
      12
      @svetius @bitpushr @MikeChannon @the_scotsman @Audentio

      Can you please add .tar.gz, .tgz, .tar.xz, .txz, etc. to the accepted attachment extension list? I'm trying to upload AIK-Linux v3.8 here and this is a bit of an annoying last minute snag. :p

      Please also look into allowing uploading simple shell scripts again. These used to be allowed at least when renamed to .sh.txt but currently they still get detected and blocked.

      This is a developers and power users forum, you would think these things would already be allowed! :)
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone