XenForo 2.2 Upgrade! Post Bugs, Issues and Comments Here

Search This thread

Timmmmaaahh!

Forum Moderator
Staff member
  • Sep 11, 2012
    4,461
    8,420
    Bruges
    Someone tell me how to edit BB code of existing post.
    Thanks
    You mean this?
    1615982182640.png
     

    osm0sis

    Senior Recognized Developer / Recognized Contribut
  • Mar 14, 2012
    14,583
    32,833
    Halifax
    GT-i9250
    Nexus 7 (2013)
    Tonnes missing or broken, e.g. Galaxy Nexus is listed when you search but fails when you attempt to add it.

    Hopefully someone can clean up the Nexus line to make them more uniform while they're at it; currently it's like "Samsung Galaxy Nexus", "Google Nexus 5", "LG Nexus 5X" and "Nexus 7 (2013)".. either should all say Google or none of them should. Ideally they'd all have Google Nexus in the names then have the manufacturer as "Samsung" or "LG" or "Asus" etc. 🧐

    Also OnePlus 5's manufacturer is listed as "Essential" 😅

    I mean, sure, but now with the benefit of hindsight I would think you'd want something uniform, especially where with the new Device Inventory you've got a separate "Manufacturer" line which would cover the Nexus' multiple OEMs beside Google. 🤷‍♂️
    Figured out part of the missing device issue with the Device Inventory. If you go to the forum for the device you want and add it from there it'll add something, it just probably isn't the same name you were looking for.

    E.g. Samsung Galaxy Nexus is searchable in the list but errors when added, but going to the Galaxy Nexus forum itself and adding from there adds instead "GT-i9250" with "Manufacturer: Unspecified".

    Not sure if this is a by-product of the forum flattening, or just multiple names over the years, but shouldn't be hard to fix by renaming whatever's wrong to reconnect them.

    @svetius @bitpushr
     
    Last edited:
    Why are not old-style links acceptable?
    For an example: https://forum.xda-developers.com/xposed/list-xposed-modules-android-pie-ed-t3892768
    It would be simple redirected
    from
    (https://forum.xda-developers.com)/xposed/(list-xposed-modules-android-pie-ed)-t(3892768)
    to
    https://forum.xda-developers.com/t/list-xposed-modules-android-pie-ed.3892768/
    That's certainly not good, and I hope it gets fixed soon. However, there's a little work around that might be useful in times where the XDA search is still broken.
    The important thing is the number at the end of the URL that hasn't changed during the transition to XenForo.
    This means if you have a link link the one you provided above as an example but which leads you only to the overarching forum just try this:
    https://forum.xda-developers.com/t/3892768
    It works i.e. behind the .com a /t/ and then simply the number.

    Bildschirmfoto vom 2021-03-22 11-48-55.png

    Bildschirmfoto vom 2021-03-22 11-50-28.png

    Bildschirmfoto vom 2021-03-22 11-50-52.png
     
    Last edited:

    VD171

    Senior Member
    Jun 21, 2012
    1,310
    1
    322
    127.0.0.1
    LG K10
    Samsung Galaxy J7
    That's certainly not good, and I hope it gets fixed soon. However, there's a little work around that might be useful in times where the XDA search is still broken.
    The important thing is the number at the end of the URL that hasn't changed during the transition to XenForo.
    This means if you have a link link the one you provided above as an example but which leads you only to the overarching forum just try this:
    https://forum.xda-developers.com/t/3892768
    It works i.e. behind the .com a /t/ and then simply the number.View attachment 5256861View attachment 5256859View attachment 5256857
    I know and I understand.
    I just suggested that due to compatibility.
    That's really easy using rewriterule.
    Thank you very much
     

    the_scotsman

    Assistant Forum Admin
    Staff member
  • Jan 30, 2006
    31,199
    24,907
    NSW, Australia
    Samsung Galaxy Note 20 Ultra
    So, now the alerts stay there for longer and there will be people who like it, BUT I DON'T. I will not say what I think of it, because I don't want get banned for cursing ...
    If there would be - at least - an option to delete the individual alerts, but no - I have to let the system handle it in the way somebody thinks it should be - if I like it or not ...
    This isn't our choice, it's a limitation of the Xenforo forum platform. They cannot be deleted, either individually or together. You can only mark them as read.

    Read alerts will clear after 4 days from your alerts page, and after 7 days in the alerts popup.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 7
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge.
      "osm0sis": Maybe this issue with displaying achievements in posts should be added to the bug list.
      It is the same for me and many user ATM. Still work in progress. So please be patient.

      "osm0sis": Maybe this issue with displaying achievements in posts should be added to the bug list.
      Yes, we should have a dedicated list or forum for achievement system bugs and feature requests (e.g. like for the new xda app)!
      I hope that it will be created as soon as the xenforo admins and devs are "finished" with this work in progress.

      Yes, obviously. I've played with any combination of ticking and unticking to no avail. I forgot to say that explicitly.
      I also tried nearly everything, but does not work for me either. Was just a kind of "worth a try" (as @the_scotsman tried to explain already in his post above).
      In the past, some strange actions in special sequence could solve a few issues. Just to name one: "Achievement Hunter" blocking some users (like me) from using different features (posting, searching, giving and receiving reactions, etc.) of the xda forum!

      ... Posts #3,201 and #3,202 exactly mirror my issue. Just because you have the 5 Year badge showing up doesn't mean the rest of us can.
      Yes, some users can select/show thosse achievements, and others not. I assume that this "weird" behavior is the cause that those issues could not be solved yet.

      My summary:
      Achievement system is still work in progress and a kind of "Beta" version.
      As I think that is might have a positive effect on many user's activity in xda forums, it is worth to be fixed. But we have to wait for it to be done.
      4
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge. @osm0sis Maybe this issue with displaying achievements in posts should be added to the bug list.
      I assume you selected the 5 year one in options? Maybe try unticking all of them, then go back and choose the 5 year one?
      3
      Absolutely not. Posts #3,201 and #3,202 exactly mirror my issue. Just because you have the 5 Year badge showing up doesn't mean the rest of us can.
      I wasn't saying that, I was just suggesting/asking things, given your post had little info...no need to be like that.
      2
      For me, my 1 Year Member achievement shows up, but my 2, 3, 4, and 5 Year Member ones do not. This has been a consistent issue for me for at least a month. In the meantime, I see other members (even throughout this thread) proudly displaying their 5 Year Member achievement badge. @osm0sis Maybe this issue with displaying achievements in posts should be added to the bug list.
      It's known they are not working
      Achievements aren't quite ready yet. Right now it's retroactively calculating XP by going through tens of millions of posts. -svetius
      and we would need a whole new list for all the Achievement bugs.
      2
      It's known they are not working

      and we would need a whole new list for all the Achievement bugs.
      I think that's more about when they appear in your list of selectable ones?
    • 57
      On 3/11/2021 at around 10am New York time, XDA will be upgrading our forum software to XenForo 2.2 which brings a bunch of new improvements, like a new thread preview tool, a Device Inventory tool to show off which phones you use, a most-thanked widget in every thread to easily spot the most important posts, plus a host of other new feature you can read about here. Not every feature of 2.2 will be available/active on XDA from day one, but we'll roll more things out soon as we settle in. :cool:

      Please use this thread to post about bugs, issues, or overall comments. If reporting a bug or issue, be sure to tell us about your configuration (device, browser, OS) and the steps to reproduce the issue. Screenshots help!

      In addition, later today we'll be updating the XDA app to work with 2.2. :cowboy:
      26
      Known Bugs/Regressions:
      1. Advanced forum user max title length is too short, truncating them (e.g. "Senior Recognized Developer / Recognized Contribut").
      2. Long forum names are truncated (e.g. "Android Software and Hacking General [Developers O").
      3. Thanks/Likes counts are reduced for most users, sometimes dramatically, seemingly from Aug 29 - Dec 2; possibly related to posts reverting to older versions.
      4. Various old forum emojis aren't mapped to new unicode ones, and ones in old posts that do exist (e.g. :cowboy:) don't display.
      5. Broken redirects from old links for many threads/posts.
      6. Disabling Alert in Preferences forces Mobile App Push enabled, one should be able to disable both.
      7. "Unfurl"ed URL links to posts sometimes show a preview of the OP instead of the correct post (e.g. [URL unfurl="true"]https://forum.xda-developers.com/t/welcome-to-xda-2021.4197018/post-84073623[/URL]
        ==
        )
      8. Colored/underlined user names to denote advanced forum users (e.g. Moderators/Admins and Recognized Contributors/Themers/Developers).
      9. Posts containing only quotes and no new text should be disallowed again.
      10. Ability to subscribe to an entire forum is missing for some forums.
      11. XDA Wiki pages are missing.
      12. [SIGPIC][/SIGPIC] functionality is broken and pics lost.
      13. Shell scripts are detected and rejected as attachments, even if renamed as .txt files.
      14. Search "this category" option never shows any results when used.
      15. Recognized Developers can't moderate their own threads anymore.
      16. Missing/broken legacy devices in Device Inventory (e.g. Galaxy Nexus is listed when you search but fails when you attempt to add it).
      17. Missing setting to receive emails for mentions and/or quotes.
      18. Reaction Score doesn't match between profile and "All" under Reactions Received.
      19. DevDB secondary thread contributors have completely lost access to updating these threads.

      See previous lists in the "Welcome To XDA 2021!" thread for items resolved up-to-and-including the XenForo 2.2 upgrade: https://forum.xda-developers.com/t/welcome-to-xda-2021.4197018
      21

      New XDA App Bugs and Requests



      New: How to Use New Questions and Answers Threads - (16 March 2021)
      Upvote or downvote replies, making the best answers listed at the top of the replies​

      Xenforo 2.2 New Features




      Device Inventory https://forum.xda-developers.com/account/xda-devices
      Screenshot 2021-03-11 115006.png



      Can't wait!
      12
      @svetius @bitpushr @MikeChannon @the_scotsman @Audentio

      Can you please add .tar.gz, .tgz, .tar.xz, .txz, etc. to the accepted attachment extension list? I'm trying to upload AIK-Linux v3.8 here and this is a bit of an annoying last minute snag. :p

      Please also look into allowing uploading simple shell scripts again. These used to be allowed at least when renamed to .sh.txt but currently they still get detected and blocked.

      This is a developers and power users forum, you would think these things would already be allowed! :)
      (y)I have added those extenstions.

      Mike
      12
      @svetius @bitpushr @MikeChannon @the_scotsman @Audentio

      Can you please add .tar.gz, .tgz, .tar.xz, .txz, etc. to the accepted attachment extension list? I'm trying to upload AIK-Linux v3.8 here and this is a bit of an annoying last minute snag. :p

      Please also look into allowing uploading simple shell scripts again. These used to be allowed at least when renamed to .sh.txt but currently they still get detected and blocked.

      This is a developers and power users forum, you would think these things would already be allowed! :)
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone