XIAOMI Redmi Note 5 Pro [whyred] global fastboot ROMs bug

Search This thread

dualkeyboard

Member
Feb 24, 2016
13
2
just to make sure no one getting the trouble i had. if you bought Xiaomi devices (not sure its the devices after Redmi 4a or every devices with miui 9.5) with the bootloader already unlocked by the seller or the distributor, make sure youre registering or linked your account to the device. because when whenever youre trying to install global fastboot ROMs with the lock option selected, the device will stuck at recovery with red notification at the bottom saying "the MIUI version cant be installed on this device". the thing is after youre installing fastboot ROMs and locking bootloader of your device, you cant install global fastboot ROMs no more and left with chinese fastboot ROMs or using TWRP. since youre locking your bootloader and if your mi account is not bound to your device, you cant unlock bootloader with the official unlocking tool (it will spit out error "current account is not bound to this device") and yes youre stuck with chinese fastboot rom. you can still bind your account after youre installing the chinese fastboot ROM and unlock your bootloader, but you still cant flash the global fastboot ROMs.

so heres my story for everyone who is experiencing the same issue

i bought my whyred with the bootloader unlocked from the seller/distributor (its a normal thing here, maybe) and i have no issue what so ever in first month i bought it. im changing ROMs with every custom ROMs i found until im bored and decided to installed global fastboot ROM then locking my bootloader. so im stuck on recovery with red notification at the bottom saying "the MIUI version cant be installed on this device" after i flashed my whyred with global fastboot ROM. i thought i was installed the wrong miui ROM, but no. since i locked my bootloader and i havent bind my mi account to the device yet i cannot install custom recovery and installed fastboot ROM no more. so i left with EDL mode then. i tried to enter EDL Mode with button combinations (since miui 9.5 this was disabled, cmiiw), deep flash cable (not working anymore), adb (well i flashed device and stuck, so i cant do adb), fastboot (nope, its locked) and i left with test point methode and this is the only working methode for you with the same situation.

so i flashed ten or so global fastboot ROMs i can find from different sources just in case i have a bad day. but nope, none was working. so i flashed chinese ROM and worked, i immediately tried to unlocked my bootloader but i now faced with 240 wating time. well i guest im stuck with chinese ROM for the next 10 days. the XDA and MIUI forum said that you should be able to flash global ROMs (not sure if this includes fastboot ROMs) again after unlocking your bootloader.
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone