• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Xolo Q700 - Issues and Solutions

Search This thread

ravisghosh

Senior Member
Jul 14, 2011
89
16
Hi folks,

Xolo Q700 seems to be an amazing machine. In this thread, I'm trying to put across some of the problems I faced and solutions I found. Probably, this can be useful to some of us as well.

ISSUE #1 - GPS DOES NOT WORK

PROBLEM: Xolo Q700 would not use GPS Satellite to find location, only use mobile towers to triangulate.

TESTING THE PROBLEM: Install GPS Test app from Google Play, turn on GPS, and hold the phone under open sky for couple minutes.

TEST RESULT: GPS Test shows some satellite "in view" but none "in use".

SOLUTION:
Go to Settings>Location Access, and then turn on the following:
Access to my location - Check (turn on)
GPS Satellites - On
Wi-Fi & mobile network location - Check (turn on)

Tap on GPS Satellites and enable the following:
GPS EPO assistance - Check (turn on)
A-GPS - Check (turn on)

Tap on GPS EPO assistance and enable the following:
Auto Download - Check (turn on)

TESTING THE SOLUTION:
1. Install GPS Test app from Google Play, turn on GPS, and hold the phone under open sky for couple minutes.
RESULT: GPS Test shows some satellite "in view" as well as "in use".

2. Open maps and browse so that it caches some maps files. Now, put phone in Airplane mode and reboot. Start maps again and see if it shows the right location.
RESULT: Location is pointed without sim connection. So, phone can be used as a GPS device as well without sim.

ISSUE #1 - LOW AUDIO

PROBLEM: Volume for ring, call, and speakers is quite low and often not audible in noisy places.

SOLUTION:
1. Enter Engineering Mode - Dial *#*#3646633#*#*
2. Go to Hardware Testing>Audio>Normal Mode.
3. Select "Sph" in type.
4. Select "level 6" in Level.
5. Enter 160 in value.
6. Press Set.
7. Restart the phone.

If you want to increase your volume in all level then choose "level 0" in level and enter 160 in value.

Some more tricks are given in the following link for zopo phones but would work for Q700 - http://www.zopomobileshop.com/zopo-...le-phone-mic-loudspeaker-and-ringtone-volume/

I am not sure whether this actually works as I cannot find any perceptible change in volume. Is others can try and give some opinion and settings that work, it would be helpful.
 

unvishu

New member
Apr 5, 2011
1
0
XOLO Q700 - Network keeps dropping

Hi

I have been facing one irritating problem (on this otherwise wonderful phone) - the network keeps dropping and coming back on its own
Can some one please update on the kind of problem.
is it hardware related or software?
can i resolve this on my own or have to go to company ?
 

Lokesh027

Member
Jan 27, 2013
49
18
Vadodara
Hi

I have been facing one irritating problem (on this otherwise wonderful phone) - the network keeps dropping and coming back on its own
Can some one please update on the kind of problem.
is it hardware related or software?
can i resolve this on my own or have to go to company ?

There are no reported issues with phone's Radio.
There would be issues with your network service provider. Activate 3g service will give you better reception.
Also you can try swapping both SIM.
 

aramosfet

Member
Aug 5, 2013
5
0
Headset Issue

Hi All,
I purchased the Xolo Q700 a week back. I just found out a possible issue with the stock headset provided with the phone.
First of all, Q700 uses a different standard for the headset-mic interface. hence regular android Headset/Mic don't work (search for CTIA vs OMTP headset standards). Q700 is follows OMTP standard. Most other brands such as LG follow CTIA.

Also noticed another issue, when the headset is plugged in during a call. The Microphone on the phone seems to be used instead of the Mic from headset. This is hard to realize since the Mic on the phone is good and the other person on the call doesn't hear any difference.

Can some one check if this is common to all Q700 phones or is specific to my phone? Here's what I did to check this.

You can call the Q700 phone with stock headset plugged in and leave it under a pillow or something. Then tap the headset mic. I don't hear anything on the other phone or a faint tap, But if I tap the Mic on Q700 at the bottom, I hear it very well.

Thanks,
 
Last edited:

ravisghosh

Senior Member
Jul 14, 2011
89
16
Hi All,
You can call the Q700 phone with stock headset plugged in and leave it under a pillow or something. Then tap the headset mic. I don't hear anything on the other phone or a faint tap, But if I tap the Mic on Q700 at the bottom, I hear it very well.

I can confirm this. The mic does not work. By the way, is there any other good compatible headset that gives better audio quality?
 

aramosfet

Member
Aug 5, 2013
5
0
I can confirm this. The mic does not work. By the way, is there any other good compatible headset that gives better audio quality?

Thanks for confirming, But I found a solution. The trick is to insert the headset very quickly. I think the problem is the phone checks for the mic before the connector is fully inserted.
One good thing is that the status bar shows two different icons for headphones and headset with mic. So we can make sure if the mic is detected or not.
Thank you,
 

draago

New member
Jan 11, 2013
1
0
ph got mad..work by itslf nd irritate me

hi all...i bought dis ph yestrdy..bt till nw i face this same problm twice..my ph wrk by itslf..this happns same whenevr i tried to txt sm1 it open a contct cl them menu gets opend..cant do nething..then i have to reboot my my then it comes to its norml position..ne1 facing the same problm??
plz gv me a solution.....
 
Last edited:

mailgopu

New member
Oct 4, 2013
2
0
Dual Standby SIM

Hi

I have been facing one irritating problem (on this otherwise wonderful phone) - the network keeps dropping and coming back on its own
Can some one please update on the kind of problem.
is it hardware related or software?
can i resolve this on my own or have to go to company ?


i get to understand that this is a problem with the Dual STANDBY SIM design of the Xolo Q700 and some other Xolo phones.. where there is only 1 network chip and therefore the phone does not permit both the SIM cards to be in use at the same time.. this surely affects the user on voice Calls, when while using one SIM the other SIM comes across as out of network..

similarly while using 3G, thanks to backend network discovery happening on both SIM, the chip altewrnates, thereby killing the 3G connection every now and then..

i am told again that this can be solved by software and an update to the phone could help.. Xolo does not update OTA, what you need to do is go to Xolo website and there they have an update download .zip file that you place in your SDCard and use Xolo Care App to make the update to your phone..

standard caveat is to backup all phone data, SMS, Call logs as the phone resets on update.. hope this helps..
 

YaduXGT

Senior Member
Apr 16, 2012
51
3
Bangalore
How to enable App to SD on Xolo Q700

Hey guys... I'm going to buy q700 this month probably this week... I've come to know that app to SD isn't supported and hence unable to install huge games like asphalt7 , most wanted etc...
Now I'm eager to know if its possible to enable App to SD(without creating an External partition on SD card) after rooting the device?
 
Last edited:

pranaylin

New member
Oct 11, 2013
1
0
3G Prob

Hi..In my Q700 ...3G service option is not showing under mobile network tab.

Can anyone help me out.

Thanks

i get to understand that this is a problem with the Dual STANDBY SIM design of the Xolo Q700 and some other Xolo phones.. where there is only 1 network chip and therefore the phone does not permit both the SIM cards to be in use at the same time.. this surely affects the user on voice Calls, when while using one SIM the other SIM comes across as out of network..

similarly while using 3G, thanks to backend network discovery happening on both SIM, the chip altewrnates, thereby killing the 3G connection every now and then..

i am told again that this can be solved by software and an update to the phone could help.. Xolo does not update OTA, what you need to do is go to Xolo website and there they have an update download .zip file that you place in your SDCard and use Xolo Care App to make the update to your phone..

standard caveat is to backup all phone data, SMS, Call logs as the phone resets on update.. hope this helps..
 

syshook

Member
Jul 28, 2013
5
1
Secunderabad
GPS Issue resolved

The phone does not come configured to use EPO Assistance data and as a result, GPS location fix just does not work out of the box. In fact, I stood under the open sky in hot sun for over 5 minutes and yet the GPS location could not fixed.

I followed the steps in this post and bam! The GPS fixation happened. It took over a minute but it happened.

My Karbonn A21 was able to determine GPS location in less than 10 seconds under open sky and in under 1 minute indoors. The Xolo Q700 does not do GPS fix while indoors at all.
ISSUE #1 - GPS DOES NOT WORK

Camera
In addition, my phone (purchased in Oct 2013) came with a software update applied that caused the camera app to show colour blocks when attempting to photograph in low light. The color blocks went away as soon the camera was pointed to a relatively well-lit scene. Fortunately, the images themselves came out correctly.

A recent OTA firmware from Xolo has fixed the camera color blocks problem also.

Battery
After the recent firmware update, the battery seems to die very quickly (in less than 2 days compared to 2 - 3 days before). Following another tip, I drained the battery completely and charged it fully. Now the battery meter is correctly (almost) showing the battery capacity. It still goes from 100% to 98% in less than 3 mintues, but seems to settle down when it reaches 80 - 85% and thereafter proceeds at a nice and slow pace. Battery life is more than 2.5 days with my average use (up-to 10 calls everyday, WiFi on for Email, WhatsApp, Battery managed by Xolo app).

The Xolo app switches the WiFi every 5 - 10 minutes to enables receipt of Email and WhatsApp updates, then it turns the WiFi off. I even have the "Device Info Live Wallpaper" active, display sleep is 1 minute and device lock is 30 minutes.

Xolo's customer care / repair procedure maybe questionable, but they are possibly the only Indian brand that are issuing regular firmware updates.
 

mansooralia

New member
Apr 29, 2007
1
0
hi all...i bought dis ph yestrdy..bt till nw i face this same problm twice..my ph wrk by itslf..this happns same whenevr i tried to txt sm1 it open a contct cl them menu gets opend..cant do nething..then i have to reboot my my then it comes to its norml position..ne1 facing the same problm??
plz gv me a solution.....
Hi,

Get an update from the settings-->About Phone-->Software update, this issue will go away.
 

musaiyabali

New member
Nov 22, 2013
1
0
External speaker not working

Hello guys,
My external speaker doesn't work, I have tried all tips on the thread but to no avail. Yesterday, I was on YouTube watching a video and suddenly the sound disappeared. Since then, I haven't heard anything from the speaker. Now, I have checked that this problem is only with the external speaker because when I plug the headphone in, I can hear everything. But I won't be wearing the headphones all the time, so this problem is worrying me. I won't be able to pick calls up etc.
So can you please help me ASAP.
Thanks
 

niranjan55

New member
Jan 30, 2014
1
0
Hi

I have been facing one irritating problem (on this otherwise wonderful phone) - the network keeps dropping and coming back on its own
Can some one please update on the kind of problem.
is it hardware related or software?
can i resolve this on my own or have to go to company ?

I am facing the exact same problem not sure if anyone has an solution for this. My network just goes and comes by itself.

Apart from that if i switch sim or add another sim it does not redily detect the network unless i reboot it 2-3 times not sure if the problem is similar. I have 64K sim.
 

am king

Member
Nov 12, 2012
11
0
Battery drops Suddenly

I have been using the xolo q700 for 6 months now everything is good except that for the past month the battery quickly drops from 40% to 15% in under 10 mins.....please help
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Hi folks,

    Xolo Q700 seems to be an amazing machine. In this thread, I'm trying to put across some of the problems I faced and solutions I found. Probably, this can be useful to some of us as well.

    ISSUE #1 - GPS DOES NOT WORK

    PROBLEM: Xolo Q700 would not use GPS Satellite to find location, only use mobile towers to triangulate.

    TESTING THE PROBLEM: Install GPS Test app from Google Play, turn on GPS, and hold the phone under open sky for couple minutes.

    TEST RESULT: GPS Test shows some satellite "in view" but none "in use".

    SOLUTION:
    Go to Settings>Location Access, and then turn on the following:
    Access to my location - Check (turn on)
    GPS Satellites - On
    Wi-Fi & mobile network location - Check (turn on)

    Tap on GPS Satellites and enable the following:
    GPS EPO assistance - Check (turn on)
    A-GPS - Check (turn on)

    Tap on GPS EPO assistance and enable the following:
    Auto Download - Check (turn on)

    TESTING THE SOLUTION:
    1. Install GPS Test app from Google Play, turn on GPS, and hold the phone under open sky for couple minutes.
    RESULT: GPS Test shows some satellite "in view" as well as "in use".

    2. Open maps and browse so that it caches some maps files. Now, put phone in Airplane mode and reboot. Start maps again and see if it shows the right location.
    RESULT: Location is pointed without sim connection. So, phone can be used as a GPS device as well without sim.

    ISSUE #1 - LOW AUDIO

    PROBLEM: Volume for ring, call, and speakers is quite low and often not audible in noisy places.

    SOLUTION:
    1. Enter Engineering Mode - Dial *#*#3646633#*#*
    2. Go to Hardware Testing>Audio>Normal Mode.
    3. Select "Sph" in type.
    4. Select "level 6" in Level.
    5. Enter 160 in value.
    6. Press Set.
    7. Restart the phone.

    If you want to increase your volume in all level then choose "level 0" in level and enter 160 in value.

    Some more tricks are given in the following link for zopo phones but would work for Q700 - http://www.zopomobileshop.com/zopo-...le-phone-mic-loudspeaker-and-ringtone-volume/

    I am not sure whether this actually works as I cannot find any perceptible change in volume. Is others can try and give some opinion and settings that work, it would be helpful.
    1
    Hi..In my Q700 ...3G service option is not showing under mobile network tab.

    Can anyone help me out.

    Thanks

    Check out for which sim you are trying to get 3g ? It is available only for SIm 1 . Generally 3g option is referred as WCDMA.
    1
    Please Help Bluetooth issue!!,:eek: rolleyes:

    Hello,I am unable to use my BT,i cant receive or send files sometimes it says "SD card full"error although I got around 1 gb of space left.lastly I m on MIUI rom and to note this issue I faced in all of the rom except for the stock q700 rom.PLS HLP ASAP.thnx
    1
    Anyone tried this..? battery-related thingy..

    Battery charging & discharging all seem to be ok.. the actual culprit seems to be the battery charge level indicator

    Why do i say so? :

    1.Switch off your phone & restart it manually( no reboot!) > there is no change or drop in battery level at all.

    2.Now immediately do a direct re-boot( from Power menu) > the battery level drops by at least 20% or more on restarting

    When phone has not been (auto-)re-booted at all , the phone gets charged from 0-100% without getting stuck anywhere.. also no battery heating issue.

    But if the phone has been auto-re-booted directly thru power menu or when some app does auto-restart (like i-font, Gbox etc) then as mentioned above in point 2 > battery level drops by ~20% or so
    & more importantly while charging, battery level goes steadily upto 75-80%. But after this point no matter how long you charge the phone, battery level % gets stuck and battery too seems to get hot. (..maybe charge lost in auto-restart causes this, not sure)

    At this point if you stop charging & manually (1st off , then turn it on) restart the phone , you will notice battery level increasing by 10-15% or even reaching the full 100% mark.

    So to avoid over-heating/swelling of battery: if battery level gets stuck at 75-85% while charging for more than 15 minutes, just switch off and turn on the phone again manually (..no auto restart!) > battery should show accurate power reading.

    Try it and lemme know if anyone finds any flaws in my theory. Also share if this helps in any way whatsoever..
    1
    try this

    Bro the above gps trick is not working, I'm on lewa os, can the rom be a problem? But others reported it to be bugfree, but pls help :(

    try this one.. worked for me:
    http://www.gizchina.com/2013/07/23/how-to-fix-poor-gps-on-mediatek-phones/