Xperia broken? red light under the ON button

Search This thread

renedis

Senior Member
Oct 19, 2006
293
143
In de stad
Guys, i think my xperia is broken :(

last night my battery was empty so no big deal i thought.
today i've connected it to the charger to charge and pressed the ON button.
when i pressed it, a red light under the ON button started burning.
i thought? wtf? mayby because it's emty or something.

but after more then 1 hour of charging it still doesn't do anything.. and now even the redlight doesn't show up!

does anyone know what to do?
 

SamAsQ

Member
Nov 10, 2008
47
0
Guys, i think my xperia is broken :(

last night my battery was empty so no big deal i thought.
today i've connected it to the charger to charge and pressed the ON button.
when i pressed it, a red light under the ON button started burning.
i thought? wtf? mayby because it's emty or something.

but after more then 1 hour of charging it still doesn't do anything.. and now even the redlight doesn't show up!

does anyone know what to do?

Hello dear friend, I sympathise with you :( I had this exact same problem and was worried sick for a day and a half that it was dead! the red light under the power button is the battery fail light (as far as i can tell) it goes on for example when you plug the charger in and remove the battery. I've found if you run the battery down to absolute minimum it almost seems like the X1 cant detect the battery any more and displays the red light. I fixed mine by removing and replacing the battery a few times and plugging it into the wall charger for a few hours. keep trying and dont lose heart, like I say it took me a day and a half (with a sleepless night inbetween ;)
 

Darth Sith

Senior Member
Jan 6, 2008
237
4
Also mine, but after five minutes it's wake up.
Try simply to remove battery, or performe a soft reset via hardware button with the stylus.
 

Wrekk

Senior Member
Oct 19, 2008
102
5
Let you X1 charge for an hour or 2 and it will start up again, guess this is when the phone don't get a enough power to start up.

(Guess it can indicate some other error as well but probably just lack of juice in the battery .. ):cool:
 

renedis

Senior Member
Oct 19, 2006
293
143
In de stad
thanks guys..
it is still not working but i know that the phone it self is OK.
i wend back to the store and they switched the battery from another xperia.
it worked fine :)

i'm so happy right now. it's charging at the moment, but still not going on, well, i have to wait and see then.

again: thanks for the posts guys
 

Br0kk0

Member
Oct 18, 2007
12
0
Nijmegen
Mind you... it might take a while! I had it connected to a cheap usb charger for a night (which wasn't good enough obviously) and it took me the better part of a morning to get it to life again with the SE charger. I find it most irritating that this sort of thing isn' t mentioned in the manual. At least not where I could find it. Things like a phone that doesn't want to start make you sweat horribly.:eek:
 

sean0r

Member
Dec 25, 2008
5
0
I have this problem with mine but still no luck :(

Been dead for weeks now.... Finding it hard to get a copy of the receipt too :( bah

Only had it a month too.. :(
 

McGilljam

Senior Member
Nov 7, 2008
116
0
Gävle
www.mcgilljam.com
It's prolly one cell in the battery that are "broken".

Had that on my X1. There are 3 cells in the battery and if one of them doesn't work as it should, the battery only delivers 3-3.1 volt.

Your phone "wakes up" at 3.335 volt but dies at 3.1. I've been measure it myself.

My phone are now back in business with a new battery, a new batterycover and latest software. No problem if you have guarantee...

PS... Try to avoid one thing. Avoid heat in battery. Lithium hates heat.
 
Last edited:

[email protected]

Senior Member
Feb 4, 2009
236
3
Rome
It's prolly one cell in the battery that are "broken".
Had that on my X1. There are 3 cells in the battery and if one of them doesn't work as it should, the battery only delivers 3-3.1 volt.
Your phone "wakes up" at 3.335 volt but dies at 3.1. I've been measure it myself.
My phone are now back in business with a new battery, a new batterycover and latest software. No problem if you have guarantee...
PS... Try to avoid one thing. Avoid heat in battery. Lithium hates heat.

You are right, man.
Usually, if you discharge a battery till the very last drop, it can happen that:
A) one of the cell goes beyond its safety level, and it "breaks". That's unrecoverable, AFAIK.
B) the cells gets unbalanced, and you nedd several charge/discharge cycles to get them balanced and fully recovered.

Add to this that Usb charging is usually unable to wake up an almost totally drained battery. This won't happen with a normal charger, but Usb charging voltage is lower than normal (of course, it's usb not home plug!) so it has not enough power to wake up the dead battery. If you leave your device in charge for some minutes, it will eventually manage to wake the battery.

However, I noticed that the X1 has a bad power management. Usually my X1 low level battery threshold varies between 10% and 5%. One week ago, at 10% it just shut down and won't recharge, showing me the red light over power button. Removed battery 3/4 times and charged with home charger, it gets recovered. Try to plug the charger, remove the battery and insert it again, doing all this with the charger always plugged.

In my opinion, that's really annoying, I never know when it *really* has a low battery!
 

Chaosstorm

Senior Member
Jan 27, 2009
244
0
@ [email protected]

B) the cells gets unbalanced, and you nedd several charge/discharge cycles to get them balanced and fully recovered.

yeah.. i had that with my P990i (symbian uiq3) phone the batter went in 1 day to 50% now it still has 80%
 

twisted

Senior Member
Mar 20, 2006
274
28
Sharjah, UAE
this same thing happend to me last night, i just pluged it to a wall charger & waited for an hour good thing when i pressed the power button it came back to life. was worried then and now its all good.
 

sharks182

Member
Feb 11, 2009
7
0
Red Power button Led

Glad to find this info, the red light gave me the chills at first too. My phone blacked out while using TomTom 7.4 on a stock unbranded NL Rom, after it had given me low batt. warnings. Now it's in the 'home plug' charger, sipping juice on the red light... I hope it comes out of it soon. Anyway, I was wondering if anybody has ideas on checking battery cell failure? Or battery diagnostics of some sort? It would be a shame to use a crippled battery just because you don't know it's operating below its max capacity. By the way, I'm not part of the lucky bunch in possession of a multi meter... :(

EDIT:
As soon as I hit 'post' the notification Led's display charging! And the red light's off of course. Guess the first post brings some beginners luck, hehe. Anyway, thoughts regarding battery diagnostics etc are still welcome!
 
Last edited:

ipporek

Senior Member
Jul 21, 2008
492
0
Encountered this and according to the helpdesk, it's cos the backup battery is empty so he advised me to charge the phone for half an hour without the battery, and then charge it with the battery after that. Didn't work. Called up the helpdesk again and he said for some, they've to charge (without the battery) for an hour. Ok, tried that. But still doesn't seem to be working. Gonna just leave it charging (with the battery) for a few more hours. If still can't guess I gotta bring it down to the service centre. :(
 

ipporek

Senior Member
Jul 21, 2008
492
0
Well, anyway, sent my X1 for servicing. Over at the service centre, they tried to 'boost my battery' but couldn't get it working. So had to leave it there for them to work on it.
 

ipporek

Senior Member
Jul 21, 2008
492
0
Sent my X1 to the service centre with regards to this issue and they replaced the motherboard. They'd tried boosting the battery but no use.
 

remyrz

Member
Aug 2, 2009
5
0
Same problem.. this is what happened

ok, I came back from work an as usually i plug the charger in my xperia, the baterry left was like 30%, ok, then, I connect in the 3.5mm an autput for a big Radio so i can listen full music... so.. in a while, in my house there was a power down.. really fast one... like... 0.01secs... (like down and up really fast).. in that change my cellphone went down =S.. and sice today never get up ='(... there's just that red light in the power button each time I plug the charger on... any help?.. is the same problem of the topic? :S.. plzzz.. i dont have even a month with this pretty cellphone =( poor baby
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Try new battery.... (Original) not fake. =)
    1
    Solution

    Plug the battery to an external wall charger,Let it charge there for an hour or 2 ,Then place it again in the phone & it starts to charge or the phone switches on...
    poor english,Hope u people understand
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone