Xperia Play (r800x) Total Wipe Help

Search This thread
Aug 9, 2013
Iowa Falls
Okay, so here's my story... I was goofing around with my inactive Xperia Play, trying to activate it on uPrepaid's network. I used ##7764726 to change the MIN and other settings, matching uPrepaid's settings in hopes that it would work. Alas, I was sorely mistaken. I've since shelved the device until StraightTalk brought out the Bring Your Own Phone plan. I did some research and found that my Xperia Play was eligible, so I bought the package. My Play was registered successfully and whatnot and activated on their end, but I can no longer make the *22890 call to activate my Play on my end, as I keep getting the uPrepaid activation hotline when I dial the number.

I tried doing a factory reset to no avail, I tried flashing a stock rom to the phone to no avail and I wasn't smart enough to write down all of the default values of the things I changed in the manual activation menu. SO... Does anyone have any idea as to what I can do to reset the phone ENTIRELY, including the MIN settings and everything? I need to be able to activate the phone on my end (through StraightTalk) but because of my goofing around, the activation call sends me to uPrepaid.

Any ideas? >_<

I would be most appreciative.