• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Xperia S not charging

Search This thread

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
so i bought yesterday my Xperia S, im pretty happy bla bla bla...

Now, my phone was branded with a carrier [Telcel] from México, so I found a tutorial to unbranding, flashing with flashtool a generic UK firmware....

First was charging normally, but after that the phone dont charge, i left it all the night and only gets to 50%, and now im putting bacj to the charger and its getting 1% - 4% and then go back to 1%, so anybody knows why happens this? how to solve it?

Thanks :D
 

gm007

Senior Member
May 29, 2011
7,831
4,501
OnePlus 8T
Does it charge offline??
Press volume up +power untill you feel 3 vibration that will reset and turn it off then try to charge again.
If you succeed to charge it you will have to flash another firmware.

Sent from my LT26i using Tapatalk 2
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
Well after all your recomendations, i do the power + volume combination technique, and a factory reset (now with Pc companion...), and the battery start to charge, now in 4 hours I get 80% LOL :confused: but i think that its discharging a little quick, in 4 hours unplugged battery is now 40% (and im not doing anything with the cellphone...) so tomorrow will go to the service and see what they can do... I hope they give me a new one ¬¬
 

netfrappe

Member
May 28, 2012
5
2
Hey friend ok i register at xda forum only for your issue :)

Ok look. Before year i buy my X10i it was and it is "the perfect device for its age". I had issue with battery like you. I did research here and there and ... I solve it with doing the following.

Charge the device to its max (until stop charging). Once is charged don't unplug the charge and remove the battery. wait 10sec and put it again. You will see that device will start charging again. Do that like 3-4 times for next 2-4 days and you will see improvement (at me).

From beginning my device battery was fully discharged in 15hours standby now it keep 2~3days .

Wish that help you a bit.

BR

Netfrappe
 
  • Like
Reactions: jacker60

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
Hey friend ok i register at xda forum only for your issue :)

Ok look. Before year i buy my X10i it was and it is "the perfect device for its age". I had issue with battery like you. I did research here and there and ... I solve it with doing the following.

Charge the device to its max (until stop charging). Once is charged don't unplug the charge and remove the battery. wait 10sec and put it again. You will see that device will start charging again. Do that like 3-4 times for next 2-4 days and you will see improvement (at me).

From beginning my device battery was fully discharged in 15hours standby now it keep 2~3days .

Wish that help you a bit.

BR

Netfrappe

Ohhh thanks for only register for that :D, well tonight i charge the device all noght again and it get 100% of the battery :D, the problem here is that in the Xperia S you cant remove the battery :(, right now im charging again and its a little annoying because the battery goes 1%... 2%..... 1%..... now its like 3% but it goes too slow......

I read that this device in half hour have to be charged almost to 100% isnt it???, because i think that 30 minutes i will get only 10% or something like that ¬¬, i was trying not to go to the technical service but i think that i will have to go :(
 

gm007

Senior Member
May 29, 2011
7,831
4,501
OnePlus 8T
Ohhh thanks for only register for that :D, well tonight i charge the device all noght again and it get 100% of the battery :D, the problem here is that in the Xperia S you cant remove the battery :(, right now im charging again and its a little annoying because the battery goes 1%... 2%..... 1%..... now its like 3% but it goes too slow......

I read that this device in half hour have to be charged almost to 100% isnt it???, because i think that 30 minutes i will get only 10% or something like that ¬¬, i was trying not to go to the technical service but i think that i will have to go :(

Did you tried another charger?? Maybe charge from your pc?
I hope you are not charging the phone while playing a game :D

Sent from my LT26i using Tapatalk 2
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
Soooooooooo continue with this sadness story... i go on tuesday afternoon to give the cellphone in the service center and they told me that they need to check it, so I say ok ok no problem, I go on Wednesday in the evening and they told me that the cellphone was without failure, that its charging and its ok, they told me that "upgrade" the system version (that its not true... its the same ¬¬) and well.... that be all, I made a question ... How many time take the phone to reach 80% (they are giving me with that charge) ???? and they told me: (with a face of surprise o_O) like 2 hours.... and I say: It's too much isn't it?, and the women said me that for this type of phones is normal..... so i want to make a question for you... how many time take your Xperia S to charge??? since 5~10% to 100%???? for me 2 hours to get 80% its a lot of time..... :confused:

Accordign to the respondes in here i will valorate to go again or leave it in that way....

BTW the cellphone its now charging but its too slowwww for me.... I plugged it at 12:30 am and still have 30% of battery, 40 minutes later its 47%.... :eek:
 
Last edited:

piafinho

Senior Member
Aug 9, 2009
69
11
How are you charging?
- Via USB or via power charger?
- Is Phone turned on?
- What temperature is the Phone? can be be hot? If it is hot the charging might be slower due to battery protection.
- Aren't there anything consuming battery? What do you see as main contributors in the Battery usage?
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
Well sorry for take a time to respond but i wanna try and wait a couple of weeks to come back XD :p

How are you charging?
- Via USB or via power charger?
- Is Phone turned on?
- What temperature is the Phone? can be be hot? If it is hot the charging might be slower due to battery protection.
- Aren't there anything consuming battery? What do you see as main contributors in the Battery usage?

- I have try both of them, via USB take a loooot to charge, and if I start to play even it starts to discharge.... x_X via power charger if im playig with it charges too slow... but charges, it takes 2 - 3 hours to get 100%, if I turn off the screen charges faster, but if i received a message or something the screen turns on and besides the brightness is almost minimal it seems that take more time to charge.....

- Yes its turned on, when its off it seems to charge faster but... well i'm off like 2 hours for all my friends or family :p

- Its cold indeed, right now its charging and its cold, not heat at all

- The main contributors are:

the screen... obvisuly :( 56%
Android system 12%
cellphone in wait 12%
standby phone 6%
wifi 5%
facebook 3%
and mcafee 2%

:p as you can see nothing strange

I dont have brightness to 100% its like 30% when its on and only wifi turn on

So i want to ask again to you, how many time take your Xperia S to take 100% of charge??? its normal this behavior...?
 

Mysteryos

Member
Jun 18, 2012
32
3
port-louis
Well sorry for take a time to respond but i wanna try and wait a couple of weeks to come back XD :p



- I have try both of them, via USB take a loooot to charge, and if I start to play even it starts to discharge.... x_X via power charger if im playig with it charges too slow... but charges, it takes 2 - 3 hours to get 100%, if I turn off the screen charges faster, but if i received a message or something the screen turns on and besides the brightness is almost minimal it seems that take more time to charge.....

- Yes its turned on, when its off it seems to charge faster but... well i'm off like 2 hours for all my friends or family :p

- Its cold indeed, right now its charging and its cold, not heat at all

- The main contributors are:

the screen... obvisuly :( 56%
Android system 12%
cellphone in wait 12%
standby phone 6%
wifi 5%
facebook 3%
and mcafee 2%

:p as you can see nothing strange

I dont have brightness to 100% its like 30% when its on and only wifi turn on

So i want to ask again to you, how many time take your Xperia S to take 100% of charge??? its normal this behavior...?

For me, it takes two hours. That's without me using it during the charge period, wifi/data/bluetooth off.

One question: which charger do you have? EP800 or EP850/851?
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
For me, it takes two hours. That's without me using it during the charge period, wifi/data/bluetooth off.

One question: which charger do you have? EP800 or EP850/851?

2 hours well it seems to be "normal" then, i will have to turn all off and see how much time takes... for me its too much i get used to have my mini pro (sk17a) get charge in 1 hour 30 mins :eek: or even less with the screen turn on and wifi & bluetooth on too :confused:

I have EP800, seems that EP850 only its given in a few markets, México its not the case :mad:
 

zlotvor

Member
Sep 19, 2007
39
3
Hahahahahahaha yes that sound like a solution, but I have 2 chargers so I think that's no the problem :(

Sent from my LT26i using XDA

You said that service guys tested the phone and it is ok, and you tested the two chargers with another device, right?

If yes, change your charger cable with another one. Try to use brand new, they are not to expensive. And try to find some brand name cable like Samsung or Nokia.

Sent from my LT26i using xda premium
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
You said that service guys tested the phone and it is ok, and you tested the two chargers with another device, right?

If yes, change your charger cable with another one. Try to use brand new, they are not to expensive. And try to find some brand name cable like Samsung or Nokia.

Sent from my LT26i using xda premium

I have 2 chargers, and 3 cables :p, one from my xperia mini, one that i bought from ebay (want to have one in the car for emergencies of a dead battery) and a new one that come with the S.... I'm using the one I bought and the xperia mini.... maybe thats the cause but i really doubt it...
 

XperiaPuser

New member
Oct 13, 2012
2
0
Same issue on Xperia P

I have a similar issue on my new Xperia P since day 1. When I charge my phone using the charger, it charges upto 50% +/- 5%. It will not go beyond that even if the charger is connected for hours. If I charge it from a PC through USB it goes to 100% without any issues. Also, if I charge it through the charger with the phone turned OFF, it charges 100%. So this appears to be a software related issue and not something to do with the charger.

Any suggestions?

*My phone is currently on ICS. Though the issue existed even with GB.
 

jacker60

Senior Member
Oct 18, 2010
274
97
Distrito Federal
Well, let it pass a week and lets see what happen, mine fixes by itself, now just take 1 hour and a half to charge it :), but in the beginning was a pain in the ass

Sent from my LT26i using xda app-developers app
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hey friend ok i register at xda forum only for your issue :)

    Ok look. Before year i buy my X10i it was and it is "the perfect device for its age". I had issue with battery like you. I did research here and there and ... I solve it with doing the following.

    Charge the device to its max (until stop charging). Once is charged don't unplug the charge and remove the battery. wait 10sec and put it again. You will see that device will start charging again. Do that like 3-4 times for next 2-4 days and you will see improvement (at me).

    From beginning my device battery was fully discharged in 15hours standby now it keep 2~3days .

    Wish that help you a bit.

    BR

    Netfrappe