Xperia Z2 autofocus not working, at all.

Search This thread

pascalbrax

Senior Member
Nov 15, 2010
145
160
So, hi guys.

I just came home with my new Z2 after giving back my Z.

I downloaded the german ftf and the new flashtool for the Z2 and updated to this firmware.

I'm really not sure if this is related to the firmware update but I don't think so.

My issue is quite simple: the camera autofocus doesn't work. It just simply has a fixed focus (which works great for the near stuff but 100% fails for all other distances).

It's not a slow autofocus, it just doesn't work, the camera doesn't move, you don't hear any focusing noise. the camera button doesn't focus, tap on the screen doesn't focus.

Basically all my pictures and my videos have an amazing quality, but are all out of focus.

I googled around but looks like nobody has this issue. Is that fatal? Should I return it?
 

Envious_Data

Senior Member
Oct 12, 2012
4,869
2,280
Imagination
enviousmedia.design
So, hi guys.

I just came home with my new Z2 after giving back my Z.

I downloaded the german ftf and the new flashtool for the Z2 and updated to this firmware.

I'm really not sure if this is related to the firmware update but I don't think so.

My issue is quite simple: the camera autofocus doesn't work. It just simply has a fixed focus (which works great for the near stuff but 100% fails for all other distances).

It's not a slow autofocus, it just doesn't work, the camera doesn't move, you don't hear any focusing noise. the camera button doesn't focus, tap on the screen doesn't focus.

Basically all my pictures and my videos have an amazing quality, but are all out of focus.

I googled around but looks like nobody has this issue. Is that fatal? Should I return it?

This sounds like a hardware fault, try getting a replacement

The german 402FTF worked fine for me its my device faults is why im returning my phone on wednesday and getting a new one on monday

Sent from my D6503 using XDA Premium 4 mobile app
 
  • Like
Reactions: pascalbrax
X

x102x96x

Guest
i

So, hi guys.

I just came home with my new Z2 after giving back my Z.

I downloaded the german ftf and the new flashtool for the Z2 and updated to this firmware.

I'm really not sure if this is related to the firmware update but I don't think so.

My issue is quite simple: the camera autofocus doesn't work. It just simply has a fixed focus (which works great for the near stuff but 100% fails for all other distances).

It's not a slow autofocus, it just doesn't work, the camera doesn't move, you don't hear any focusing noise. the camera button doesn't focus, tap on the screen doesn't focus.

Basically all my pictures and my videos have an amazing quality, but are all out of focus.

I googled around but looks like nobody has this issue. Is that fatal? Should I return it?

Xperia and almost all smartphones have digital focus
there s no special hardware for zooming
SO if you have problem in one feature of camera App do this;
- use another camera app : for example google camera and check if it can do auto focus
- install another firmware or just reinstall current firmware
- repair firmware by PCC
- after these IF sill thr s no auto focus >> take it to sony service
:good:
 

pascalbrax

Senior Member
Nov 15, 2010
145
160
This sounds like a hardware fault, try getting a replacement

The german 402FTF worked fine for me its my device faults is why im returning my phone on wednesday and getting a new one on monday

Is your device faulty, too?

Thanks, I'll get a replacement today, I hope...


Xperia and almost all smartphones have digital focus
there s no special hardware for zooming

Autofocus and (digital) zoom are two different things.
 

Mastno

New member
May 17, 2015
1
0
Got the same Problem as you i have cyanogenmod 12.1 and my autofocus doesn't work as well on my z2. It worked with the stock Rom but after i unlocked, rooted and flashed CM on it, the autofocus doesn't work anymore. I Tried other camera apps but the AF just won't work. Have you solved the Problem yet? I'm considering to flash back to stock Rom but CM is so awesome :p
 

Skriptkiddie

Member
Jun 13, 2014
10
1
Got the same Problem as you i have cyanogenmod 12.1 and my autofocus doesn't work as well on my z2. It worked with the stock Rom but after i unlocked, rooted and flashed CM on it, the autofocus doesn't work anymore. I Tried other camera apps but the AF just won't work. Have you solved the Problem yet? I'm considering to flash back to stock Rom but CM is so awesome :p

I can confirm that the focus button doesn't work on CM12.1 on my Z2 and the focus state doesn't work on the Google camera app, but I found an app that makes use of this autofocus feature - DSLR Camera Pro. The only downside to it, however, is that you can only take photos with it, and plus it's a paid app (but was worth it). Maybe there are other apps that can detect this autofocus, but I haven't researched this problem fully.
 

SacredSkill

New member
Jun 25, 2016
2
0
Same issue except it won't even take photos and just sits there trying to focus.

The only fix is to revert to the previous official OS if you think it's worth it...
 

sublinker

Senior Member
Mar 26, 2013
290
193
Cape Coast
I hate necro-ing, but I have this last described problem too. Phone tries to focus, and the app stays that way forever.
I thought it was the result of restoring a TWRP backup from another phone, but resetting anything camera-related does not solve the problem.
Current config: Z2 system, Z3 Compact data

Hitting the top part of the phone where camera module is located with the back of my finger helped. This happened to me after flashing a camera mod.
It's now working without problems
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    So, hi guys.

    I just came home with my new Z2 after giving back my Z.

    I downloaded the german ftf and the new flashtool for the Z2 and updated to this firmware.

    I'm really not sure if this is related to the firmware update but I don't think so.

    My issue is quite simple: the camera autofocus doesn't work. It just simply has a fixed focus (which works great for the near stuff but 100% fails for all other distances).

    It's not a slow autofocus, it just doesn't work, the camera doesn't move, you don't hear any focusing noise. the camera button doesn't focus, tap on the screen doesn't focus.

    Basically all my pictures and my videos have an amazing quality, but are all out of focus.

    I googled around but looks like nobody has this issue. Is that fatal? Should I return it?

    This sounds like a hardware fault, try getting a replacement

    The german 402FTF worked fine for me its my device faults is why im returning my phone on wednesday and getting a new one on monday

    Sent from my D6503 using XDA Premium 4 mobile app
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone