[XperiaXZ]Cannot unlock bootloader, flash and etc

Search This thread


Oct 5, 2022
Hi everyone. I am trying to unbrick my Xperia XZ. I tried a lot during these 3 days. Guess I need help.

Here's what happened and actions I took. I can upload screenshots, but I am very exhausted now, and considering you have more knowledge about this topic than me, I don't upload screenshots.

Phone's charge went 0%. I tried to charge it via wallcharger. But stuck on Sony Logo.
Tried ADB Fastboot, flashtool, Xperia Companion, Emma to flash it with stock rom.
Emma says this phone is locked.
Xperia Companion gives error at approx 25%.
Fastboot commands doesn't work. Cannot unlock bootloader via fastboot. remote: 'Command not allowed'. (I can only manage to run fastboot devices command. Cannot even install twrp).
Tried unlocking bootloader via BLU, it stucks at Unlock code saved to C:\......

I tried flash 3 different roms, always stuck at Closing TA Partition after Opening Ta Partition 2. Not even 5% of process.

Fastboot Toolbox
Select Kernel to HotBoot - Only way I got screen besides Sony logo. And it says Your device has failed verification and will not work properly.
Select system to Flash - When I choose boot.img or kernel.sin it says remote: 'Command not allowed' as in fastboot.
Select Kernel to Flash - 'Command not allowed'

The only thing comes to my mind is enabling OEM unlocking and debugging mode. But since I cannot boot my device up, I cannot do these either.
I tried execute fastboot oem unlock via adb fastboot cmd, again I got Command not Allowed.

Thanks for attention.


Oct 5, 2022
ADB and Fastboot are two complety different softwares: ADB deals with Android OS, whereas Fastboot deals with device's bootloader. :)

Do you use USB drivers provided / supported by Sony?
I meant I tried cmd thing in the folder called Minimal_adb_fastboot

And yes, I have tried lots of different drivers, either sony or adb drivers. Computer sees the device. And by the way, I have tried on different computers and with different cables, nothing changed.