• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Xposed install guide

Search This thread

Liffeyman

Senior Member
Feb 13, 2013
334
102
Dublin
Hi all,

First off, backup everything and you do this at your own risk!
Okay, so you'll need a unlocked bootloader, twrp recovery and a rooted system with supersu installed.
Download the following

http://forum.xda-developers.com/attachment.php?attachmentid=3383776&d=1435601440
http://dl-xda.xposed.info/framework/sdk23/arm64/xposed-v83-sdk23-arm64.zip

Install XposedInstaller_3.0_alpha4.apk
Open SuperSU and leave it running in the background. Open Xposed app, click on framework and select soft reboot. You should now get a popup from SuperSU requesting access from the xposed app.
After reboot, browse to the following location. / system / EMUI / base / prop , open the local.prop file and locate the line "ro.config.hwtheme = 1". Once you have located the line, change from 1 to 0. Save the file and reboot to twrp recovery.
Install the xposed-v83-sdk23-arm64.zip, once installed click on wipe Dalvik cache.

Reboot and test.
The first reboot after the install can take up to 10 mins, don't panic its normal!

You can update to the latest version of xposed-v85-sdk23-arm64.zip after this, but for whatever reason v85 doesn't work when installing first.

Cheers,
Paul
 
Last edited:
  • Like
Reactions: imrock

Etilas

Member
Aug 31, 2008
31
2
Hi,
Thx for this!
I've a question: is it possible to use Xposed but to have possibility to change theme?
Because with "ro.config.hwtheme = 0" the theme app is down (normal i think) but the theme is ..... not very pretty :/

Thanks, sorry for my english!
 

buddimanv

Senior Member
Apr 19, 2015
109
14
The setting does not work intermittently, won't load, tried on two Honor 5c so far, latest version as well as xposed-v85.1-sdk23-arm64-custom-build-by-wanam-20160530.zip - a reboot fixes but may be other issues as only had the phone for a week or so. Any solution?
 

hackslash

Recognized Contributor
Feb 20, 2015
1,249
1,522
23
Islamabad
Redmi K20 Pro
There is no need to disable Huawei Theme Engine. Just flash Xposed v86 (or any version later than 86) and you're good to go. No build.prop and local.prop edits needed.
 

Mike_Wasawsky

Senior Member
Apr 2, 2011
56
15
London
The setting does not work intermittently, won't load, tried on two Honor 5c so far, latest version as well as xposed-v85.1-sdk23-arm64-custom-build-by-wanam-20160530.zip - a reboot fixes but may be other issues as only had the phone for a week or so. Any solution?

I had exactly the same problem, and to make it even worst I was having crashes when trying to call someone and also unable to receive calls. Sometimes a reboot would fix the situation but then it was back again. Are you facing the same problems with newer versions of xposed?
@Liffeyman Could you update the thread to the most recent xposed and installer? And also the change of the value inside the file is not needed anymore. Check this thread https://forum.xda-developers.com/android/general/guide-workaround-running-xposed-t3338765/
 

buddimanv

Senior Member
Apr 19, 2015
109
14
Mike_Wasawsky, didn't notice any other issues but settings won't launch - it was also the case with p9 lite. However, I am currently using Xposed framework 86.1 (custom build by wanam / 20160904) on build NEM-L51C432B120 and settings works most of the time if not all the time (I think I had to reboot once, not sure whether it was p9 Lite or 5c). Same version is also on a p9 lite and working OK. I would advise you to use latest Wanam build.
 
  • Like
Reactions: Mike_Wasawsky

Mike_Wasawsky

Senior Member
Apr 2, 2011
56
15
London
Mike_Wasawsky, didn't notice any other issues but settings won't launch - it was also the case with p9 lite. However, I am currently using Xposed framework 86.1 (custom build by wanam / 20160904) on build NEM-L51C432B120 and settings works most of the time if not all the time (I think I had to reboot once, not sure whether it was p9 Lite or 5c). Same version is also on a p9 lite and working OK. I would advise you to use latest Wanam build.
Do you have a link to that version? I couldn't find it. Thanks!
 

Mike_Wasawsky

Senior Member
Apr 2, 2011
56
15
London

Thank you very much. I tried it anyway and I'm having the same issues.
I've been exploring this situation and realised that the problem wasn't specifically Xposed, but some of the modules.

I always use Youtube background, Youtube adAway and xInternalSD. Only installing youtube background it goes fine, but when I activate one of the others or both of them the problem starts again, randomly crashes settings and I can not make or receive calls, because the call app crashes too. :/
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi all,

    First off, backup everything and you do this at your own risk!
    Okay, so you'll need a unlocked bootloader, twrp recovery and a rooted system with supersu installed.
    Download the following

    http://forum.xda-developers.com/attachment.php?attachmentid=3383776&d=1435601440
    http://dl-xda.xposed.info/framework/sdk23/arm64/xposed-v83-sdk23-arm64.zip

    Install XposedInstaller_3.0_alpha4.apk
    Open SuperSU and leave it running in the background. Open Xposed app, click on framework and select soft reboot. You should now get a popup from SuperSU requesting access from the xposed app.
    After reboot, browse to the following location. / system / EMUI / base / prop , open the local.prop file and locate the line "ro.config.hwtheme = 1". Once you have located the line, change from 1 to 0. Save the file and reboot to twrp recovery.
    Install the xposed-v83-sdk23-arm64.zip, once installed click on wipe Dalvik cache.

    Reboot and test.
    The first reboot after the install can take up to 10 mins, don't panic its normal!

    You can update to the latest version of xposed-v85-sdk23-arm64.zip after this, but for whatever reason v85 doesn't work when installing first.

    Cheers,
    Paul
    1
    Mike_Wasawsky, didn't notice any other issues but settings won't launch - it was also the case with p9 lite. However, I am currently using Xposed framework 86.1 (custom build by wanam / 20160904) on build NEM-L51C432B120 and settings works most of the time if not all the time (I think I had to reboot once, not sure whether it was p9 Lite or 5c). Same version is also on a p9 lite and working OK. I would advise you to use latest Wanam build.